editors/cooledit: Update 3.17.17 -> 3.17.25

Port changes:
* Change to DISTVERSION
* Add LICENSE/LICENSE_FILE
* Fix misspeling in the CONFIGURE_ENABLE for the NEXT_LOOK option
* Add ifdef guarding against non-existing I_PUSH ioctl value
* Regenerate other patches because portlint said they weren't properly generated
* Remove nls translation files (.mo) because they were deleted in configure with
  the note that they weren't maintained

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2018-05-06 18:14:42 +00:00
parent ca0bf13f58
commit 852a8ad094
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=469243
7 changed files with 26 additions and 38 deletions

View File

@ -2,15 +2,17 @@
# $FreeBSD$
PORTNAME= cooledit
PORTVERSION= 3.17.17
PORTREVISION= 11
DISTVERSION= 3.17.25
CATEGORIES= editors
MASTER_SITES= SUNSITE/apps/editors/X/cooledit
MAINTAINER= ports@FreeBSD.org
COMMENT= Suite of utilities, including a GUI editor
USES= gettext gmake libtool python
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gettext gmake libtool python # gettext is linked to despite .mo files having been deleted
GNU_CONFIGURE= yes
USE_XORG= x11 xt
USE_LDCONFIG= yes
@ -23,7 +25,7 @@ CFLAGS+= -DHAVE_MBRTOWC
OPTIONS_DEFINE= NEXT_LOOK
NEXT_LOOK_DESC= Enable NeXT look
NEXT_CONFIGURE_ENABLE= NeXT-look
NEXT_LOOK_CONFIGURE_ENABLE= NeXT-look
post-patch:
@${REINPLACE_CMD} -e 's|po pixmap man|po man|g' ${WRKSRC}/Makefile.in

View File

@ -1,2 +1,3 @@
SHA256 (cooledit-3.17.17.tar.gz) = 3c0d95d409796e3d92405e8ec317acb040713b432cc9ff9742f8657c092be489
SIZE (cooledit-3.17.17.tar.gz) = 1674273
TIMESTAMP = 1525627067
SHA256 (cooledit-3.17.25.tar.gz) = c24b437ae7f9861133559e58191af73fa1ebd48cc8933ef588ed41d71e839b3a
SIZE (cooledit-3.17.25.tar.gz) = 1371155

View File

@ -1,5 +1,5 @@
--- rxvt/_rxvtlib.h.orig 2010-05-26 21:25:41.000000000 -0400
+++ rxvt/_rxvtlib.h 2010-05-26 21:39:11.000000000 -0400
--- rxvt/_rxvtlib.h.orig 2017-07-14 16:03:54 UTC
+++ rxvt/_rxvtlib.h
@@ -128,7 +128,7 @@
#ifdef TTY_GID_SUPPORT
# include <grp.h>

View File

@ -1,11 +1,11 @@
--- rxvt/rxvtlib_command.c.orig 2005-04-04 20:47:45.000000000 +0000
--- rxvt/rxvtlib_command.c.orig 2017-04-24 20:06:43 UTC
+++ rxvt/rxvtlib_command.c
@@ -385,7 +385,7 @@ int rxvtlib_get_tty (rxvtlib
o->killed = EXIT_FAILURE | DO_EXIT;
return -1;
}
-#ifdef PTYS_ARE_PTMX
+#if defined(PTYS_ARE_PTMX) && !defined(__DragonFly__)
+#if defined(PTYS_ARE_PTMX) && !defined(__FreeBSD__) && !defined(__DragonFly__)
/*
* Push STREAMS modules:
* ptem: pseudo-terminal hardware emulation module.

View File

@ -1,6 +1,6 @@
--- widget/coollocal.h.orig 2007-11-02 00:37:50.000000000 +0100
+++ widget/coollocal.h 2007-11-02 00:45:22.000000000 +0100
@@ -49,7 +49,6 @@
--- widget/coollocal.h.orig 2018-04-24 22:04:24 UTC
+++ widget/coollocal.h
@@ -51,7 +51,6 @@ CWidget *allocate_widget (Window newwin,
int eh_picture (struct cool_widget *w, XEvent * xevent, CEvent * cwevent);
void drawstring_xy (Window win, int x, int y, const char *text);
void drawstring_xy_hotkey (Window win, int x, int y, const char *text, int hotkey);

View File

@ -1,6 +1,6 @@
--- widget/widechar.c.orig Sat Nov 27 17:46:03 2004
+++ widget/widechar.c Wed Dec 15 01:17:59 2004
@@ -227,6 +227,7 @@
--- widget/widechar.c.orig 2017-08-04 19:12:31 UTC
+++ widget/widechar.c
@@ -227,6 +227,7 @@ static inline struct mb_rule apply_mb_ru
static inline struct mb_rule apply_mb_rules_going_right (WEdit * edit, long byte_index, struct mb_rule mb_rule)
{
#ifdef HAVE_WCHAR_H
@ -8,11 +8,11 @@
wchar_t wc;
unsigned char p[16];
int n;
@@ -252,6 +253,7 @@
}
@@ -253,6 +254,7 @@ static inline struct mb_rule apply_mb_ru
mb_rule.end = 0;
mb_rule.ch = -1;
+#endif
#endif
+#endif
return mb_rule;
}

View File

@ -7,6 +7,9 @@ lib/libCw.a
lib/libCw.so
lib/libCw.so.1
lib/libCw.so.1.0.0
man/man1/cooledit.1.gz
man/man1/coolman.1.gz
man/man1/smalledit.1.gz
%%DATADIR%%/c_utils.py
%%DATADIR%%/global.py
%%DATADIR%%/sh_utils.py
@ -20,6 +23,7 @@ lib/libCw.so.1.0.0
%%DATADIR%%/syntax/html.syntax
%%DATADIR%%/syntax/jasm.syntax
%%DATADIR%%/syntax/java.syntax
%%DATADIR%%/syntax/js.syntax
%%DATADIR%%/syntax/latex.syntax
%%DATADIR%%/syntax/lsm.syntax
%%DATADIR%%/syntax/lsm4.syntax
@ -43,22 +47,3 @@ lib/libCw.so.1.0.0
%%DATADIR%%/syntax/texinfo.syntax
%%DATADIR%%/syntax/unknown.syntax
%%DATADIR%%/syntax/xml.syntax
share/locale/cs/LC_MESSAGES/cooledit.mo
share/locale/da/LC_MESSAGES/cooledit.mo
share/locale/de/LC_MESSAGES/cooledit.mo
share/locale/es/LC_MESSAGES/cooledit.mo
share/locale/fi/LC_MESSAGES/cooledit.mo
share/locale/fr/LC_MESSAGES/cooledit.mo
share/locale/it/LC_MESSAGES/cooledit.mo
share/locale/ja/LC_MESSAGES/cooledit.mo
share/locale/ko/LC_MESSAGES/cooledit.mo
share/locale/nl/LC_MESSAGES/cooledit.mo
share/locale/no/LC_MESSAGES/cooledit.mo
share/locale/pl/LC_MESSAGES/cooledit.mo
share/locale/pt/LC_MESSAGES/cooledit.mo
share/locale/ru/LC_MESSAGES/cooledit.mo
share/locale/sl/LC_MESSAGES/cooledit.mo
share/locale/sv/LC_MESSAGES/cooledit.mo
man/man1/cooledit.1.gz
man/man1/coolman.1.gz
man/man1/smalledit.1.gz