MFH: r560033

devel/cvs: remove libgnuregex dependency.

The only usage of regular expression in cvs was in import.c, and for
that particular usage, no GNU extension was used; with the removal of
libgnuregex, we could just drop the dependency and use the base system
regex(3) instead.

This fixes build on -CURRENT.

PR:		252248
Approved by:	portmgr (build fix blanket)
This commit is contained in:
Xin LI 2021-01-03 19:22:37 +00:00
parent c13614488e
commit 85189b3c2f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=560034
3 changed files with 33 additions and 6 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= cvs
PORTVERSION= 1.20120905
PORTREVISION?= 6
PORTREVISION?= 7
CATEGORIES= devel
MASTER_SITES= LOCAL/eadler

View File

@ -1,8 +1,13 @@
--- ../cvs-build/cvs/Makefile.orig 2012-09-06 06:25:43.000000000 +0400
+++ ../cvs-build/cvs/Makefile 2014-07-15 12:37:28.000000000 +0400
@@ -32,7 +32,7 @@
DPADD= ${LIBCVS} ${LIBDIFF} ${LIBGNUREGEX} ${LIBMD} ${LIBCRYPT} ${LIBZ}
LDADD= ${LIBCVS} ${LIBDIFF} -lgnuregex -lmd -lcrypt -lz
--- ../cvs-build/cvs/Makefile.orig 2012-09-05 19:25:43.000000000 -0700
+++ ../cvs-build/cvs/Makefile 2021-01-02 17:11:22.159883000 -0800
@@ -29,10 +29,10 @@
-I/usr/include/gnu \
-I${CVSDIR}/lib -I${CVSDIR}/diff -I.
-DPADD= ${LIBCVS} ${LIBDIFF} ${LIBGNUREGEX} ${LIBMD} ${LIBCRYPT} ${LIBZ}
-LDADD= ${LIBCVS} ${LIBDIFF} -lgnuregex -lmd -lcrypt -lz
+DPADD= ${LIBCVS} ${LIBDIFF} ${LIBMD} ${LIBCRYPT} ${LIBZ}
+LDADD= ${LIBCVS} ${LIBDIFF} -lmd -lcrypt -lz
-.if ${MK_KERBEROS_SUPPORT} != "no"
+.if defined(KERBEROS_SUPPORT)

View File

@ -0,0 +1,22 @@
--- ../cvs-build/lib/Makefile.orig 2012-09-05 19:19:41.000000000 -0700
+++ ../cvs-build/lib/Makefile 2021-01-02 17:10:09.173277000 -0800
@@ -11,9 +11,7 @@
LIB= cvs
INTERNALLIB=
-# gnu must be before lib to pick correct regex.h
-CFLAGS+= -I. -I${CVSDIR}/src -I/usr/include/gnu \
- -I${CVSDIR}/lib
+CFLAGS+= -I. -I${CVSDIR}/src -I${CVSDIR}/lib
CFLAGS+= -DHAVE_CONFIG_H
YFLAGS=
CLEANFILES+= config.h
@@ -23,7 +21,7 @@
CVS_TMPDIR_DFLT?= /tmp
SRCS= config.h argmatch.c getdate.y getline.c \
- getopt.c getopt1.c savecwd.c \
+ getopt.c getopt1.c regex.c savecwd.c \
sighandle.c stripslash.c \
xgetwd.c yesno.c