MAINTAINER's update

1. Fixed PostScript display error (has appeared with newer version of GS)
2. Put variables in order.
This commit is contained in:
Yoshio MITA 2002-01-19 03:31:35 +00:00
parent 5dc8cfe863
commit 84fc70b00e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53317
2 changed files with 27 additions and 25 deletions

View File

@ -7,12 +7,13 @@
PORTNAME= vfxdvi
PORTVERSION= 17
PKGNAMESUFFIX= ${RESOLUTION}
PORTREVISION= 1
CATEGORIES= japanese print
MASTER_SITES= ${MASTER_SITE_PORTS_JP} \
ftp://ftp.hipecs.hokudai.ac.jp/pub/news-archive/fj.comp.texhax/volume95/Sep/ \
ftp://ftp.hipecs.hokudai.ac.jp/pub/news-archive/fj.comp.texhax/volume95/Oct/ \
ftp://ftp.hipecs.hokudai.ac.jp/pub/news-archive/fj.comp.texhax/volume95/Nov/
PKGNAMESUFFIX= ${RESOLUTION}
DISTNAME= xdvi-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
xdvi-${PORTVERSION}miyu.patch-beta6.gz \
@ -21,6 +22,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
951007.02.Z \
951109.04.Z
DIST_SUBDIR= xdvi
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= mita@FreeBSD.org
@ -30,7 +32,6 @@ RUN_DEPENDS= ${LOCALBASE}/lib/fonts/pk${RESOLUTION}:${PORTSDIR}/print/pkfonts${R
NO_WRKSUBDIR= yes
USE_IMAKE= yes
XMKMF= xmkmf
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAN1= xdvi.1
@ -60,17 +61,17 @@ pre-patch:
cd tmp; \
${PATCH} -f < ../xdvi18.vflib.patch >/dev/null 2>&1; \
cd .. ; \
${GZCAT} ${DISTDIR}/${DIST_SUBDIR}/xdvi-${PORTVERSION}miyu.patch-beta6.gz | patch -d . >/dev/null 2>&1; \
${GZCAT} xdvi-pl${PORTVERSION}+markpage+toc+printdvi+paper.patch.gz | patch -d . >/dev/null 2>&1 ; \
${GZCAT} ${DISTDIR}/${DIST_SUBDIR}/xdvi-${PORTVERSION}miyu.patch-beta6.gz | ${PATCH} -d . >/dev/null 2>&1; \
${GZCAT} xdvi-pl${PORTVERSION}+markpage+toc+printdvi+paper.patch.gz | ${PATCH} -d . >/dev/null 2>&1 ; \
${PATCH} -d . < xdvi-${PORTVERSION}+ptex.fixed.patch >/dev/null 2>&1; \
${CP} tmp/dnpzeit.c tmp/zeit.c . ; \
)
post-patch:
.if defined(BATCH)
@(cd ${WRKDIR}; sh ${FILESDIR}/customize.sh ${RESOLUTION} BATCH)
@(cd ${WRKDIR}; ${SH} ${FILESDIR}/customize.sh ${RESOLUTION} BATCH)
.else
@(cd ${WRKDIR}; sh ${FILESDIR}/customize.sh ${RESOLUTION})
@(cd ${WRKDIR}; ${SH} ${FILESDIR}/customize.sh ${RESOLUTION})
.endif
.include <bsd.port.mk>

View File

@ -1,22 +1,23 @@
*** gs-view.c.orig Sat Jan 13 18:33:59 1996
--- gs-view.c Sat Jan 13 18:34:19 1996
***************
*** 126,132 ****
#ifdef PS_LITERAL
fflush(temp_ps_file);
! lseek(fileno(temp_ps_file), 0L, SEEK_SET);
#endif /* PS_LITERAL */
{
--- 126,132 ----
#ifdef PS_LITERAL
fflush(temp_ps_file);
! lseek(fileno(temp_ps_file), (off_t)0, SEEK_SET);
#endif /* PS_LITERAL */
{
--- gs-view.c.orig Sat Jan 19 12:06:41 2002
+++ gs-view.c Sat Jan 19 12:10:26 2002
@@ -126,7 +126,7 @@
#ifdef PS_LITERAL
fflush(temp_ps_file);
- lseek(fileno(temp_ps_file), 0L, SEEK_SET);
+ lseek(fileno(temp_ps_file), (off_t)0, SEEK_SET);
#endif /* PS_LITERAL */
{
@@ -208,7 +208,7 @@
for (p = ps_headers; p != NULL; p = p->next)
argv[i++] = p->psheader;
#endif /* PS_HEADER */
- argv[i++] = "-";
+ argv[i++] = "-sOutputFile=-";
argv[i++] = gs->psfile;
argv[i++] = "quit.ps";
argv[i++] = NULL;
*** font_open.c.orig Sat Jan 13 18:29:22 1996
--- font_open.c Sat Jan 13 18:39:14 1996
***************