upgrade to 1.1.5

handle gnome correctly
This commit is contained in:
Ying-Chieh Liao 2001-11-28 20:55:42 +00:00
parent cdc0a86dc7
commit 84e710a152
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50702
4 changed files with 32 additions and 17 deletions

View File

@ -7,22 +7,29 @@
#
PORTNAME= poedit
PORTVERSION= 1.0.3
PORTVERSION= 1.1.5
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PATCH_SITES= ${MASTER_SITES}
PATCHFILES= poedit-1.1.5-wxwin-2.3.1.patch
MAINTAINER= ijliao@FreeBSD.org
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk \
db3:${PORTSDIR}/databases/db3
PATCH_DIST_ARGS= -d ${PATCH_WRKSRC} -E ${PATCH_DIST_STRIP} -p1
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -liconv"
USE_GMAKE= yes
.include <bsd.port.pre.mk>
.if defined(HAVE_GNOME)
USE_GNOME= yes
@ -30,4 +37,4 @@ USE_GNOME= yes
CONFIGURE_ARGS= --without-gnome
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1 +1,2 @@
MD5 (poedit-1.0.3.tar.gz) = 87cea627b2644ada54a328449938eb05
MD5 (poedit-1.1.5.tar.gz) = b0fea841ee24f9f4cdcc3673138a6a05
MD5 (poedit-1.1.5-wxwin-2.3.1.patch) = 840912cd70e8182adab34d8cdbaa1e60

View File

@ -1,13 +1,19 @@
--- install/Makefile.in.orig Tue Mar 27 13:41:45 2001
+++ install/Makefile.in Tue Mar 27 13:42:15 2001
@@ -197,8 +197,8 @@
--- install/Makefile.in.orig Sun Nov 25 01:15:33 2001
+++ install/Makefile.in Sun Nov 25 01:16:56 2001
@@ -206,13 +206,13 @@
@USE_GNOME_TRUE@install-gnome:
@USE_GNOME_TRUE@ mkdir -p $(GNOME_DATA_DIR)/pixmaps
@USE_GNOME_TRUE@ install -m 644 $(top_srcdir)/src/bitmaps/appicon.xpm $(GNOME_DATA_DIR)/pixmaps/poedit.xpm
-@USE_GNOME_TRUE@ mkdir -p $(GNOME_DATA_DIR)/gnome/apps/Development
-@USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.desktop $(GNOME_DATA_DIR)/gnome/apps/Development
+@USE_GNOME_TRUE@ mkdir -p $(GNOME_DATA_DIR)/apps/Development
+@USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.desktop $(GNOME_DATA_DIR)/apps/Development
@USE_GNOME_TRUE@ mkdir -p $(GNOME_DATA_DIR)/mime-info
@USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.mime $(GNOME_DATA_DIR)/mime-info
@USE_GNOME_TRUE@ install -m 644 poedit.keys $(GNOME_DATA_DIR)/mime-info
@USE_GNOME_TRUE@ if test -w $(GNOME_DATA_DIR)/pixmaps ; then \
@USE_GNOME_TRUE@ install -m 644 $(top_srcdir)/src/appicon.xpm $(GNOME_DATA_DIR)/pixmaps/poedit.xpm; \
@USE_GNOME_TRUE@ fi
-@USE_GNOME_TRUE@ if test -w $(GNOME_DATA_DIR)/gnome/apps/Development ; then \
-@USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.desktop $(GNOME_DATA_DIR)/gnome/apps/Development; \
+@USE_GNOME_TRUE@ if test -w $(GNOME_DATA_DIR)/apps/Development ; then \
+@USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.desktop $(GNOME_DATA_DIR)/apps/Development; \
@USE_GNOME_TRUE@ fi
@USE_GNOME_TRUE@ if test -w $(GNOME_DATA_DIR)/mime-info ; then \
@USE_GNOME_TRUE@ install -m 644 $(srcdir)/poedit.mime $(GNOME_DATA_DIR)/mime-info; \

View File

@ -3,5 +3,6 @@ bin/poedit
%%GNOME:%%share/gnome/mime-info/poedit.keys
%%GNOME:%%share/gnome/mime-info/poedit.mime
%%GNOME:%%share/gnome/pixmaps/poedit.xpm
share/poedit/poedit_help.htb
@dirrm share/poedit
%%GNOME:%%share/gnome/poedit/help.zip
%%GNOME:%%share/gnome/poedit/resources.zip
@dirrm share/gnome/poedit