- Fix build on 4-x
PR: ports/65319 Submitted by: michael johnson <ahze@ahze.net>
This commit is contained in:
parent
86e893255c
commit
84e5bd3f4e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106492
@ -33,10 +33,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} <= 500000
|
||||
BROKEN= "Does not compile"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${RM} -rf ${WRKSRC}/.libs
|
||||
@${RM} -rf ${WRKSRC}/autom4te.cache
|
||||
|
19
audio/xmms-jack/files/patch-bio2jack.c
Normal file
19
audio/xmms-jack/files/patch-bio2jack.c
Normal file
@ -0,0 +1,19 @@
|
||||
--- bio2jack.c.orig Thu Apr 8 10:03:08 2004
|
||||
+++ bio2jack.c Thu Apr 8 10:07:28 2004
|
||||
@@ -585,6 +585,7 @@
|
||||
/* and transition to STOPPED */
|
||||
if(this->state == RESET)
|
||||
{
|
||||
+ wave_header_t *wh;
|
||||
this->written_client_bytes = 0;
|
||||
this->played_client_bytes = 0; /* number of the clients bytes that jack has played */
|
||||
|
||||
@@ -598,7 +599,7 @@
|
||||
/* free up all of the buffers of audio that are queued */
|
||||
/* NOTE: this needs to be done inside of the callback because */
|
||||
/* the callback could be using any of these buffers */
|
||||
- wave_header_t *wh = this->pPlayPtr;
|
||||
+ wh = this->pPlayPtr;
|
||||
while(wh)
|
||||
{
|
||||
wh = wh->pNext;
|
Loading…
Reference in New Issue
Block a user