- Fix build on 4-x

PR:		ports/65319
Submitted by:	michael johnson <ahze@ahze.net>
This commit is contained in:
Kirill Ponomarev 2004-04-08 12:23:50 +00:00
parent 86e893255c
commit 84e5bd3f4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106492
2 changed files with 19 additions and 4 deletions

View File

@ -33,10 +33,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 500000
BROKEN= "Does not compile"
.endif
post-patch:
@${RM} -rf ${WRKSRC}/.libs
@${RM} -rf ${WRKSRC}/autom4te.cache

View File

@ -0,0 +1,19 @@
--- bio2jack.c.orig Thu Apr 8 10:03:08 2004
+++ bio2jack.c Thu Apr 8 10:07:28 2004
@@ -585,6 +585,7 @@
/* and transition to STOPPED */
if(this->state == RESET)
{
+ wave_header_t *wh;
this->written_client_bytes = 0;
this->played_client_bytes = 0; /* number of the clients bytes that jack has played */
@@ -598,7 +599,7 @@
/* free up all of the buffers of audio that are queued */
/* NOTE: this needs to be done inside of the callback because */
/* the callback could be using any of these buffers */
- wave_header_t *wh = this->pPlayPtr;
+ wh = this->pPlayPtr;
while(wh)
{
wh = wh->pNext;