This software (agm) is no longer distributed or supported by the author.

PR:		28091
Submitted by:	Jeff Palmer <scorpio@drkshdw.org>
This commit is contained in:
Steve Price 2001-06-17 18:42:56 +00:00
parent 4b9159060f
commit 84b49f1ab6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44135
8 changed files with 0 additions and 82 deletions

View File

@ -12,7 +12,6 @@
SUBDIR += actx
SUBDIR += adom
SUBDIR += affenspiel
SUBDIR += agm
SUBDIR += alephone
SUBDIR += alephone-data
SUBDIR += amphetamine

View File

@ -1,25 +0,0 @@
# New ports collection makefile for: agm
# Date created: 4 July 1997
# Whom: Andrey Zakhvatov
#
# $FreeBSD$
#
PORTNAME= agm
PORTVERSION= 1.4
CATEGORIES= games
MASTER_SITES= http://users.gtn.net/fraserm/
MAINTAINER= ports@FreeBSD.org
MAN6= agm.6
post-patch:
@${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/xagm
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/agm ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/xagm ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/agm.6 ${PREFIX}/man/man6
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (agm-1.4.tar.gz) = 3ff16447dba1d693fdd32752ddc9966c

View File

@ -1,42 +0,0 @@
--- Makefile.orig Sun Oct 18 00:21:25 1998
+++ Makefile Wed May 3 12:00:00 2000
@@ -50,18 +50,18 @@
RELEASE=-DRELEASE=\"$(VER)\"
# Set this to the destination directory for the executable
#BINDIR=../../bin/`uname`
-BINDIR=/usr/local/bin
+BINDIR=${PREFIX}/bin
# Location of manual pages
#MANDIR=../../man
-MANDIR=/usr/local/man
+MANDIR=${PREFIX}/man
# Location of the word file
-WORDDIR=/usr/local/lib
+WORDDIR=/usr/share/dict
# Name of the default wordfile
WORDFILE=-DWORDFILE=\"$(WORDDIR)/words\"
# C compiler
-CC=cc
+CC?=cc
# Optimization or other flags for C compiler
-CCFLAGS=-O
+CFLAGS?=-O
#CCFLAGS=-g
# Alter this if you have problems compiling the CPU limit code or the
# timer code
@@ -77,13 +77,13 @@
doc: agm.ps
agm: main.o process.o listfuncs.o wordfuncs.o gobble.o sort.o output.o progress.o
- $(CC) $(CCFLAGS) $(DEFINES) $(RELEASE) $(WORDFILE) -o agm main.o process.o listfuncs.o wordfuncs.o gobble.o sort.o output.o progress.o
+ $(CC) $(CFLAGS) $(DEFINES) $(RELEASE) $(WORDFILE) -o agm main.o process.o listfuncs.o wordfuncs.o gobble.o sort.o output.o progress.o
#gagm: gtkmain.o
# $(CC) $(CCFLAGS) $(DEFINES) $(RELEASE) $(WORDFILE) -o gagm gtkmain.o $(GTKCFLAGS) $(GTKLIBS)
.c.o:
- $(CC) -c $(CCFLAGS) $(DEFINES) $(RELEASE) $(WORDFILE) $<
+ $(CC) -c $(CFLAGS) $(DEFINES) $(RELEASE) $(WORDFILE) $<
#gtkmain.o: gtkmain.c agm.h

View File

@ -1,5 +0,0 @@
--- xagm.orig Wed Mar 18 01:02:29 1998
+++ xagm Wed May 3 12:00:00 2000
@@ -1,1 +1,1 @@
-#!/usr/bin/wish
+#!%%LOCALBASE%%/bin/wish8.0

View File

@ -1 +0,0 @@
AnaGraM search utility

View File

@ -1,5 +0,0 @@
'agm' searches for single- or multi-word anagrams of target
words, and has options to assist finding good anagrams by
eliminating excessive "dross" words.
WWW: http://users.gtn.net/fraserm/anagrams.html

View File

@ -1,2 +0,0 @@
bin/agm
bin/xagm