- Update to 0.3.8
- Adopt port
This commit is contained in:
parent
799992531a
commit
849774c616
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=162686
@ -6,24 +6,24 @@
|
||||
#
|
||||
|
||||
PORTNAME= liboil
|
||||
PORTVERSION= 0.3.6
|
||||
PORTVERSION= 0.3.8
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://liboil.freedesktop.org/download/
|
||||
MASTER_SITES= http://liboil.freedesktop.org/download/ \
|
||||
${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= ahze
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= ahze@FreeBSD.org
|
||||
COMMENT= Library of optimized inner loops
|
||||
|
||||
USE_GNOME= glib20
|
||||
USE_GNOME= glib20 gnomehack
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ARGS= --disable-gtk-doc
|
||||
|
||||
PLIST_SUB= VERSION=${PORTVERSION:R}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|stdint\.h|inttypes.h|g' \
|
||||
@${REINPLACE_CMD} -e 's|<stdint\.h|<inttypes.h|g' \
|
||||
${WRKSRC}/liboil/liboiltypes.h \
|
||||
${WRKSRC}/liboil/liboilprofile.h \
|
||||
${WRKSRC}/liboil/liboil.h
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (liboil-0.3.6.tar.gz) = a36b2d9cc71d75d814d7bdca2263290f
|
||||
SHA256 (liboil-0.3.6.tar.gz) = 52cb40905064ef836527b01c86650bebf662e1224da43c6fb0f3e1f443de232c
|
||||
SIZE (liboil-0.3.6.tar.gz) = 714947
|
||||
MD5 (liboil-0.3.8.tar.gz) = a402c4af2603c8fb69b365af0b8ec775
|
||||
SHA256 (liboil-0.3.8.tar.gz) = 40fa52503e30c21fd1ae1affcc038ff05af5caf0c77c27630526069ffad804ff
|
||||
SIZE (liboil-0.3.8.tar.gz) = 834167
|
||||
|
@ -1,18 +1,19 @@
|
||||
--- liboil/liboilcpu.c.orig Sat May 21 14:12:56 2005
|
||||
+++ liboil/liboilcpu.c Sat May 21 14:34:37 2005
|
||||
@@ -59,7 +59,11 @@
|
||||
--- liboil/liboilcpu.c.orig Mon Mar 20 22:14:01 2006
|
||||
+++ liboil/liboilcpu.c Wed May 17 17:47:44 2006
|
||||
@@ -71,7 +71,11 @@
|
||||
cpuinfo = malloc(4096);
|
||||
if (cpuinfo == NULL) return NULL;
|
||||
|
||||
+#if defined(__FreeBSD__)
|
||||
+ fd = open("/var/run/dmesg.boot", O_RDONLY);
|
||||
+#else
|
||||
fd = open("/proc/cpuinfo", O_RDONLY);
|
||||
+#endif
|
||||
if (fd < 0) return NULL;
|
||||
|
||||
n = read(fd, cpuinfo, 4095);
|
||||
@@ -84,6 +88,37 @@
|
||||
- fd = open("/proc/cpuinfo", O_RDONLY);
|
||||
+ #if defined(__FreeBSD__)
|
||||
+ fd = open("/var/run/dmesg.boot", O_RDONLY);
|
||||
+ #else
|
||||
+ fd = open("/proc/cpuinfo", O_RDONLY);
|
||||
+ #endif
|
||||
if (fd < 0) {
|
||||
free (cpuinfo);
|
||||
return NULL;
|
||||
@@ -104,6 +108,37 @@
|
||||
}
|
||||
|
||||
flags = strsplit(cpuinfo_flags);
|
||||
@ -50,7 +51,7 @@
|
||||
for (f = flags; *f; f++) {
|
||||
if (strcmp (*f, "cmov") == 0) {
|
||||
OIL_DEBUG ("cpu flag %s", *f);
|
||||
@@ -113,6 +148,7 @@
|
||||
@@ -134,6 +169,7 @@
|
||||
OIL_DEBUG ("cpu flag %s", *f);
|
||||
oil_cpu_flags |= OIL_IMPL_FLAG_3DNOWEXT;
|
||||
}
|
||||
@ -58,7 +59,7 @@
|
||||
|
||||
free (*f);
|
||||
}
|
||||
@@ -282,12 +318,22 @@
|
||||
@@ -381,12 +417,22 @@
|
||||
char *end;
|
||||
char *colon;
|
||||
|
||||
@ -81,7 +82,7 @@
|
||||
if (colon == NULL) return NULL;
|
||||
colon++;
|
||||
if(colon >= end) return NULL;
|
||||
@@ -303,15 +349,22 @@
|
||||
@@ -402,15 +448,22 @@
|
||||
char *tok;
|
||||
int n = 0;
|
||||
|
||||
|
@ -1,22 +1,24 @@
|
||||
include/liboil-%%VERSION%%/liboil/liboil.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilclasses.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilcpu.h
|
||||
include/liboil-%%VERSION%%/liboil/liboildebug.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilfuncs.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilfunction.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilgcc.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilinternal.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilparameter.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilprofile.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilprototype.h
|
||||
include/liboil-%%VERSION%%/liboil/liboilrandom.h
|
||||
include/liboil-%%VERSION%%/liboil/liboiltest.h
|
||||
include/liboil-%%VERSION%%/liboil/liboiltypes.h
|
||||
lib/liboil-%%VERSION%%.a
|
||||
lib/liboil-%%VERSION%%.la
|
||||
lib/liboil-%%VERSION%%.so
|
||||
lib/liboil-%%VERSION%%.so.1
|
||||
libdata/pkgconfig/liboil-%%VERSION%%.pc
|
||||
bin/oil-bugreport
|
||||
include/liboil-0.3/liboil/liboil-stdint.h
|
||||
include/liboil-0.3/liboil/liboil.h
|
||||
include/liboil-0.3/liboil/liboilclasses.h
|
||||
include/liboil-0.3/liboil/liboilcpu.h
|
||||
include/liboil-0.3/liboil/liboildebug.h
|
||||
include/liboil-0.3/liboil/liboilfuncs.h
|
||||
include/liboil-0.3/liboil/liboilfunction.h
|
||||
include/liboil-0.3/liboil/liboilgcc.h
|
||||
include/liboil-0.3/liboil/liboilinternal.h
|
||||
include/liboil-0.3/liboil/liboilparameter.h
|
||||
include/liboil-0.3/liboil/liboilprofile.h
|
||||
include/liboil-0.3/liboil/liboilprototype.h
|
||||
include/liboil-0.3/liboil/liboilrandom.h
|
||||
include/liboil-0.3/liboil/liboiltest.h
|
||||
include/liboil-0.3/liboil/liboiltypes.h
|
||||
lib/liboil-0.3.a
|
||||
lib/liboil-0.3.la
|
||||
lib/liboil-0.3.so
|
||||
lib/liboil-0.3.so.1
|
||||
libdata/pkgconfig/liboil-0.3.pc
|
||||
share/gtk-doc/html/liboil/ch01.html
|
||||
share/gtk-doc/html/liboil/ch02.html
|
||||
share/gtk-doc/html/liboil/home.png
|
||||
@ -45,11 +47,12 @@ share/gtk-doc/html/liboil/liboil-liboilrandom.html
|
||||
share/gtk-doc/html/liboil/liboil-liboiltest.html
|
||||
share/gtk-doc/html/liboil/liboil-liboiltypes.html
|
||||
share/gtk-doc/html/liboil/liboil.devhelp
|
||||
share/gtk-doc/html/liboil/liboil.devhelp2
|
||||
share/gtk-doc/html/liboil/right.png
|
||||
share/gtk-doc/html/liboil/style.css
|
||||
share/gtk-doc/html/liboil/up.png
|
||||
@dirrm share/gtk-doc/html/liboil
|
||||
@dirrmtry share/gtk-doc/html
|
||||
@dirrmtry share/gtk-doc
|
||||
@dirrm include/liboil-%%VERSION%%/liboil
|
||||
@dirrm include/liboil-%%VERSION%%
|
||||
@dirrm include/liboil-0.3/liboil
|
||||
@dirrm include/liboil-0.3
|
||||
|
Loading…
Reference in New Issue
Block a user