- Update to 1.2.1

PR:		ports/72685
Submitted by:	Roman Bogorodskiy <bogorodskiy@inbox.ru>
Approved by:	Hendrik Scholz <hscholz@raisdorf.net> (maintainer)
This commit is contained in:
Pav Lucistnik 2004-10-18 20:44:49 +00:00
parent f30d42f081
commit 847293a727
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=119745
10 changed files with 50 additions and 38 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= fbdesk
PORTVERSION= 1.1.5
PORTVERSION= 1.2.1
CATEGORIES= x11-wm
MASTER_SITES= http://fluxbox.sourceforge.net/download/
@ -24,10 +24,6 @@ PORTDOCS= COPYING ChangeLog INSTALL README
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
.if ${OSVERSION} >= 500000
USE_REINPLACE= yes
post-patch:

View File

@ -1,2 +1,2 @@
MD5 (fbdesk-1.1.5.tar.gz) = c41319c9a2a03cf4d7d5e0586e57cba6
SIZE (fbdesk-1.1.5.tar.gz) = 253057
MD5 (fbdesk-1.2.1.tar.gz) = 382a32a6e26b3f3d3a647fa4bdc81b7a
SIZE (fbdesk-1.2.1.tar.gz) = 388679

View File

@ -0,0 +1,10 @@
--- src/FbTk/FbPixmap.cc.orig Mon Sep 20 12:26:19 2004
+++ src/FbTk/FbPixmap.cc Fri Oct 15 18:08:16 2004
@@ -28,6 +28,7 @@
#include <X11/Xutil.h>
#include <X11/Xatom.h>
#include <iostream>
+#include <stdio.h>
using namespace std;
namespace FbTk {

View File

@ -0,0 +1,12 @@
--- src/FbTk/Font.cc.orig Mon Sep 20 12:45:01 2004
+++ src/FbTk/Font.cc Fri Oct 15 18:04:48 2004
@@ -89,9 +89,7 @@
namespace {
-#ifdef HAVE_SETLOCALE
#include <locale.h>
-#endif //HAVE_SETLOCALE
#ifdef HAVE_ICONV
/**

View File

@ -1,12 +0,0 @@
--- src/FbTk/FbWindow.cc.orig Sat Feb 14 10:48:03 2004
+++ src/FbTk/FbWindow.cc Sat Feb 14 10:48:11 2004
@@ -168,7 +168,8 @@
Window root;
size_t border_width, depth;
XGetGeometry(s_display, m_window, &root, &m_x, &m_y,
- &m_width, &m_height, &border_width, &depth);
+ (unsigned int*) &m_width, (unsigned int*) &m_height,
+ (unsigned int*) &border_width, (unsigned int*) &depth);
}
void FbWindow::create(Window parent, int x, int y,

View File

@ -6,7 +6,7 @@
#
PORTNAME= fbdesk
PORTVERSION= 1.1.5
PORTVERSION= 1.2.1
CATEGORIES= x11-wm
MASTER_SITES= http://fluxbox.sourceforge.net/download/
@ -24,10 +24,6 @@ PORTDOCS= COPYING ChangeLog INSTALL README
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
.if ${OSVERSION} >= 500000
USE_REINPLACE= yes
post-patch:

View File

@ -1,2 +1,2 @@
MD5 (fbdesk-1.1.5.tar.gz) = c41319c9a2a03cf4d7d5e0586e57cba6
SIZE (fbdesk-1.1.5.tar.gz) = 253057
MD5 (fbdesk-1.2.1.tar.gz) = 382a32a6e26b3f3d3a647fa4bdc81b7a
SIZE (fbdesk-1.2.1.tar.gz) = 388679

View File

@ -0,0 +1,10 @@
--- src/FbTk/FbPixmap.cc.orig Mon Sep 20 12:26:19 2004
+++ src/FbTk/FbPixmap.cc Fri Oct 15 18:08:16 2004
@@ -28,6 +28,7 @@
#include <X11/Xutil.h>
#include <X11/Xatom.h>
#include <iostream>
+#include <stdio.h>
using namespace std;
namespace FbTk {

View File

@ -0,0 +1,12 @@
--- src/FbTk/Font.cc.orig Mon Sep 20 12:45:01 2004
+++ src/FbTk/Font.cc Fri Oct 15 18:04:48 2004
@@ -89,9 +89,7 @@
namespace {
-#ifdef HAVE_SETLOCALE
#include <locale.h>
-#endif //HAVE_SETLOCALE
#ifdef HAVE_ICONV
/**

View File

@ -1,12 +0,0 @@
--- src/FbTk/FbWindow.cc.orig Sat Feb 14 10:48:03 2004
+++ src/FbTk/FbWindow.cc Sat Feb 14 10:48:11 2004
@@ -168,7 +168,8 @@
Window root;
size_t border_width, depth;
XGetGeometry(s_display, m_window, &root, &m_x, &m_y,
- &m_width, &m_height, &border_width, &depth);
+ (unsigned int*) &m_width, (unsigned int*) &m_height,
+ (unsigned int*) &border_width, (unsigned int*) &depth);
}
void FbWindow::create(Window parent, int x, int y,