Remove expired port:
2020-12-31 games/dangerdeep: Uses Python 2.7 version of scons, and Python 2.7 which is EOLed upstream games/dangerdeep-data
This commit is contained in:
parent
28ee394669
commit
8471c7a53a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559943
2
MOVED
2
MOVED
@ -15990,3 +15990,5 @@ games/pingus||2021-01-02|Has expired: Uses Python 2.7 version of scons, and Pyth
|
||||
graphics/goxel||2021-01-02|Has expired: Uses Python 2.7 version of scons, and Python 2.7 which is EOLed upstream
|
||||
graphics/sk1libs||2021-01-02|Has expired: Uses Python 2.7 which is EOLed upstream
|
||||
graphics/uniconvertor||2021-01-02|Has expired: Uses deprecated version of python
|
||||
games/dangerdeep||2021-01-02|Has expired: Uses Python 2.7 version of scons, and Python 2.7 which is EOLed upstream
|
||||
games/dangerdeep-data||2021-01-02|Removed, useless without games/dangerdeep
|
||||
|
@ -184,8 +184,6 @@
|
||||
SUBDIR += d2x
|
||||
SUBDIR += dMagnetic
|
||||
SUBDIR += dangen
|
||||
SUBDIR += dangerdeep
|
||||
SUBDIR += dangerdeep-data
|
||||
SUBDIR += darkplaces
|
||||
SUBDIR += defendguin
|
||||
SUBDIR += devilutionX
|
||||
|
@ -1,27 +0,0 @@
|
||||
# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dangerdeep-data
|
||||
PORTVERSION= 0.3.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/dangerdeep/danger_from_the_deep-data/${PORTVERSION}
|
||||
DIST_SUBDIR= dangerdeep
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Danger from the Deep data files
|
||||
|
||||
LICENSE= CC-BY-NC-ND-2.5
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= zip
|
||||
NO_BUILD= yes
|
||||
NO_ARCH= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/data
|
||||
DATADIR= ${PREFIX}/share/dangerdeep
|
||||
PORTDATA= *
|
||||
|
||||
do-install:
|
||||
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (dangerdeep/dangerdeep-data-0.3.0.zip) = 00412a4f8f571a9291df48fa40fbbe846680b4fcb1de2f168539b1606cb4fb81
|
||||
SIZE (dangerdeep/dangerdeep-data-0.3.0.zip) = 61914764
|
@ -1,3 +0,0 @@
|
||||
The Danger From the Deep data files
|
||||
|
||||
WWW: http://dangerdeep.sourceforge.net/
|
@ -1,56 +0,0 @@
|
||||
# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dangerdeep
|
||||
PORTVERSION= 0.3.0
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/danger_from_the_deep-src/${PORTVERSION}
|
||||
DIST_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Open source World War II German submarine simulation
|
||||
|
||||
LIB_DEPENDS= libfftw3.so:math/fftw3
|
||||
RUN_DEPENDS= dangerdeep-data>0:games/dangerdeep-data
|
||||
|
||||
USES= compiler gl scons:python2 sdl
|
||||
USE_GL= yes
|
||||
USE_SDL= sdl mixer image net
|
||||
|
||||
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
|
||||
CXXFLAGS_clang= -Wno-c++11-narrowing
|
||||
MAKE_ARGS= installbindir=${PREFIX}/bin installdatadir=${DATADIR}
|
||||
MAKE_ENV= X11BASE=${LOCALBASE}
|
||||
|
||||
PLIST_FILES= bin/dangerdeep bin/crosssection bin/damagemodel \
|
||||
bin/oceantest bin/portal bin/viewmodel \
|
||||
man/man6/dangerdeep.6.gz
|
||||
|
||||
PORTDOCS= CREDITS README
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(PACKAGE_BUILDING)
|
||||
MAKE_ARGS+= usex86sse=-1 # disable MMX/SSE on the build cluster
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/share/games/dangerdeep|${DATADIR}|; \
|
||||
s|Linux|"Danger from the Deep"|' ${WRKSRC}/doc/man/dangerdeep.6
|
||||
@${REINPLACE_CMD} -e 's|/usr/X11BASE|${LOCALBASE}|g' \
|
||||
${WRKSRC}/SConstruct
|
||||
|
||||
do-install:
|
||||
@cd ${WRKSRC}/build/freebsd && \
|
||||
${INSTALL_PROGRAM} dangerdeep crosssection damagemodel oceantest \
|
||||
portal viewmodel ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/man/dangerdeep.6 ${STAGEDIR}${PREFIX}/man/man6
|
||||
${GZIP_CMD} ${STAGEDIR}${PREFIX}/man/man6/dangerdeep.6
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (dangerdeep/dangerdeep-0.3.0.tar.gz) = bdab6b9b1c2b5f8e618f5c346965ec1f48c9edc9bff1d4f5ff7c8d235464283f
|
||||
SIZE (dangerdeep/dangerdeep-0.3.0.tar.gz) = 1100972
|
@ -1,104 +0,0 @@
|
||||
--- SConstruct.orig 2007-06-11 18:29:13 UTC
|
||||
+++ SConstruct
|
||||
@@ -46,7 +46,7 @@ if sys.platform == 'win32':
|
||||
env.Append(CPPDEFINES = ['USE_SSE'])
|
||||
print 'Using x86 SSE/MMX optimizations with GCC intrinsics.'
|
||||
datadir = './data' # use slashes as separator always. C/C++ want it so.
|
||||
- build_dir = 'win32'
|
||||
+ variant_dir = 'win32'
|
||||
elif sys.platform == 'darwin':
|
||||
print "Compiling for MacOSX"
|
||||
env = Environment(ENV = os.environ)
|
||||
@@ -57,12 +57,12 @@ elif sys.platform == 'darwin':
|
||||
env.Append(CCFLAGS = '-Wall -g -O2 `sdl-config --cflags`')
|
||||
env.Append(LINKFLAGS = '-F/System/Library/Frameworks -framework AGL -framework OpenGL -framework GLUT -framework Cocoa -framework SDL -framework SDL_image -framework SDL_mixer -framework SDL_net')
|
||||
datadir = './data' # use slashes as separator always. C/C++ want it so.
|
||||
- build_dir = 'macosx'
|
||||
+ variant_dir = 'macosx'
|
||||
osspecificsrc = Split("""Mac/SDLMain.m""")
|
||||
if (debug == 1):
|
||||
env.Append(CCFLAGS = '-g')
|
||||
env.Append(CPPDEFINES = ['DEBUG'])
|
||||
-elif (sys.platform == 'freebsd5') or (sys.platform == 'freebsd6') or (sys.platform == 'freebsd7'):
|
||||
+elif sys.platform.startswith('freebsd'):
|
||||
print "Compiling for FreeBSD Environment"
|
||||
env = Environment(ENV = os.environ)
|
||||
LOCALBASE = os.environ['LOCALBASE']
|
||||
@@ -70,7 +70,7 @@ elif (sys.platform == 'freebsd5') or (sys.platform ==
|
||||
SDL_CONFIG = os.environ['SDL_CONFIG']
|
||||
env.Replace(CC = os.environ['CC'])
|
||||
env.Replace(CXX = os.environ['CXX'])
|
||||
- env.Append(CPPPATH = [LOCALBASE + '/include', LOCALBASE + '/include/SDL11', X11BASE + '/include', X11BASE + '/include/GL'])
|
||||
+ env.Append(CPPPATH = [LOCALBASE + '/include', LOCALBASE + '/include/SDL', X11BASE + '/include', X11BASE + '/include/GL'])
|
||||
libpath = [LOCALBASE + '/lib', X11BASE + '/lib']
|
||||
gllibs = ['GL', 'GLU']
|
||||
sdllibs = ['SDL_image']
|
||||
@@ -79,7 +79,7 @@ elif (sys.platform == 'freebsd5') or (sys.platform ==
|
||||
cpuinfol = cpuinfof.readlines()
|
||||
mmxsupported = False
|
||||
ssesupported = False
|
||||
- for i in cpuinfol:
|
||||
+ for i in cpuinfol:
|
||||
if i == '1\n':
|
||||
mmxsupported = True
|
||||
ssesupported = True
|
||||
@@ -91,14 +91,15 @@ elif (sys.platform == 'freebsd5') or (sys.platform ==
|
||||
osspecificsrc += []
|
||||
print 'Using x86 SSE/MMX optimizations.'
|
||||
|
||||
- env.Replace(CCFLAGS = os.environ['CFLAGS'])
|
||||
+ env.Replace(CCFLAGS = os.environ['CFLAGS'])
|
||||
if (debug == 1):
|
||||
env.Append(CCFLAGS = '-g')
|
||||
env.Append(CPPDEFINES = ['DEBUG'])
|
||||
- env.Replace(CXXFLAGS = os.environ['CXXFLAGS'] + ' `' + SDL_CONFIG + ' --cflags`')
|
||||
- env.Append(LINKFLAGS = '`' + SDL_CONFIG + ' --libs`')
|
||||
- datadir = '/usr/local/share/dangerdeep'
|
||||
- build_dir = 'freebsd'
|
||||
+ env.Replace(CXXFLAGS = os.environ['CXXFLAGS'] + ' `' + SDL_CONFIG + ' --cflags`')
|
||||
+ env.Append(LINKFLAGS = '`' + SDL_CONFIG + ' --libs`')
|
||||
+ env.Append(LIBPATH = [LOCALBASE + '/lib', X11BASE + '/lib'])
|
||||
+ datadir = '/usr/local/share/dangerdeep'
|
||||
+ variant_dir = 'freebsd'
|
||||
|
||||
if (os.system('grep glBindProgram ' + X11BASE + '/include/GL/gl*.h > /dev/null') == 0):
|
||||
gllibdirs = [X11BASE + '/lib/', '/usr/lib/', LOCALBASE + '/lib/']
|
||||
@@ -179,7 +180,7 @@ else:
|
||||
print 'Using x86 SSE/MMX optimizations with GCC intrinsics.'
|
||||
env.Append(CCFLAGS = ccflags)
|
||||
datadir = '/usr/local/share/dangerdeep'
|
||||
- build_dir = 'linux'
|
||||
+ variant_dir = 'linux'
|
||||
# check for broken libGL, ignore undefined symbols then
|
||||
if (os.system('grep glBindProgram /usr/include/GL/gl*.h > /dev/null') == 0):
|
||||
gllibdirs = ['/usr/X11R6/lib/', '/usr/lib/', '/usr/local/lib/']
|
||||
@@ -208,7 +209,7 @@ if ARGUMENTS.get('installbindir', 0):
|
||||
print 'Install binary path: ' + installbindir
|
||||
print 'Using data dir: ' + datadir
|
||||
|
||||
-target_dir = '#build' + os.sep + build_dir
|
||||
+target_dir = '#build' + os.sep + variant_dir
|
||||
source_base_dir = 'src'
|
||||
|
||||
################ configure
|
||||
@@ -273,9 +274,9 @@ f.close()
|
||||
|
||||
Export('env', 'gfxlibs', 'alllibs', 'installbindir', 'datadir', 'version', 'osspecificsrc')
|
||||
|
||||
-SConscript(source_base_dir + os.sep + 'SConscript', build_dir = target_dir, duplicate = 0)
|
||||
+SConscript(source_base_dir + os.sep + 'SConscript', variant_dir = target_dir, duplicate = 0)
|
||||
|
||||
-BuildDir(target_dir, source_base_dir, duplicate=0)
|
||||
+VariantDir(target_dir, source_base_dir, duplicate=0)
|
||||
|
||||
############### Helper functions
|
||||
def findCVS(basedir):
|
||||
@@ -304,7 +305,7 @@ def findCVS(basedir):
|
||||
|
||||
############### option so that "scons tarball" builds a tarball of source
|
||||
# tar building works only on linux
|
||||
-if (( build_dir == 'linux' ) or ( build_dir == 'freebsd' )) and (os.path.isdir('./CVS')):
|
||||
+if (( variant_dir == 'linux' ) or ( variant_dir == 'freebsd' )) and (os.path.isdir('./CVS')):
|
||||
basetarfilename = 'dangerdeep-' + version
|
||||
os.system('rm -rf ' + basetarfilename)
|
||||
os.system('ln -s . ' + basetarfilename)
|
@ -1,18 +0,0 @@
|
||||
--- ./src/condvar.h.orig 2007-06-11 11:16:23.000000000 -0400
|
||||
+++ ./src/condvar.h 2014-08-11 09:56:15.000000000 -0400
|
||||
@@ -43,13 +43,13 @@
|
||||
|
||||
/// wait on condition
|
||||
///@param m - mutex to encapsulate waiting condition
|
||||
- void wait(mutex& m);
|
||||
+ void wait(::mutex& m);
|
||||
|
||||
/// wait on condition with timeout
|
||||
///@param m - mutex to encapsulate waiting condition
|
||||
///@param ms - timeout value in milliseconds
|
||||
///@return true when woken up by signal, false on timeout
|
||||
- bool timed_wait(mutex& m, unsigned ms);
|
||||
+ bool timed_wait(::mutex& m, unsigned ms);
|
||||
|
||||
/// send signal to threads that are waiting on the condition.
|
||||
///@note Note that before sending the signal you must make the condition false that would
|
@ -1,10 +0,0 @@
|
||||
--- ./src/faulthandler.h.orig 2007-06-11 14:29:30.000000000 -0400
|
||||
+++ ./src/faulthandler.h 2014-08-11 10:17:47.000000000 -0400
|
||||
@@ -46,6 +46,7 @@
|
||||
#include <execinfo.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
#include <cxxabi.h> // Needed for __cxa_demangle
|
||||
#include <signal.h>
|
||||
#include <string>
|
@ -1,20 +0,0 @@
|
||||
--- ./src/mutex.h.orig 2007-06-11 11:16:23.000000000 -0400
|
||||
+++ ./src/mutex.h 2014-08-11 09:59:15.000000000 -0400
|
||||
@@ -58,7 +58,7 @@
|
||||
class mutex_locker
|
||||
{
|
||||
protected:
|
||||
- mutex& mymutex;
|
||||
+ ::mutex& mymutex;
|
||||
private:
|
||||
mutex_locker();
|
||||
mutex_locker(const mutex_locker& );
|
||||
@@ -67,7 +67,7 @@
|
||||
/// create mutex locker
|
||||
///@param mtx - mutex to lock
|
||||
///@note will instantly lock the mutex that was given as parameter
|
||||
- mutex_locker(mutex& mtx) : mymutex(mtx) { mymutex.lock(); }
|
||||
+ mutex_locker(::mutex& mtx) : mymutex(mtx) { mymutex.lock(); }
|
||||
|
||||
/// destroy mutex locker
|
||||
///@note will unlock the mutex that was given to the constructor
|
@ -1,19 +0,0 @@
|
||||
--- src/subsim.cpp.orig 2007-06-11 15:16:23 UTC
|
||||
+++ src/subsim.cpp
|
||||
@@ -31,6 +31,7 @@ Foundation, Inc., 59 Temple Place, Suite 330, Boston,
|
||||
#else
|
||||
#include "oglext/OglExt.h"
|
||||
#endif
|
||||
+#include <unistd.h>
|
||||
#include <glu.h>
|
||||
#include <SDL.h>
|
||||
#include <SDL_net.h>
|
||||
@@ -1735,7 +1736,7 @@ int mymain(list<string>& args)
|
||||
glEnable(GL_LIGHT0);
|
||||
|
||||
// create and start thread for music handling.
|
||||
- thread::auto_ptr<music> mmusic(new music(use_sound));
|
||||
+ ::thread::auto_ptr<music> mmusic(new music(use_sound));
|
||||
mmusic->start();
|
||||
|
||||
reset_loading_screen();
|
@ -1,19 +0,0 @@
|
||||
--- ./src/thread.h.orig 2007-06-11 11:16:23.000000000 -0400
|
||||
+++ ./src/thread.h 2014-08-11 10:14:00.000000000 -0400
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
#include "condvar.h"
|
||||
#include <stdexcept>
|
||||
+#include <string>
|
||||
#include <stdint.h>
|
||||
|
||||
/// base class for threads.
|
||||
@@ -47,7 +48,7 @@
|
||||
struct SDL_Thread* thread_id;
|
||||
bool thread_abort_request;
|
||||
thread_state_t thread_state;
|
||||
- mutex thread_state_mutex;
|
||||
+ ::mutex thread_state_mutex;
|
||||
condvar thread_start_cond;
|
||||
std::string thread_error_message; // to pass exception texts via thread boundaries
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- src/coastmap.h.orig 2020-03-29 09:04:12 UTC
|
||||
+++ src/coastmap.h
|
||||
@@ -151,7 +151,7 @@ class coastmap
|
||||
void process_coastline(int x, int y);
|
||||
void process_segment(int x, int y);
|
||||
|
||||
- class worker : public thread
|
||||
+ class worker : public ::thread
|
||||
{
|
||||
coastmap& cm;
|
||||
public:
|
||||
@@ -163,7 +163,7 @@ class coastmap
|
||||
}
|
||||
};
|
||||
|
||||
- thread::auto_ptr<worker> myworker;
|
||||
+ ::thread::auto_ptr<worker> myworker;
|
||||
void construction_threaded();
|
||||
|
||||
public:
|
@ -1,26 +0,0 @@
|
||||
compiling failed, log:
|
||||
0:2(1): preprocessor error: #version must appear on the first line
|
||||
|
||||
--- src/shader.cpp.orig 2020-03-29 17:02:18 UTC
|
||||
+++ src/shader.cpp
|
||||
@@ -74,6 +74,8 @@ glsl_shader::glsl_shader(const string& filename, type
|
||||
// the program as string
|
||||
string prg;
|
||||
|
||||
+ prg += "#version 110\n";
|
||||
+
|
||||
// add defines to top of list for preprocessor
|
||||
for (defines_list::const_iterator it = dl.begin(); it != dl.end(); ++it) {
|
||||
prg += string("#define ") + *it + "\n";
|
||||
@@ -83,7 +85,10 @@ glsl_shader::glsl_shader(const string& filename, type
|
||||
while (!ifprg.eof()) {
|
||||
string s;
|
||||
getline(ifprg, s);
|
||||
- prg += s + "\n";
|
||||
+ string prefix("#version");
|
||||
+ if (0 != s.compare(0, prefix.size(), prefix)) {
|
||||
+ prg += s + "\n";
|
||||
+ }
|
||||
}
|
||||
|
||||
const char* prg_cstr = prg.c_str();
|
@ -1,6 +0,0 @@
|
||||
Danger from the deep (aka dangerdeep) is a Free / Open Source World War II
|
||||
German submarine simulation. It is currently available for FreeBSD, Linux/i386
|
||||
and Windows, but since it uses SDL/OpenGL it should be portable to other
|
||||
operating systems or platforms.
|
||||
|
||||
WWW: http://dangerdeep.sourceforge.net/
|
Loading…
Reference in New Issue
Block a user