print/epson-inkjet-printer-escpr: Update to 1.7.9
PR: 250441 Approved by: Tatsuki Makino <tatsuki_makino@hotmail.com> (maintainer)
This commit is contained in:
parent
99ee33eefa
commit
846e451329
@ -1,8 +1,8 @@
|
||||
PORTNAME= epson-inkjet-printer-escpr
|
||||
PORTVERSION= 1.7.7
|
||||
DISTVERSION= 1.7.9
|
||||
DISTVERSIONSUFFIX= -1lsb3.2
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= https://download3.ebz.epson.net/dsc/f/03/00/10/49/18/f3016be6120a7271a6d9cb64872f817bce1920b8/
|
||||
MASTER_SITES= https://download3.ebz.epson.net/dsc/f/03/00/12/50/95/322b8d6b915ab85add33d41f04ba5130866aadbe/
|
||||
|
||||
MAINTAINER= tatsuki_makino@hotmail.com
|
||||
COMMENT= Epson Inkjet Printer Driver (ESC/P-R) for Linux
|
||||
@ -10,10 +10,11 @@ COMMENT= Epson Inkjet Printer Driver (ESC/P-R) for Linux
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/libexec/cups/filter/gstoraster:print/cups-filters
|
||||
LIB_DEPENDS= libcupsimage.so:print/cups
|
||||
|
||||
USES= autoreconf dos2unix gmake libtool
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
|
||||
PORTDOCS= AUTHORS NEWS README README.ja
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-lsb
|
||||
@ -23,7 +24,7 @@ USE_LDCONFIG= yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
PORTSCOUT= ignore # MASTER_SITES is changed in each version
|
||||
PORTSCOUT= ignore:1 # MASTER_SITES is changed in each version
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1577415600
|
||||
SHA256 (epson-inkjet-printer-escpr-1.7.7-1lsb3.2.tar.gz) = 8d964368a1395a8902b8637e3dc176d6793f0afdfe3f21e95509f29894700d4e
|
||||
SIZE (epson-inkjet-printer-escpr-1.7.7-1lsb3.2.tar.gz) = 4767015
|
||||
TIMESTAMP = 1613962800
|
||||
SHA256 (epson-inkjet-printer-escpr-1.7.9-1lsb3.2.tar.gz) = 80bdfbe70e93f0613680e8ff7129cf2eead725d771e9396ccbd6f51ae186d08c
|
||||
SIZE (epson-inkjet-printer-escpr-1.7.9-1lsb3.2.tar.gz) = 4831399
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ppd/Makefile.am.orig 2019-08-28 05:35:05 UTC
|
||||
--- ppd/Makefile.am.orig 2021-02-15 02:27:34 UTC
|
||||
+++ ppd/Makefile.am
|
||||
@@ -624,8 +624,10 @@ EXTRA_DIST = $(cupsppd_DATA)
|
||||
@@ -639,8 +639,10 @@ EXTRA_DIST = $(cupsppd_DATA)
|
||||
|
||||
# LSBビルド環境の場合、~/.rpmmacros %adjust_ppds が担っている処理を実施
|
||||
install-data-hook:
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- src/filter.c.orig 2019-07-31 06:49:48 UTC
|
||||
--- src/filter.c.orig 2020-10-12 02:31:41 UTC
|
||||
+++ src/filter.c
|
||||
@@ -32,7 +32,10 @@
|
||||
|
||||
@ -19,6 +19,15 @@
|
||||
|
||||
#define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
|
||||
|
||||
@@ -225,7 +229,7 @@ main (int argc, char *argv[])
|
||||
EPS_BANDBMP bandBmp;
|
||||
|
||||
/* Fifo for Backend */
|
||||
-// context = (void*)XFIFOOpen();
|
||||
+ context = (void*)XFIFOOpen();
|
||||
|
||||
///////////////////////////////////////////////////////////////////////////////////////////////////////////
|
||||
memset (&jobAttr, 0, sizeof(jobAttr));
|
||||
@@ -380,7 +384,7 @@ main (int argc, char *argv[])
|
||||
}
|
||||
|
||||
@ -92,11 +101,29 @@
|
||||
bandBmp.bits += band_line_count;
|
||||
}
|
||||
|
||||
@@ -710,7 +730,7 @@ quit:;
|
||||
mem_free(paper);
|
||||
debug_msg("PRINT SUCCESS\n");
|
||||
|
||||
-// XFIFOClose(&context);
|
||||
+ XFIFOClose(&context);
|
||||
|
||||
return 0;
|
||||
}
|
||||
@@ -871,7 +891,7 @@ static int getMediaTypeID(char *rsc_name)
|
||||
|
||||
EPS_INT32 print_spool_fnc(void* hParam, const EPS_UINT8* pBuf, EPS_UINT32 cbBuf)
|
||||
{
|
||||
-#if 1
|
||||
+#if 0
|
||||
long int i;
|
||||
for (i = 0; i < cbBuf; i++)
|
||||
putc(*(pBuf + i), outfp);
|
||||
@@ -879,7 +899,7 @@ EPS_INT32 print_spool_fnc(void* hParam, const EPS_UINT
|
||||
|
||||
// fwrite (pBuf, cbBuf, 1, outfp);
|
||||
|
||||
- XFIFOWrite(context, pBuf, cbBuf);
|
||||
-// XFIFOWrite(context, pBuf, cbBuf);
|
||||
+ XFIFOWrite(context, (char *)pBuf, cbBuf);
|
||||
|
||||
return 1;
|
||||
|
@ -1,24 +1,56 @@
|
||||
[
|
||||
{ type: install
|
||||
message: <<EOM
|
||||
Examples to add printer for EP-803AW
|
||||
Start cupsd and then do the following:
|
||||
# Example to add printer
|
||||
This is an example of how to set up EP-803AW (white color EP-803A).
|
||||
|
||||
# The printer connected with USB cable (using ulpt0)
|
||||
1. start cupsd
|
||||
|
||||
lpadmin -p EPSON_EP-803AW -m "`lpinfo --make-and-model 'EPSON EP-803A' -m | cut -f 1 -w | grep escpr | head -n 1`" -v 'usb:/dev/ulpt0' -D 'EPSON EP-803AW (ulpt0)' -E
|
||||
service cupsd start
|
||||
|
||||
# The printer connected with USB cable (using unlpt0)
|
||||
2. find the PPD file for the printer
|
||||
|
||||
lpadmin -p EPSON_EP-803AW -m "`lpinfo --make-and-model 'EPSON EP-803A' -m | cut -f 1 -w | grep escpr | head -n 1`" -v 'usb:/dev/unlpt0' -D 'EPSON EP-803AW (unlpt0)' -E
|
||||
lpinfo --make-and-model 'EPSON EP-803A' -m
|
||||
|
||||
# The printer joined network (using LPD port)
|
||||
Use the first column.
|
||||
|
||||
lpadmin -p EPSON_EP-803AW -m "`lpinfo --make-and-model 'EPSON EP-803A' -m | cut -f 1 -w | grep escpr | head -n 1`" -v 'lpd://192.0.2.100:515/PASSTHRU' -D 'EPSON EP-803AW (LPR)' -E
|
||||
3. find the device-uri for the printer
|
||||
|
||||
# The printer joined network (using port 9100)
|
||||
lpinfo -v
|
||||
|
||||
lpadmin -p EPSON_EP-803AW -m "`lpinfo --make-and-model 'EPSON EP-803A' -m | cut -f 1 -w | grep escpr | head -n 1`" -v 'socket://192.0.2.100:9100' -D 'EPSON EP-803AW (RAW)' -E
|
||||
USB printer (using result returned by lpinfo)
|
||||
|
||||
usb://EPSON/EP-803A?serial=XXXXXXXXXXXXXXXXXX&interface=1
|
||||
|
||||
USB printer (using device node directly)
|
||||
|
||||
usb:/dev/ulpt0
|
||||
|
||||
If printer cannot handle the reset on open, use /dev/unlpt0 instead.
|
||||
|
||||
Network printer (using LPD Port)
|
||||
|
||||
lpd://192.0.2.100:515/PASSTHRU
|
||||
|
||||
Network printer (using PDL Data Streaming Port)
|
||||
|
||||
socket://192.0.2.100:9100
|
||||
|
||||
4. add the printer
|
||||
|
||||
The following is an example of a command to use LPD port.
|
||||
|
||||
lpadmin -p EPSON_EP-803AW \
|
||||
-m epson-inkjet-printer-escpr/Epson-EP-803A-epson-escpr-en.ppd \
|
||||
-v lpd://192.0.2.100:515/PASSTHRU \
|
||||
-D 'EPSON EP-803AW be careful of ink dripping :)'
|
||||
|
||||
Specify the name of the printer in option -p.
|
||||
Using the result of 2. for option -m.
|
||||
Using the result of 3. for option -v.
|
||||
Option -D is description of the printer.
|
||||
|
||||
* * *
|
||||
EOM
|
||||
}
|
||||
]
|
||||
|
@ -51,6 +51,7 @@ share/cups/model/epson-inkjet-printer-escpr/Epson-EP-709A_Series-epson-escpr-en.
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-710A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-711A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-712A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-713A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-774A-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-775A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-776A_Series-epson-escpr-en.ppd
|
||||
@ -66,6 +67,7 @@ share/cups/model/epson-inkjet-printer-escpr/Epson-EP-808A_Series-epson-escpr-en.
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-810A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-811A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-812A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-813A_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-901A-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-901F-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-902A-epson-escpr-en.ppd
|
||||
@ -82,6 +84,7 @@ share/cups/model/epson-inkjet-printer-escpr/Epson-EP-977A3_Series-epson-escpr-en
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-978A3_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-979A3_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-M552T_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-M553T_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EP-M570T_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-1110_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-16500_Series-epson-escpr-en.ppd
|
||||
|
Loading…
Reference in New Issue
Block a user