MFH: r474027 r474028

- Update to 0.13.68
- Security fixes for:
- CVE-2017-5974
- CVE-2017-5975
- CVE-2017-5976
- CVE-2017-5979
- CVE-2017-5980
- CVE-2017-5981
- CVE-2017-5977
- CVE-2018-6381
- CVE-2018-6484
- CVE-2018-6540
- CVE-2018-6541
- CVE-2018-6542
- CVE-2018-6869
- CVE-2018-7725
- CVE-2018-7726
- CVE-2018-7727

PR:	226491
Submitted by:	maintainer

- Added/RM missing patches

Approved by: ports-secteam
This commit is contained in:
Martin Wilke 2018-07-06 18:05:50 +00:00
parent 1f72d5f5d6
commit 844279adad
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q3/; revision=474029
8 changed files with 78 additions and 39 deletions

View File

@ -2,31 +2,35 @@
# $FreeBSD$
PORTNAME= zziplib
PORTVERSION= 0.13.62
PORTREVISION= 2
DISTVERSIONPREFIX= v
DISTVERSION= 0.13.69
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}13/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to provide transparent read access to zipped files
LICENSE= LGPL21 MPL11
LICENSE_COMB= dual
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LIB
LICENSE_FILE_MPL11= ${WRKSRC}/docs/COPYING.MPL
BUILD_DEPENDS= zip:archivers/zip
USES= libtool pathfix pkgconfig python:2.7,build tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_XMLTO=":"
USES= libtool pathfix pkgconfig python:2.7,build shebangfix
USE_GITHUB= yes
GH_ACCOUNT= gdraheim
GH_PROJECT= zziplib
USE_LDCONFIG= yes
SHEBANG_FILES= docs/*.py
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --srcdir=${WRKSRC}
INSTALL_TARGET= install-strip
TEST_TARGET= check
PORTSCOUT= limit:^0\.
OPTIONS_DEFINE= SDL
OPTIONS_SUB= yes
SDL_USE= SDL=sdl
SDL_CONFIGURE_ENABLE= sdl

View File

@ -1,2 +1,3 @@
SHA256 (zziplib-0.13.62.tar.bz2) = a1b8033f1a1fd6385f4820b01ee32d8eca818409235d22caf5119e0078c7525b
SIZE (zziplib-0.13.62.tar.bz2) = 685770
TIMESTAMP = 1521293451
SHA256 (gdraheim-zziplib-v0.13.69_GH0.tar.gz) = 846246d7cdeee405d8d21e2922c6e97f55f24ecbe3b6dcf5778073a88f120544
SIZE (gdraheim-zziplib-v0.13.69_GH0.tar.gz) = 1132204

View File

@ -1,6 +1,6 @@
--- configure.orig 2012-03-11 23:21:53.000000000 +0900
+++ configure 2012-03-12 17:46:25.000000000 +0900
@@ -11452,7 +11452,7 @@
--- configure.orig 2018-03-15 22:54:37 UTC
+++ configure
@@ -13077,7 +13077,7 @@ $as_echo_n "checking out linker version
if test "_$MICRO_VERSION" = "_" ; then MICRO_VERSION="0" ; fi
if test "_$MINOR_VERSION" = "_" ; then MINOR_VERSION="$MAJOR_VERSION" ; MAJOR_VERSION="0" ; fi
MINOR_VERSION=`echo "$MINOR_VERSION" | sed -e 's/[^0-9].*//'`
@ -9,7 +9,7 @@
VERSION_INFO="-version-info $MINOR_VERSION:$MICRO_VERSION"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: /$MAJOR_VERSION/$MINOR_VERSION:$MICRO_VERSION (-$MAJOR_VERSION.so.$MINOR_VERSION.0.$MICRO_VERSION)" >&5
$as_echo "/$MAJOR_VERSION/$MINOR_VERSION:$MICRO_VERSION (-$MAJOR_VERSION.so.$MINOR_VERSION.0.$MICRO_VERSION)" >&6; }
@@ -13733,12 +13733,12 @@
@@ -15430,12 +15430,12 @@ case "$host_os" in mingw*)
;; *)
if test ".$can_build_shared" != ".no" ; then
ZZIPLIB_LDFLAGS="-export-dynamic"

View File

@ -1,11 +0,0 @@
--- docs/Makefile.in.orig 2009-08-27 16:33:21.000000000 +0200
+++ docs/Makefile.in 2009-08-27 16:33:21.000000000 +0200
@@ -451,7 +451,7 @@ uninstall-am:
all : all-am default
-default : doc @MAINTAINER_MODE_FALSE@ mans
+default : @MAINTAINER_MODE_FALSE@ mans
clean-doc clean-docs : clean-unpack
- rm $(DISTCLEANFILES)
- rm $(MAINTAINERCLEANFILES)

View File

@ -0,0 +1,47 @@
--- docs/dbk2man.py.orig 2018-03-16 11:55:55 UTC
+++ docs/dbk2man.py
@@ -1,4 +1,4 @@
-#!/usr/local/bin/python2.7
+#! /usr/bin/python
""" Converts an xml-file with docbook elements into troff manual pages.
The conversion uses etree expecting <refentry> elements in the input.
The output goes to a multiple files in manX/* subdirectories.
@@ -223,22 +223,23 @@ def refentry2man(refentry, subdirectory
if found is not None: manvolnum = found.text
written = 0
section = refentry.find("refnamediv")
- for refname in section.findall("refname"):
- if not refentrytitle:
- refentrytitle = refname.text
- manpage = refname.text
- filename = "%s/man%s/%s.%s" % (subdirectory, manvolnum, manpage, manvolnum)
- if manpage != refentrytitle:
- manpagetext = ".so %s.%s\n" % (refentrytitle, manvolnum)
- writefile(filename, manpagetext)
- else:
- manpagetext = text
+ if section is not None:
+ for refname in section.findall("refname"):
+ if not refentrytitle:
+ refentrytitle = refname.text
+ manpage = refname.text
+ filename = "%s/man%s/%s.%s" % (subdirectory, manvolnum, manpage, manvolnum)
+ if manpage != refentrytitle:
+ manpagetext = ".so %s.%s\n" % (refentrytitle, manvolnum)
+ writefile(filename, manpagetext)
+ else:
+ manpagetext = text
+ writefile(filename, manpagetext)
+ written += 1
+ if not written:
+ manpage = refentrytitle
+ filename = "%s/man%s/%s.%s" % (subdirectory, manvolnum, manpage, manvolnum)
writefile(filename, manpagetext)
- written += 1
- if not written:
- manpage = refentrytitle
- filename = "%s/man%s/%s.%s" % (subdirectory, manvolnum, manpage, manvolnum)
- writefile(filename, manpagetext)
def writefile(filename, manpagetext):
dirname = os.path.dirname(filename)

View File

@ -1,6 +1,6 @@
--- zzip/Makefile.in.orig 2010-05-20 16:46:22.000000000 +0200
+++ zzip/Makefile.in 2010-05-20 16:47:02.000000000 +0200
@@ -694,7 +694,6 @@
--- zzip/Makefile.in.orig 2018-03-16 11:43:07 UTC
+++ zzip/Makefile.in
@@ -826,7 +826,6 @@ install-dvi-am:
install-exec-am: install-libLTLIBRARIES
@$(NORMAL_INSTALL)

View File

@ -3,4 +3,4 @@ It is based solely on free algorithms provided by zlib and can
transparently access files being either real files or zipped files
with the same file path argument.
WWW: http://zziplib.sourceforge.net/
WWW: https://github.com/gdraheim/zziplib

View File

@ -1,10 +1,8 @@
bin/unzip-mem
bin/unzzip
bin/unzzipcat
bin/unzzipcat-mem
bin/unzzipcat-seeko
bin/unzzipdir
bin/unzzipdir-mem
bin/unzzip-big
bin/unzzip-mem
bin/unzzip-mix
bin/zzcat
bin/zzdir
bin/zzxorcat
@ -37,19 +35,19 @@ include/zziplib.h
lib/libzzip.a
lib/libzzip.so
lib/libzzip.so.13
lib/libzzip.so.13.0.62
lib/libzzip.so.13.0.69
lib/libzzipfseeko.a
lib/libzzipfseeko.so
lib/libzzipfseeko.so.13
lib/libzzipfseeko.so.13.0.62
lib/libzzipfseeko.so.13.0.69
lib/libzzipmmapped.a
lib/libzzipmmapped.so
lib/libzzipmmapped.so.13
lib/libzzipmmapped.so.13.0.62
lib/libzzipmmapped.so.13.0.69
lib/libzzipwrap.a
lib/libzzipwrap.so
lib/libzzipwrap.so.13
lib/libzzipwrap.so.13.0.62
lib/libzzipwrap.so.13.0.69
%%SDL%%libdata/pkgconfig/SDL_rwops_zzip.pc
libdata/pkgconfig/zzip-zlib-config.pc
libdata/pkgconfig/zzipfseeko.pc
@ -64,7 +62,6 @@ man/man3/zzip_closedir.3.gz
man/man3/zzip_compr_str.3.gz
man/man3/zzip_dir_alloc.3.gz
man/man3/zzip_dir_alloc_ext_io.3.gz
man/man3/zzip_dir_close.3.gz
man/man3/zzip_dir_fdopen.3.gz
man/man3/zzip_dir_fdopen_ext_io.3.gz
man/man3/zzip_dir_free.3.gz
@ -116,6 +113,7 @@ man/man3/zzip_file_open.3.gz
man/man3/zzip_file_read.3.gz
man/man3/zzip_file_real.3.gz
man/man3/zzip_file_stat.3.gz
man/man3/zzip_filesize.3.gz
man/man3/zzip_fopen.3.gz
man/man3/zzip_fread.3.gz
man/man3/zzip_freopen.3.gz