MFH: r527810
textproc/py-textfsm: Update to 1.1.1 This update resolves a package installation conflict with textproc/py-texttable as both ports installs "texttable.py" into the same place. [1] Also while I'm here: * Switch to GitHub for a while as no sdist tarballs are available at PyPi. * Make the port concurrent safe because it installs scripts outside of the site-lib directory. * Remove the "testdata" directory to prevent possible package conflicts as it's only required for the test suite. * Add a "do-test" target to make future QA easier. Changelog: https://github.com/google/textfsm/releases/tag/v1.1.0 https://github.com/google/textfsm/releases/tag/v1.1.1 PR: 244257 Reported by: John Hein <jcfyecrayz@liamekaens.com> [1] Approved by: ports-secteam (joneum)
This commit is contained in:
parent
925e010fc9
commit
83eb67cb55
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q1/; revision=527813
@ -1,9 +1,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= textfsm
|
||||
DISTVERSION= 0.4.1
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.1.1
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= kai@FreeBSD.org
|
||||
@ -12,10 +12,21 @@ COMMENT= Parses semi-structured text into Python tables
|
||||
LICENSE= APACHE20
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= distutils autoplist
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= google
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
do-test:
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1523365433
|
||||
SHA256 (textfsm-0.4.1.tar.gz) = 21a31e212d625d84a8c7a52f35055d536bd3a1c63d3d41ed65ee5d8bd5f29f00
|
||||
SIZE (textfsm-0.4.1.tar.gz) = 38369
|
||||
TIMESTAMP = 1582272415
|
||||
SHA256 (google-textfsm-v1.1.1_GH0.tar.gz) = 9299d54544b679ef2a477c9256ec5e906c649f8f79593b71d2bb56e1c96e6601
|
||||
SIZE (google-textfsm-v1.1.1_GH0.tar.gz) = 51340
|
||||
|
13
textproc/py-textfsm/files/patch-setup.py
Normal file
13
textproc/py-textfsm/files/patch-setup.py
Normal file
@ -0,0 +1,13 @@
|
||||
Remove "testdata" directory from installation. It is only required for the
|
||||
testsuite.
|
||||
|
||||
--- setup.py.orig 2019-11-26 11:17:07 UTC
|
||||
+++ setup.py
|
||||
@@ -52,7 +52,6 @@ setup(name='textfsm',
|
||||
]
|
||||
},
|
||||
include_package_data=True,
|
||||
- package_data={'textfsm': ['../testdata/*']},
|
||||
install_requires=['six', 'future'],
|
||||
setup_requires=['pytest-runner'],
|
||||
tests_require=['pytest'])
|
Loading…
Reference in New Issue
Block a user