Fix build with gcc 3.x.

Noticed by:		kris/amd64 build
Approved by:		maintainer
Build tested on:	ia32
This commit is contained in:
Alexander Leidinger 2004-02-02 14:17:24 +00:00
parent 5da5196c0a
commit 83d7454729
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99811
18 changed files with 203 additions and 0 deletions

View File

@ -0,0 +1,11 @@
--- authenticate/Makefile.in.orig Mon Feb 2 14:47:40 2004
+++ authenticate/Makefile.in Mon Feb 2 14:49:35 2004
@@ -93,7 +93,7 @@
EXTRA_DIST = $(man_MANS) $(noinst_HTMLS) $(noinst_PODS)
-CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
+CXXLINK = $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@
INCLUDES = $(CIINCLUDES) -I../lib
checkvpw_SOURCES = checkvpw.cc authvlib.cc authvlib.h

View File

@ -0,0 +1,10 @@
--- ./authenticate/authvmailmgr.cc.orig Mon Feb 2 14:45:25 2004
+++ ./authenticate/authvmailmgr.cc Mon Feb 2 14:45:40 2004
@@ -15,6 +15,7 @@
// Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#include <config.h>
+#include <string.h>
#include "misc/exec.h"
#include "authvlib.h"
// Courier-IMAP includes

View File

@ -0,0 +1,10 @@
--- authenticate/checkvpw.cc.orig Mon Feb 2 14:51:35 2004
+++ authenticate/checkvpw.cc Mon Feb 2 14:51:55 2004
@@ -16,6 +16,7 @@
#include <config.h>
#include <errno.h>
+#include <stdlib.h>
#include <string.h>
#include <sys/types.h>
#include "config/configrc.h"

View File

@ -0,0 +1,10 @@
--- authenticate/vauthenticate.cc.orig Mon Feb 2 14:53:58 2004
+++ authenticate/vauthenticate.cc Mon Feb 2 14:54:10 2004
@@ -16,6 +16,7 @@
#include <config.h>
#include <errno.h>
+#include <stdlib.h>
#include <unistd.h>
#include "authvlib.h"
#include "fdbuf/fdbuf.h"

View File

@ -0,0 +1,11 @@
--- cgi/Makefile.in.orig Mon Feb 2 15:09:56 2004
+++ cgi/Makefile.in Mon Feb 2 15:10:07 2004
@@ -86,7 +86,7 @@
cgi_PROGRAMS = vpasswd vadduser vdeluser vaddalias vchattr vchforwards listvdomain
-CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
+CXXLINK = $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@
INCLUDES = -I../lib
vpasswd_SOURCES = vpasswd.cc

View File

@ -0,0 +1,11 @@
--- commands/Makefile.in.orig Mon Feb 2 14:57:14 2004
+++ commands/Makefile.in Mon Feb 2 14:57:24 2004
@@ -99,7 +99,7 @@
EXTRA_PROGRAMS = vpasswd2cdb vrehash
EXTRA_SCRIPTS = allvpasswd2cdb
-CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
+CXXLINK = $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@
INCLUDES = -I../lib -DBINDIR=\"@bindir@\"
listvdomain_SOURCES = listvdomain.cc vcommand.cc

View File

@ -0,0 +1,17 @@
--- commands/vcheckquota.cc.orig Mon Feb 2 15:00:41 2004
+++ commands/vcheckquota.cc Mon Feb 2 15:01:15 2004
@@ -31,10 +31,10 @@
const char* cli_program = "vcheckquota";
const char* cli_help_prefix = "vmailmgr quota enforcement program\n";
-const char* cli_help_suffix = "
-Warning: the soft-message is linked into the users maildir once for each
-message that is received while the account is over its soft quota. This may
-result in multiple warning messages.\n";
+const char* cli_help_suffix = "\n"
+"Warning: the soft-message is linked into the users maildir once for each\n"
+"message that is received while the account is over its soft quota. This may\n"
+"result in multiple warning messages.\n";
const char* cli_args_usage = "";
const int cli_args_min = 0;
const int cli_args_max = 0;

View File

@ -0,0 +1,12 @@
--- commands/vchforwards.cc.orig Mon Feb 2 14:58:55 2004
+++ commands/vchforwards.cc Mon Feb 2 14:59:29 2004
@@ -25,8 +25,7 @@
const char* cli_help_prefix =
"Change virtual user forwarding addresses.\n";
const char* cli_help_suffix =
-"If no forwarding addresses are given, forwarding is disabled.
-";
+"If no forwarding addresses are given, forwarding is disabled.\n";
const char* cli_args_usage = "USERNAME [DESTINATION1 ...]";
const int cli_args_min = 1;
const int cli_args_max = -1;

View File

@ -0,0 +1,15 @@
--- commands/vpasswd2cdb.cc.orig Mon Feb 2 14:55:24 2004
+++ commands/vpasswd2cdb.cc Mon Feb 2 14:56:26 2004
@@ -27,9 +27,9 @@
const char* cli_program = "vpasswd2cdb";
const char* cli_help_prefix = "Converts text password tables to CDB format\n";
const char* cli_help_suffix =
-"Reads in a standard virtual password table in the current directory,
-and writes it out to a CDB table. The file names for the text and CDB
-tables are determined from the configuration file.";
+"Reads in a standard virtual password table in the current directory,\n"
+"and writes it out to a CDB table. The file names for the text and CDB\n"
+"tables are determined from the configuration file.";
const char* cli_args_usage = "";
const int cli_args_min = 0;
const int cli_args_max = 0;

View File

@ -0,0 +1,15 @@
--- commands/vpasswd2db.cc.orig Mon Feb 2 15:02:15 2004
+++ commands/vpasswd2db.cc Mon Feb 2 15:02:33 2004
@@ -26,9 +26,9 @@
const char* cli_program = "vpasswd2db";
const char* cli_help_prefix = "Converts text password tables to current vpwtable DB format\n";
const char* cli_help_suffix =
-"Reads in a standard virtual password table in the current directory,
-and writes it out to a table. The file names for the input and output
-tables are determined from the configuration file.";
+"Reads in a standard virtual password table in the current directory,\n"
+"and writes it out to a table. The file names for the input and output\n"
+"tables are determined from the configuration file.";
const char* cli_args_usage = "";
const int cli_args_min = 0;
const int cli_args_max = 0;

View File

@ -0,0 +1,11 @@
--- daemon/Makefile.in.orig Mon Feb 2 15:06:13 2004
+++ daemon/Makefile.in Mon Feb 2 15:06:27 2004
@@ -91,7 +91,7 @@
EXTRA_DIST = $(man_MANS) $(noinst_HTMLS) $(noinst_PODS)
-CXXLINK = $(CC) $(CXXFLAGS) $(LDFLAGS) -o $@
+CXXLINK = $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@
INCLUDES = -I../lib
vmailmgrd_SOURCES = daemon.h adduser2.cc autoresponse.cc chattr.cc check.cc command.h command.cc deluser.cc dispatch.cc listdomain.cc log.h log.cc lookup.cc main.cc state.h state.cc

View File

@ -0,0 +1,10 @@
--- ./lib/courier-authlib/changeuidgid.c.orig Mon Feb 2 14:43:32 2004
+++ ./lib/courier-authlib/changeuidgid.c Mon Feb 2 14:43:57 2004
@@ -12,6 +12,7 @@
#endif
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include <grp.h>
#include <pwd.h>
#include <errno.h>

View File

@ -0,0 +1,12 @@
--- lib/fdbuf/fdbuf.h.orig Mon Feb 2 14:40:11 2004
+++ lib/fdbuf/fdbuf.h Mon Feb 2 14:40:38 2004
@@ -25,6 +25,9 @@
#include <pthread.h>
#endif
+#include <unistd.h>
+#include <sys/types.h>
+
#ifndef FDBUF_SIZE
#define FDBUF_SIZE 4096
#endif

View File

@ -0,0 +1,10 @@
--- lib/misc/exec.cc.orig Mon Feb 2 14:31:16 2004
+++ lib/misc/exec.cc Mon Feb 2 14:31:41 2004
@@ -17,6 +17,7 @@
#include <config.h>
#include <errno.h>
#include <stdlib.h>
+#include <string.h>
#include <sys/stat.h>
#include <sys/types.h>
#include <sys/wait.h>

View File

@ -0,0 +1,10 @@
--- lib/misc/keystrlist.cc.orig Mon Feb 2 14:33:33 2004
+++ lib/misc/keystrlist.cc Mon Feb 2 14:33:55 2004
@@ -15,6 +15,7 @@
// Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#include <config.h>
+#include <string.h>
#include "strlist.h"
void keystrlist::set(const mystring& var, const mystring& val)

View File

@ -0,0 +1,10 @@
--- lib/misc/server.cc.orig Mon Feb 2 14:37:29 2004
+++ lib/misc/server.cc Mon Feb 2 14:37:47 2004
@@ -17,6 +17,7 @@
#include <config.h>
#include "server.h"
#include <stdlib.h>
+#include <string.h>
#include <unistd.h>
#include "un.h"
#include "debug.h"

View File

@ -0,0 +1,10 @@
--- lib/misc/strlist.cc.orig Mon Feb 2 14:38:26 2004
+++ lib/misc/strlist.cc Mon Feb 2 14:38:45 2004
@@ -15,6 +15,7 @@
// Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#include <config.h>
+#include <string.h>
#include "strlist.h"
static const char* compare(const char* ptr, const char* end,

View File

@ -0,0 +1,8 @@
--- lib/mystring/append.cc.orig Mon Feb 2 14:41:33 2004
+++ lib/mystring/append.cc Mon Feb 2 14:41:52 2004
@@ -1,3 +1,5 @@
+#include <string.h>
+
#include "mystring.h"
#include "trace.h"