update irc/ircII to 20190117
PR: 238176 Approved by: maintainer (andrew at tao11 dot riddles dot org dot uk)
This commit is contained in:
parent
55205f16a4
commit
83b331ae55
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=503606
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ircii
|
||||
PORTVERSION= 20170704
|
||||
PORTVERSION= 20190117
|
||||
CATEGORIES= irc ipv6
|
||||
MASTER_SITES= http://ircii.warped.com/
|
||||
|
||||
@ -12,6 +12,7 @@ COMMENT= Small and high extensible IRC client
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-warnings
|
||||
DATADIR= ${PREFIX}/share/irc
|
||||
USES= iconv ncurses tar:bzip2
|
||||
|
||||
@ -38,7 +39,7 @@ LDFLAGS+= -L${ICONV_PREFIX}/lib
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^mandir =/s/@mandir@/$${DESTDIR}&/' \
|
||||
-e '/^LDFLAGS =/s/$$/ -s ${ICONV_LIB}/' \
|
||||
-e '/^LDFLAGS =/s/$$/ ${STRIP} ${ICONV_LIB}/' \
|
||||
-e '/^INCLUDES =/s|$$| -I${ICONV_PREFIX}/include -DHAVE_ICONV_OPEN|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|PREFIX/|${PREFIX}/|' ${WRKSRC}/doc/ircII.1
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1541878948
|
||||
SHA256 (ircii-20170704.tar.bz2) = 4e5a70fc4577de06fd5855ab7ca0a501fd16e02d5fd34e434a2b5abac80a2eda
|
||||
SIZE (ircii-20170704.tar.bz2) = 596535
|
||||
TIMESTAMP = 1558984067
|
||||
SHA256 (ircii-20190117.tar.bz2) = 10316f0a3723e4ce3d67fd5a7df10e6bcf30dd0750fb96d5437cacb16b0e9617
|
||||
SIZE (ircii-20190117.tar.bz2) = 606327
|
||||
|
11
irc/ircII/files/patch-source_alias.c
Normal file
11
irc/ircII/files/patch-source_alias.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- source/alias.c.orig 2019-01-18 10:29:41 UTC
|
||||
+++ source/alias.c
|
||||
@@ -2528,7 +2528,7 @@ function_userhost(u_char *input)
|
||||
static u_char *
|
||||
function_strip(u_char *input)
|
||||
{
|
||||
- u_char tmpbuf[128], *result;
|
||||
+ u_char tmpbuf[128], *result = NULL;
|
||||
u_char *retval = NULL;
|
||||
u_char *chars;
|
||||
u_char *cp, *dp;
|
11
irc/ircII/files/patch-source_help.c
Normal file
11
irc/ircII/files/patch-source_help.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- source/help.c.orig 2019-05-29 09:55:50 UTC
|
||||
+++ source/help.c
|
||||
@@ -311,7 +311,7 @@ help_topic(u_char *path, u_char *name)
|
||||
#ifdef ZCAT
|
||||
if (my_strcmp(name + (my_strlen(name) - my_strlen(ZSUFFIX)), ZSUFFIX))
|
||||
{
|
||||
- malloc_snprintf(&filename, "%s/%s%s", path, ZSUFFIX);
|
||||
+ malloc_snprintf(&filename, "%s/%s%s", path, name, ZSUFFIX);
|
||||
if (stat(CP(filename), &sb) == -1)
|
||||
{
|
||||
new_free(&filename);
|
@ -1,14 +0,0 @@
|
||||
--- source/mksiginc.c.orig 2014-03-17 20:38:51 UTC
|
||||
+++ source/mksiginc.c
|
||||
@@ -35,7 +35,11 @@ IRCII_RCSID("@(#)$eterna: mksiginc.c,v 1
|
||||
#define NSIG 64
|
||||
#endif
|
||||
|
||||
+#if defined(SIGRTMAX) && (SIGRTMAX > NSIG)
|
||||
+#define MY_MAXSIG SIGRTMAX+1
|
||||
+#else
|
||||
#define MY_MAXSIG NSIG+1
|
||||
+#endif
|
||||
char *signames[MY_MAXSIG];
|
||||
|
||||
int main(int, char *[]);
|
@ -117,6 +117,7 @@ man/man1/ircII.1.gz
|
||||
%%HELP%%%%DATADIR%%/help/exit
|
||||
%%HELP%%%%DATADIR%%/help/expressions
|
||||
%%HELP%%%%DATADIR%%/help/flush
|
||||
%%HELP%%%%DATADIR%%/help/for
|
||||
%%HELP%%%%DATADIR%%/help/foreach
|
||||
%%HELP%%%%DATADIR%%/help/help
|
||||
%%HELP%%%%DATADIR%%/help/history
|
||||
@ -128,7 +129,11 @@ man/man1/ircII.1.gz
|
||||
%%HELP%%%%DATADIR%%/help/input
|
||||
%%HELP%%%%DATADIR%%/help/intro
|
||||
%%HELP%%%%DATADIR%%/help/invite
|
||||
%%HELP%%%%DATADIR%%/help/ircii/command_line_args
|
||||
%%HELP%%%%DATADIR%%/help/ircii/copyright
|
||||
%%HELP%%%%DATADIR%%/help/ircii/environment_vars
|
||||
%%HELP%%%%DATADIR%%/help/ircii/programming
|
||||
%%HELP%%%%DATADIR%%/help/ircii/server_lists
|
||||
%%HELP%%%%DATADIR%%/help/ison
|
||||
%%HELP%%%%DATADIR%%/help/join
|
||||
%%HELP%%%%DATADIR%%/help/kick
|
||||
@ -288,11 +293,9 @@ man/man1/ircII.1.gz
|
||||
%%HELP%%%%DATADIR%%/help/on/send_msg
|
||||
%%HELP%%%%DATADIR%%/help/on/send_notice
|
||||
%%HELP%%%%DATADIR%%/help/on/send_public
|
||||
%%HELP%%%%DATADIR%%/help/on/send_talk
|
||||
%%HELP%%%%DATADIR%%/help/on/serial_numbers
|
||||
%%HELP%%%%DATADIR%%/help/on/server_notice
|
||||
%%HELP%%%%DATADIR%%/help/on/signoff
|
||||
%%HELP%%%%DATADIR%%/help/on/talk
|
||||
%%HELP%%%%DATADIR%%/help/on/timer
|
||||
%%HELP%%%%DATADIR%%/help/on/topic
|
||||
%%HELP%%%%DATADIR%%/help/on/wall
|
||||
|
Loading…
Reference in New Issue
Block a user