emulators/yuzu: update to s20201214

Changes:	4e94d0d53...df6427d30
This commit is contained in:
Jan Beich 2020-12-15 00:45:32 +00:00
parent 53ca8d5051
commit 83aaa608e7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=558119
3 changed files with 22 additions and 15 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= yuzu
PORTVERSION= s20201209
PORTVERSION= s20201214
PORTREVISION?= 0
CATEGORIES= emulators
@ -35,7 +35,7 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
USE_GITHUB= yes
GH_ACCOUNT= yuzu-emu
GH_TAGNAME= 4e94d0d53
GH_TAGNAME= df6427d30
GH_TUPLE= DarkLordZach:mbedtls:a280e60:mbedtls/externals/mbedtls \
KhronosGroup:SPIRV-Headers:2c51218:SPIRV_Headers/externals/sirit/externals/SPIRV-Headers \
KhronosGroup:Vulkan-Headers:v1.2.145:Vulkan_Headers/externals/Vulkan-Headers \

View File

@ -1,8 +1,8 @@
TIMESTAMP = 1607552709
TIMESTAMP = 1607990918
SHA256 (libcxx-10.0.1.src.tar.xz) = def674535f22f83131353b3c382ccebfef4ba6a35c488bdb76f10b68b25be86c
SIZE (libcxx-10.0.1.src.tar.xz) = 1839172
SHA256 (yuzu-emu-yuzu-s20201209-4e94d0d53_GH0.tar.gz) = d0cae8f80196bd4704ed44bd1682327584c14547596110874d1c44809fee39b8
SIZE (yuzu-emu-yuzu-s20201209-4e94d0d53_GH0.tar.gz) = 4054043
SHA256 (yuzu-emu-yuzu-s20201214-df6427d30_GH0.tar.gz) = 4eca1a122ab52024fc9a467183c5354a0a311baf079e54ff8969105c8f62b531
SIZE (yuzu-emu-yuzu-s20201214-df6427d30_GH0.tar.gz) = 4057966
SHA256 (DarkLordZach-mbedtls-a280e60_GH0.tar.gz) = 4fc6ddc256bc75b975fd5ad8bb7d31ff79c62d49daafb0108585c9ef80c6c5a7
SIZE (DarkLordZach-mbedtls-a280e60_GH0.tar.gz) = 2283313
SHA256 (KhronosGroup-SPIRV-Headers-2c51218_GH0.tar.gz) = 08f70947b69e17c7e322156adcd471cf02b4b3f63e7baf8ee0f02d32603ac5ff

View File

@ -1,16 +1,23 @@
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246106
CMake Warning at /usr/local/share/cmake/Modules/FindBoost.cmake:2023 (message):
No header defined for headers; skipping header check (note: header-only
libraries have no designated component)
Call Stack (most recent call first):
CMakeLists.txt:199 (find_package)
-- Boost 1.73.0 or newer not found, falling back to Conan
-- Could NOT find Boost: Found unsuitable version "1.72.0", but required is at least "1.73" (found /usr/local/include)
-- Packages boost/1.73.0 not found!
--- CMakeLists.txt.orig 2020-08-10 17:53:43 UTC
--- CMakeLists.txt.orig 2020-12-13 07:42:14 UTC
+++ CMakeLists.txt
@@ -159,7 +159,7 @@ macro(yuzu_find_packages)
# Capitalization matters here. We need the naming to match the generated paths from Conan
set(REQUIRED_LIBS
# Cmake Pkg Prefix Version Conan Pkg
- "Boost 1.73 boost/1.73.0"
+ "Boost 1.72 boost/1.72.0"
"Catch2 2.13 catch2/2.13.0"
"fmt 7.0 fmt/7.0.3"
# can't use until https://github.com/bincrafters/community/issues/1173
@@ -195,7 +195,7 @@ macro(yuzu_find_packages)
endmacro()
if (NOT Boost_FOUND)
- find_package(Boost 1.73.0 COMPONENTS context headers QUIET)
+ find_package(Boost 1.72.0 COMPONENTS context headers QUIET)
if (Boost_FOUND)
set(Boost_LIBRARIES Boost::boost Boost::context)
endif()