cad/py-cadquery: create port

CadQuery is an intuitive, easy-to-use Python module for building parametric 3D
CAD models. Using CadQuery, you can write short, simple scripts that produce
high quality CAD models. It is easy to make many different objects using a
single script that can be customized.

WWW: https://github.com/CadQuery/cadquery

PR:		248210
Submitted by:	Neal Nelson <ports@nicandneal.net>
This commit is contained in:
Steve Wills 2020-08-16 12:54:13 +00:00
parent e5e1215114
commit 8398ee71c0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=545104
4 changed files with 49 additions and 0 deletions

29
cad/py-cadquery/Makefile Normal file
View File

@ -0,0 +1,29 @@
# $FreeBSD$
PORTNAME= cadquery
DISTVERSION= 2.0.1
CATEGORIES= cad
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@nicandneal.net
COMMENT= Python module for building parametric 3D CAD models
LICENSE= APACHE20
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ezdxf/__init__.py:cad/py-ezdxf@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/OCP.so:cad/py-ocp@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/pyparsing.py:devel/py-pyparsing@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/typing_extensions.py:devel/py-typing-extensions@${PY_FLAVOR}
USES= python:3.6+,run
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= CadQuery
GH_PROJECT= cadquery
post-extract:
# Move into a sub-directory so that we don't pollute site-packages.
${MV} ${WRKSRC}/tests ${WRKSRC}/cadquery/tests
.include <bsd.port.mk>

3
cad/py-cadquery/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1595406745
SHA256 (CadQuery-cadquery-2.0.1_GH0.tar.gz) = 7e126628a3928af42f9a86f2f0efd3ea2b143f9f9c14603a26ac76c25d1596b1
SIZE (CadQuery-cadquery-2.0.1_GH0.tar.gz) = 1835724

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2020-06-25 14:36:51 UTC
+++ setup.py
@@ -35,7 +35,7 @@ setup(
"cadquery.contrib",
"cadquery.occ_impl",
"cadquery.plugins",
- "tests",
+ "cadquery.tests",
],
include_package_data=True,
zip_safe=False,

View File

@ -0,0 +1,6 @@
CadQuery is an intuitive, easy-to-use Python module for building parametric 3D
CAD models. Using CadQuery, you can write short, simple scripts that produce
high quality CAD models. It is easy to make many different objects using a
single script that can be customized.
WWW: https://github.com/CadQuery/cadquery