Update to 1.0.2
PR: ports/39485 Submitted by: KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
parent
ea103f8b13
commit
837e8ef30f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61533
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= paragui
|
||||
PORTVERSION= 1.0.1
|
||||
PORTVERSION= 1.0.2
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ftp://ftp.bms-austria.com/pub/paragui/release/
|
||||
|
||||
@ -21,7 +21,8 @@ LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
|
||||
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
@ -34,10 +35,10 @@ post-extract:
|
||||
@${RM} -f ${WRKSRC}/src/physfs/platform.c
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's|LT_CURRENT=.*$$|LT_CURRENT=${SHLIB_VER}|g ; \
|
||||
${REINPLACE_CMD} -e 's|LT_CURRENT=.*$$|LT_CURRENT=${SHLIB_VER}|g ; \
|
||||
s|`sdl-config |`\$$\{SDL_CONFIG\} |g' ${WRKSRC}/configure
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
|
||||
's|\$$\(SDL_CFLAGS\)|\$$\(PARAGUI_CFLAGS\)|g ; \
|
||||
s|-release \$$\(LT_RELEASE\)||g'
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[$][(]SDL_CFLAGS[)]|\$\(PARAGUI_CFLAGS\)|g ; \
|
||||
s|lib/pkgconfig|libdata/pkgconfig|g'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (paragui-1.0.1.tar.gz) = d08bc4f48600fabcfa03e796c3bc04d5
|
||||
MD5 (paragui-1.0.2.tar.gz) = 57ca321ef8222d7f8ce55ad620adf63c
|
||||
|
10
x11-toolkits/paragui-devel/files/patch-configure
Normal file
10
x11-toolkits/paragui-devel/files/patch-configure
Normal file
@ -0,0 +1,10 @@
|
||||
--- configure.orig Mon Jun 10 18:05:42 2002
|
||||
+++ configure Tue Jun 18 20:05:24 2002
|
||||
@@ -5618,6 +5618,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
@ -1,41 +0,0 @@
|
||||
--- ltmain.sh.orig Mon Feb 11 17:35:31 2002
|
||||
+++ ltmain.sh Fri Mar 1 06:01:48 2002
|
||||
@@ -1056,14 +1056,14 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -2494,7 +2494,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
@@ -4281,10 +4281,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -13,6 +13,7 @@ include/paragui/pgdatacontainer.h
|
||||
include/paragui/pgdraw.h
|
||||
include/paragui/pgdropdown.h
|
||||
include/paragui/pgeventobject.h
|
||||
include/paragui/pgtimerobject.h
|
||||
include/paragui/pgfile.h
|
||||
include/paragui/pgfilearchive.h
|
||||
include/paragui/pgfont.h
|
||||
@ -50,7 +51,7 @@ include/paragui/pgwindow.h
|
||||
lib/libparagui.a
|
||||
lib/libparagui.so
|
||||
lib/libparagui.so.%%SHLIB_VER%%
|
||||
lib/pkgconfig/paragui.pc
|
||||
libdata/pkgconfig/paragui.pc
|
||||
share/aclocal/paragui.m4
|
||||
share/paragui/default.zip
|
||||
share/paragui/simple.zip
|
||||
|
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= paragui
|
||||
PORTVERSION= 1.0.1
|
||||
PORTVERSION= 1.0.2
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ftp://ftp.bms-austria.com/pub/paragui/release/
|
||||
|
||||
@ -21,7 +21,8 @@ LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
|
||||
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
|
||||
@ -34,10 +35,10 @@ post-extract:
|
||||
@${RM} -f ${WRKSRC}/src/physfs/platform.c
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's|LT_CURRENT=.*$$|LT_CURRENT=${SHLIB_VER}|g ; \
|
||||
${REINPLACE_CMD} -e 's|LT_CURRENT=.*$$|LT_CURRENT=${SHLIB_VER}|g ; \
|
||||
s|`sdl-config |`\$$\{SDL_CONFIG\} |g' ${WRKSRC}/configure
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
|
||||
's|\$$\(SDL_CFLAGS\)|\$$\(PARAGUI_CFLAGS\)|g ; \
|
||||
s|-release \$$\(LT_RELEASE\)||g'
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|[$][(]SDL_CFLAGS[)]|\$\(PARAGUI_CFLAGS\)|g ; \
|
||||
s|lib/pkgconfig|libdata/pkgconfig|g'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (paragui-1.0.1.tar.gz) = d08bc4f48600fabcfa03e796c3bc04d5
|
||||
MD5 (paragui-1.0.2.tar.gz) = 57ca321ef8222d7f8ce55ad620adf63c
|
||||
|
10
x11-toolkits/paragui/files/patch-configure
Normal file
10
x11-toolkits/paragui/files/patch-configure
Normal file
@ -0,0 +1,10 @@
|
||||
--- configure.orig Mon Jun 10 18:05:42 2002
|
||||
+++ configure Tue Jun 18 20:05:24 2002
|
||||
@@ -5618,6 +5618,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
@ -1,41 +0,0 @@
|
||||
--- ltmain.sh.orig Mon Feb 11 17:35:31 2002
|
||||
+++ ltmain.sh Fri Mar 1 06:01:48 2002
|
||||
@@ -1056,14 +1056,14 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -2494,7 +2494,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
@@ -4281,10 +4281,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -13,6 +13,7 @@ include/paragui/pgdatacontainer.h
|
||||
include/paragui/pgdraw.h
|
||||
include/paragui/pgdropdown.h
|
||||
include/paragui/pgeventobject.h
|
||||
include/paragui/pgtimerobject.h
|
||||
include/paragui/pgfile.h
|
||||
include/paragui/pgfilearchive.h
|
||||
include/paragui/pgfont.h
|
||||
@ -50,7 +51,7 @@ include/paragui/pgwindow.h
|
||||
lib/libparagui.a
|
||||
lib/libparagui.so
|
||||
lib/libparagui.so.%%SHLIB_VER%%
|
||||
lib/pkgconfig/paragui.pc
|
||||
libdata/pkgconfig/paragui.pc
|
||||
share/aclocal/paragui.m4
|
||||
share/paragui/default.zip
|
||||
share/paragui/simple.zip
|
||||
|
Loading…
Reference in New Issue
Block a user