Antoine Brodin 2015-07-25 17:09:01 +00:00
parent 584922bc73
commit 836aa8d7d1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=392900
4 changed files with 19 additions and 28 deletions

View File

@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= plaso
PORTVERSION= 1.2.0
PORTREVISION= 1
PORTVERSION= 1.3.0
CATEGORIES= security python
MASTER_SITES= https://googledrive.com/host/0B30H7z4S52FleW5vUHBnblJfcjg/${PORTVERSION}/final/ \
MASTER_SITES= https://github.com/log2timeline/plaso/releases/download/${PORTVERSION}/ \
LOCAL/antoine
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -25,6 +24,7 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
libmsiecf>=a:${PORTSDIR}/devel/libmsiecf \
libolecf>=a:${PORTSDIR}/devel/libolecf \
libregf>=a:${PORTSDIR}/devel/libregf \
${PYTHON_PKGNAMEPREFIX}artifacts>=0:${PORTSDIR}/security/py-artifacts \
${PYTHON_PKGNAMEPREFIX}bencode>=0:${PORTSDIR}/converters/py-bencode \
${PYTHON_PKGNAMEPREFIX}binplist>=0:${PORTSDIR}/devel/py-binplist \
${PYTHON_PKGNAMEPREFIX}construct>=0:${PORTSDIR}/devel/py-construct \
@ -33,6 +33,7 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
${PYTHON_PKGNAMEPREFIX}dpkt>=0:${PORTSDIR}/net/py-dpkt \
${PYTHON_PKGNAMEPREFIX}ipython>=0:${PORTSDIR}/devel/ipython \
${PYTHON_PKGNAMEPREFIX}parsing>=0:${PORTSDIR}/devel/py-parsing \
${PYTHON_PKGNAMEPREFIX}pefile>=0:${PORTSDIR}/devel/py-pefile \
${PYTHON_PKGNAMEPREFIX}protobuf>=0:${PORTSDIR}/devel/py-protobuf \
${PYTHON_PKGNAMEPREFIX}psutil121>=0:${PORTSDIR}/sysutils/py-psutil121 \
${PYTHON_PKGNAMEPREFIX}pyelasticsearch>=0:${PORTSDIR}/textproc/py-pyelasticsearch \
@ -45,17 +46,6 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
USES= python:2
USE_PYTHON= distutils autoplist
PORTDOCS= ACKNOWLEDGEMENTS AUTHORS README
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/extra/* ${STAGEDIR}${EXAMPLESDIR}
# Note: for regression tests set LANG to en_US.UTF-8
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (plaso-1.2.0.tar.gz) = f6b073fbf967fbdc32cecae0f78ad26d4fa666e6f238304e796d8f3b5550b327
SIZE (plaso-1.2.0.tar.gz) = 40215055
SHA256 (plaso-1.3.0.tar.gz) = 2f73876ee716464a0593ffc92651ac6445413f15ae096f8e68193597a98db9fa
SIZE (plaso-1.3.0.tar.gz) = 110383339

View File

@ -1,11 +1,11 @@
--- plaso/output/elastic.py.orig 2014-12-20 17:43:35 UTC
--- plaso/output/elastic.py.orig 2015-06-09 20:25:30 UTC
+++ plaso/output/elastic.py
@@ -81,6 +81,8 @@ class Elastic(output.LogOutputFormatter)
elastic_port = getattr(config, 'elastic_port', 9200)
@@ -135,6 +135,8 @@ class ElasticSearchOutputModule(interfac
"""
self._elastic_db = pyelasticsearch.ElasticSearch(
u'http://{0:s}:{1:d}'.format(elastic_host, elastic_port))
+ logging.getLogger('elasticsearch.trace').setLevel(logging.WARNING)
+ logging.getLogger('elasticsearch').setLevel(logging.WARNING)
case_name = getattr(config, 'case_name', u'')
document_type = getattr(config, 'document_type', u'')
def WriteEventBody(self, event_object):
"""Writes the body of an event object to the output.

View File

@ -1,9 +1,10 @@
--- setup.py.orig 2014-12-20 17:43:35 UTC
--- setup.py.orig 2015-06-15 05:38:55 UTC
+++ setup.py
@@ -119,5 +119,5 @@ setup(
'Programming Language :: Python',
@@ -104,7 +104,6 @@ setup(
},
data_files=[
('share/plaso', glob.glob(os.path.join('data', '*'))),
- ('share/doc/plaso', glob.glob(os.path.join('docs', '*'))),
],
package_dir={'plaso': 'plaso'},
- packages=find_packages('.'),
+ packages=find_packages('.', exclude=['test_data', 'tools']),
)
# TODO: this is disabled for now since setup.py will actually try
# to install the depencies directly from pypi.