x11-wm/compton-yshui: add new port
Actively maintained fork of Compton (X11 compositor). Will be renamed to Picom during the next update. PR: 241216 Tested by: jsm, q5sys Reviewed by: danfe (previous version)
This commit is contained in:
parent
33940ea93f
commit
836865a044
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=516059
@ -26,6 +26,7 @@
|
||||
SUBDIR += compizconfig-backend-gconf
|
||||
SUBDIR += compizconfig-python
|
||||
SUBDIR += compton
|
||||
SUBDIR += compton-yshui
|
||||
SUBDIR += ctwm
|
||||
SUBDIR += cwm
|
||||
SUBDIR += devilspie
|
||||
|
77
x11-wm/compton-yshui/Makefile
Normal file
77
x11-wm/compton-yshui/Makefile
Normal file
@ -0,0 +1,77 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= compton
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 7.4
|
||||
CATEGORIES= x11-wm
|
||||
PKGNAMESUFFIX= -yshui
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES+= bd5a5fb56812.patch:-p1 065f9ffd4d35.patch:-p1
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= Lightweight X11 compositor
|
||||
|
||||
LICENSE= MIT MPL20
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_FILE_MIT= ${WRKSRC}/LICENSES/MIT
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:devel/uthash
|
||||
LIB_DEPENDS= libev.so:devel/libev \
|
||||
libxcb-image.so:x11/xcb-util-image \
|
||||
libxcb-render-util.so:x11/xcb-util-renderutil
|
||||
RUN_DEPENDS= xprop:x11/xprop \
|
||||
xwininfo:x11/xwininfo
|
||||
|
||||
CONFLICTS_INSTALL= compton # bin/compton
|
||||
|
||||
USES= compiler:c11 meson localbase pkgconfig python:3.4+,run shebangfix
|
||||
USE_GITHUB= yes
|
||||
USE_XORG= x11 xcb xext pixman
|
||||
GH_ACCOUNT= yshui
|
||||
SHEBANG_FILES= bin/compton-convgen.py
|
||||
MESON_ARGS= -Dunittest=true
|
||||
TEST_TARGET= test
|
||||
|
||||
OPTIONS_DEFINE= CONFIG DBUS DOCS DRM OPENGL PCRE
|
||||
OPTIONS_DEFAULT=CONFIG DBUS OPENGL PCRE
|
||||
|
||||
CONFIG_DESC= Configuration file parsing support
|
||||
CONFIG_LIB_DEPENDS= libconfig.so:devel/libconfig \
|
||||
libxdg-basedir.so:x11/libxdg-basedir
|
||||
CONFIG_MESON_TRUE= config_file
|
||||
|
||||
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
|
||||
PCRE_MESON_TRUE= regex
|
||||
|
||||
DRM_DESC= DRM VSync fallback (deprecated)
|
||||
DRM_LIB_DEPENDS= libdrm.so:graphics/libdrm
|
||||
DRM_MESON_TRUE= vsync_drm
|
||||
|
||||
OPENGL_USE= GL=gl
|
||||
OPENGL_MESON_TRUE= opengl
|
||||
|
||||
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
|
||||
DBUS_MESON_TRUE= dbus
|
||||
|
||||
DOCS_BUILD_DEPENDS= a2x:textproc/asciidoc
|
||||
DOCS_MESON_TRUE= build_docs
|
||||
DOCS_PLIST_FILES= man/man1/${PORTNAME}.1.gz \
|
||||
man/man1/${PORTNAME}-trans.1.gz
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/install_dir/s,share/man,man,' \
|
||||
${WRKSRC}/man/meson.build
|
||||
@${REINPLACE_CMD} -e '/config_system_dir/s,/etc,${PREFIX}&,' \
|
||||
${WRKSRC}/src/config_libconfig.c
|
||||
# Extract (snapshot) version from the port instead of meson.build
|
||||
@${REINPLACE_CMD} -i .nogit -e 's/git.found()/false/' \
|
||||
-e "/project_version/s/=.*/= '${DISTVERSIONFULL}'/" \
|
||||
${WRKSRC}/meson.build
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/etc/xdg
|
||||
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.sample.conf \
|
||||
${STAGEDIR}${PREFIX}/etc/xdg/${PORTNAME}.conf.sample
|
||||
|
||||
.include <bsd.port.mk>
|
7
x11-wm/compton-yshui/distinfo
Normal file
7
x11-wm/compton-yshui/distinfo
Normal file
@ -0,0 +1,7 @@
|
||||
TIMESTAMP = 1569024480
|
||||
SHA256 (yshui-compton-v7.4_GH0.tar.gz) = 1911aebb49f765586f655933ee016828e126bc7b2bb016b13c9a34a4865a8fd3
|
||||
SIZE (yshui-compton-v7.4_GH0.tar.gz) = 218899
|
||||
SHA256 (bd5a5fb56812.patch) = a7e29d526517f05fb90f3a6415ef08108ba45865175a676f50376ef8d0e10a7f
|
||||
SIZE (bd5a5fb56812.patch) = 680
|
||||
SHA256 (065f9ffd4d35.patch) = 5d6d687c9ee1eb6ab7a9d39636bb85c4aac7d36ad13433ac66885914ff2e2944
|
||||
SIZE (065f9ffd4d35.patch) = 10209
|
21
x11-wm/compton-yshui/files/patch-src_log.c
Normal file
21
x11-wm/compton-yshui/files/patch-src_log.c
Normal file
@ -0,0 +1,21 @@
|
||||
Drop after FreeBSD 11 EOL, other systems had timespec_get() for years.
|
||||
|
||||
../src/log.c:162:20: error: use of undeclared identifier 'TIME_UTC'
|
||||
timespec_get(&ts, TIME_UTC);
|
||||
^
|
||||
log.c:(.text+0x1db): undefined reference to `timespec_get'
|
||||
|
||||
--- src/log.c.orig 2019-09-21 00:08:00 UTC
|
||||
+++ src/log.c
|
||||
@@ -159,7 +159,11 @@ attr_printf(4, 5) void log_printf(struct log *l, int l
|
||||
}
|
||||
|
||||
struct timespec ts;
|
||||
+#ifdef TIME_UTC
|
||||
timespec_get(&ts, TIME_UTC);
|
||||
+#else
|
||||
+ clock_gettime(CLOCK_REALTIME, &ts);
|
||||
+#endif
|
||||
auto tm = localtime(&ts.tv_sec);
|
||||
char time_buf[100];
|
||||
strftime(time_buf, sizeof time_buf, "%x %T", tm);
|
15
x11-wm/compton-yshui/pkg-descr
Normal file
15
x11-wm/compton-yshui/pkg-descr
Normal file
@ -0,0 +1,15 @@
|
||||
Compton is a standalone compositor for X11 for window managers without
|
||||
built-in compositing. This is an actively maintained fork of Compton.
|
||||
|
||||
Features:
|
||||
- Rendering with optional VSync via OpenGL or XRender
|
||||
- Transparent windows, menus, titlebars, borders
|
||||
- Shadows and colored shadows
|
||||
- Fading effects
|
||||
- Bluring of background
|
||||
- GLSL fragment shader for window contents
|
||||
- Conditional settings
|
||||
- Config, log and PID file support
|
||||
- Remote control via DBus
|
||||
|
||||
WWW: https://github.com/yshui/compton
|
7
x11-wm/compton-yshui/pkg-plist
Normal file
7
x11-wm/compton-yshui/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
bin/compton
|
||||
bin/compton-convgen.py
|
||||
bin/compton-trans
|
||||
@sample etc/xdg/compton.conf.sample
|
||||
share/applications/compton.desktop
|
||||
share/icons/hicolor/48x48/apps/compton.png
|
||||
share/icons/hicolor/scalable/apps/compton.svg
|
@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
RUN_DEPENDS= xprop:x11/xprop \
|
||||
xwininfo:x11/xwininfo
|
||||
|
||||
CONFLICTS_INSTALL= compton-yshui # bin/compton
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= chjj
|
||||
GH_TAGNAME= b7f43ee
|
||||
|
Loading…
Reference in New Issue
Block a user