Update to 0.64.0.

This commit is contained in:
Maxim Sobolev 2001-02-19 20:41:40 +00:00
parent d634eb0bd7
commit 834910eb61
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38492
8 changed files with 48 additions and 60 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= windowmaker
PORTVERSION= 0.63.1
PORTVERSION= 0.64.0
CATEGORIES= x11-wm windowmaker
MASTER_SITES= ${MASTER_SITE_WINDOWMAKER} \
http://jgo.local.net/cool_downloads/wm/ \
@ -19,14 +19,12 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libfreetype.a:${PORTSDIR}/print/freetype2
LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
PropList.2:${PORTSDIR}/devel/libPropList \
intl.1:${PORTSDIR}/devel/gettext \
freetype.6:${PORTSDIR}/print/freetype2
intl.1:${PORTSDIR}/devel/gettext
USE_BZIP2= yes
USE_PERL5= yes
@ -37,7 +35,7 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= X11BASE=${X11BASE} \
LIBS=-L${LOCALBASE}/lib \
CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2" \
CPPFLAGS="-I${LOCALBASE}/include" \
LINGUAS="${LINGUAS}"
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \

View File

@ -1,3 +1,3 @@
MD5 (WindowMaker-0.63.1.tar.bz2) = 681de0bf984a370236f3f0e56848392b
MD5 (libwmfun-0.63.1.tar.bz2) = 9fb998465fafab4a8b6ab404285896e9
MD5 (WindowMaker-0.64.0.tar.bz2) = f03a6e99eb62c6edc2b452b7d6c54edb
MD5 (libwmfun-0.64.0.tar.bz2) = b0066a2444c413567c9185adf37fd05b
MD5 (WindowMaker-extra-0.1.tar.bz2) = e6fb381da0d207c320f58e7a1fea2a2b

View File

@ -1 +1 @@
bg cs da de el es fi fr gl hr hu it ja ko nl no pl pt ro ru se sk tr zh_CN zh_TW.Big5
bg cs da de el es fi fr gl hr hu it ja ko nl no pl pt ro ru sk sv tr zh_CN zh_TW.Big5

View File

@ -1,22 +1,23 @@
--- configure.orig Thu Jan 4 12:10:11 2001
+++ configure Thu Jan 4 12:30:57 2001
@@ -5897,7 +5897,8 @@
$FreeBSD$
--- configure.orig Sat Feb 10 21:46:34 2001
+++ configure Mon Feb 19 21:14:48 2001
@@ -5897,7 +5897,7 @@
WindowMaker/Icons/Makefile WindowMaker/Pixmaps/Makefile \
WindowMaker/Styles/Makefile WindowMaker/Themes/Makefile \
WPrefs.app/Makefile WPrefs.app/tiff/Makefile WPrefs.app/xpm/Makefile \
- WPrefs.app/po/Makefile contrib/WindowMaker.spec src/config.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
+ WPrefs.app/po/Makefile \
+ plugins/libwmfun/Makefile contrib/WindowMaker.spec src/config.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
- WPrefs.app/po/Makefile \
+ WPrefs.app/po/Makefile plugins/libwmfun/Makefile \
contrib/Makefile contrib/WindowMaker.spec src/config.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
EOF
cat >> $CONFIG_STATUS <<EOF
@@ -6030,7 +6031,8 @@
@@ -6032,7 +6032,7 @@
WindowMaker/Icons/Makefile WindowMaker/Pixmaps/Makefile \
WindowMaker/Styles/Makefile WindowMaker/Themes/Makefile \
WPrefs.app/Makefile WPrefs.app/tiff/Makefile WPrefs.app/xpm/Makefile \
- WPrefs.app/po/Makefile contrib/WindowMaker.spec "}
+ WPrefs.app/po/Makefile \
+ plugins/libwmfun/Makefile contrib/WindowMaker.spec "}
- WPrefs.app/po/Makefile \
+ WPrefs.app/po/Makefile plugins/libwmfun/Makefile \
contrib/Makefile contrib/WindowMaker.spec "}
EOF
cat >> $CONFIG_STATUS <<\EOF
for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then

View File

@ -1,5 +1,8 @@
--- plugins/libwmfun/Makefile.in.orig Thu Jan 4 12:16:06 2001
+++ plugins/libwmfun/Makefile.in Fri Jan 5 12:47:05 2001
$FreeBSD$
--- plugins/libwmfun/Makefile.in.orig Mon Feb 19 21:10:18 2001
+++ plugins/libwmfun/Makefile.in Mon Feb 19 21:20:52 2001
@@ -38,7 +38,7 @@
pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
@ -23,9 +26,9 @@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
-libwmfun_la_LIBADD =
+libwmfun_la_LIBADD = -lfreetype
+libwmfun_la_LIBADD =
libwmfun_la_OBJECTS = bilinear.lo fade.lo generic.lo getopt.lo \
getopt1.lo wave.lo drawstring.lo
getopt1.lo wave.lo
CFLAGS = @CFLAGS@
@@ -107,12 +109,12 @@
all: all-redirect

View File

@ -1,11 +0,0 @@
--- plugins/libwmfun/drawstring.c 2001/01/09 16:22:05 1.1
+++ plugins/libwmfun/drawstring.c 2001/01/09 16:22:54
@@ -4,7 +4,7 @@
#include "generic.h"
#ifdef USE_FREETYPE
-#include <freetype/freetype.h>
+#include <freetype2/freetype/freetype.h>
#endif
#define MAX_GLYPHS 256

View File

@ -1,24 +1,14 @@
--- util/wmaker.inst.in 2001/01/08 01:41:27 1.1
+++ util/wmaker.inst.in 2001/01/08 01:48:25
@@ -65,12 +65,18 @@
elif [ "$file" = "WMRootMenu" ]; then
if [ "$LOCALE" ]; then
if [ -f $GLOBALDIR/plmenu.${LOCALE%_*} ]; then
- cp $GLOBALDIR/plmenu.${LOCALE%_*} $GSDIR/Defaults/WMRootMenu
+ sed -e "s|\$HOME/GNUstep|$GSDIR|g" \
+ -e "s:#wmdatadir#:$GLOBALDIR:g" \
+ $GLOBALDIR/plmenu.${LOCALE%_*} > $GSDIR/Defaults/WMRootMenu
else
- cp $GLOBALDIR/plmenu $GSDIR/Defaults/WMRootMenu
+ sed -e "s|\$HOME/GNUstep|$GSDIR|g" \
+ -e "s:#wmdatadir#:$GLOBALDIR:g" \
+ $GLOBALDIR/plmenu > $GSDIR/Defaults/WMRootMenu
fi
else
- cp $GLOBALDIR/plmenu $GSDIR/Defaults/WMRootMenu
+ sed -e "s|\$HOME/GNUstep|$GSDIR|g" \
+ -e "s:#wmdatadir#:$GLOBALDIR:g" \
+ $GLOBALDIR/plmenu > $GSDIR/Defaults/WMRootMenu
fi
else
if test "x$GNUSTEP_USER_ROOT" = "x"; then
$FreeBSD$
--- util/wmaker.inst.in 2001/02/19 20:05:14 1.1
+++ util/wmaker.inst.in 2001/02/19 20:05:29
@@ -293,7 +293,7 @@
echo "menu that will be used by default is the property list one. Read"
echo " $GSDIR/Library/WindowMaker/README"
echo "for information on how to change it."
- if [ "${inst_menu%.*}" == "menu" ]; then
+ if [ "${inst_menu%.*}" = "menu" ]; then
echo "However, since you have locale set to $LOCALE and plmenu for such locale"
echo "was not found, your WMRootMenu contains path to text formated menu:"
echo " $GSDIR/Library/WindowMaker/$inst_menu"

View File

@ -72,12 +72,14 @@ bin/geticonset
bin/getstyle
bin/seticons
bin/setstyle
bin/wdread
bin/wdwrite
bin/wkdemenu.pl
bin/wm-oldmenu2new
bin/wmagnify
bin/wmaker
bin/wmaker.inst
bin/wmchlocale
bin/wmsetbg
bin/wmsetup
bin/wsetfont
@ -318,6 +320,7 @@ share/WindowMaker/menu.pt
share/WindowMaker/menu.ro
share/WindowMaker/menu.ru
share/WindowMaker/menu.se
share/WindowMaker/menu.sk
share/WindowMaker/menu.sl
share/WindowMaker/menu.tr
share/WindowMaker/menu.zh_CN
@ -334,6 +337,7 @@ share/WindowMaker/plmenu.it
share/WindowMaker/plmenu.ko
share/WindowMaker/plmenu.pl
share/WindowMaker/plmenu.ro
share/WindowMaker/plmenu.sk
share/WindowMaker/plmenu.zh_CN
share/WindowMaker/wmmacros
share/WindowMaker/xtree.dat
@ -354,6 +358,8 @@ share/locale/fr/LC_MESSAGES/WindowMaker.mo
share/locale/gl/LC_MESSAGES/WindowMaker.mo
share/locale/hr/LC_MESSAGES/WPrefs.mo
share/locale/hr/LC_MESSAGES/WindowMaker.mo
share/locale/hu/LC_MESSAGES/WPrefs.mo
share/locale/hu/LC_MESSAGES/WindowMaker.mo
share/locale/it/LC_MESSAGES/WPrefs.mo
share/locale/it/LC_MESSAGES/WindowMaker.mo
share/locale/ja/LC_MESSAGES/WPrefs.mo
@ -368,8 +374,9 @@ share/locale/pt/LC_MESSAGES/WindowMaker.mo
share/locale/ro/LC_MESSAGES/WindowMaker.mo
share/locale/ru/LC_MESSAGES/WPrefs.mo
share/locale/ru/LC_MESSAGES/WindowMaker.mo
share/locale/se/LC_MESSAGES/WindowMaker.mo
share/locale/sk/LC_MESSAGES/WPrefs.mo
share/locale/sk/LC_MESSAGES/WindowMaker.mo
share/locale/sv/LC_MESSAGES/WindowMaker.mo
share/locale/tr/LC_MESSAGES/WindowMaker.mo
share/locale/zh_CN/LC_MESSAGES/WPrefs.mo
share/locale/zh_CN/LC_MESSAGES/WindowMaker.mo