emulators/simh-hp3000: fix the build with LLVM 11.
Similar to the patch for emulators/simh-hp2100, drop an -fcommon in to fix the build in the face of GCC 10 / LLVM 11 switching the default to -fno-common. Minor cleanup while we're here, remove USES= compiler and just use ${CC} for the compiler. PR: 248872 MFH: 2020Q3 (-fno-common build fix)
This commit is contained in:
parent
70e88083b5
commit
834586c272
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=546866
@ -22,7 +22,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/share/doc/hpdoc/simh_doc.pdf:emulators/simh-hpdoc
|
||||
|
||||
USES= compiler gmake dos2unix zip
|
||||
USES= gmake dos2unix zip
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
@ -34,7 +34,7 @@ SUB_FILES= hp3000.1
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC}; GCC=${CHOSEN_COMPILER_TYPE} ${GMAKE} -C SCP hp3000)
|
||||
(cd ${WRKSRC}; GCC=${CC} ${GMAKE} -C SCP hp3000)
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/hp3000 ${STAGEDIR}${PREFIX}/bin
|
||||
|
17
emulators/simh-hp3000/files/patch-SCP_makefile
Normal file
17
emulators/simh-hp3000/files/patch-SCP_makefile
Normal file
@ -0,0 +1,17 @@
|
||||
--- SCP/makefile.orig 2020-08-23 21:58:56 UTC
|
||||
+++ SCP/makefile
|
||||
@@ -532,10 +532,12 @@ ifneq ($(DONT_USE_READER_THREAD),)
|
||||
endif
|
||||
|
||||
|
||||
-# Shut up annoying clang default warnings.
|
||||
+# Shut up annoying clang default warnings, and also fix
|
||||
+# multiply defined symbols on clang 11 and above
|
||||
|
||||
-ifeq ($(GCC),clang)
|
||||
+ifeq ($(findstring clang,$(COMPILER_NAME)),clang)
|
||||
OS_CCDEFS += -Wno-parentheses -Wno-bitwise-op-parentheses -Wno-dangling-else
|
||||
+ CFLAGS_O += -fcommon
|
||||
endif
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user