Version 3.1
2016-12-31 * Fix kenwood_set_mode for ts590s and mode CW, RTTY or AM. Tks Tom, DL1JBE * Proper IPV6 and dual stack networking. Bill, G4WJS * Add a new command line option '--no-restore-ai' ('-n') to rigctl. Bill, G4WJS * Fix missing PKTUSB mode setting code for FT-817 & FT-897. Bill, G4WJS * New Prosistel rotor backend from IZ7CRX * Install daemon man files to man1. Nate, N0NB * Migrate from libusb-0.1 to libusb-1.0. Stephane, F8CFE * Added support for Icom IC-2730. robinolejnik * Added support for the Icom IC-7300. Mike, W9MDB * Add send_morse to icom rigs. Mike, W9MDB * added instructions how to compile on OSX. DH1TW * New Perseus model. Stephane, F8CFE * Added Lua binding and demo script. Ervin, HA2OS * Added test to support Flex 6300. Bill, KB4AAA * Many bug fixes and feature enhancements to the code base. See the Git commit log for complete details.
This commit is contained in:
parent
2b3da0ea3a
commit
82e25d4166
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=430233
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= hamlib
|
||||
PORTVERSION= 3.0.1
|
||||
PORTVERSION= 3.1
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (hamlib-3.0.1.tar.gz) = 3fec97ea326d02aa8f35834c4af34194a3f544e6212f391397d788c566b44e32
|
||||
SIZE (hamlib-3.0.1.tar.gz) = 2074254
|
||||
TIMESTAMP = 1483233776
|
||||
SHA256 (hamlib-3.1.tar.gz) = 682304c3e88ff6ccfd6a5fc28b33bcc95d2d0a54321973fef015ff62570c994e
|
||||
SIZE (hamlib-3.1.tar.gz) = 2130615
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- bindings/Makefile.am.orig 2015-09-25 20:06:24 UTC
|
||||
--- bindings/Makefile.am.orig 2017-01-01 01:25:57 UTC
|
||||
+++ bindings/Makefile.am
|
||||
@@ -120,7 +120,7 @@ MOSTLYCLEANFILES+= hamlibtcl_wrap.c pkgI
|
||||
|
||||
tcl_ltlib = hamlibtcl.la
|
||||
|
||||
-tcldir = $(libdir)/tcl/Hamlib
|
||||
+tcldir = %%TCL_LIBDIR%%/Hamlib
|
||||
+tcldir = /usr/local/lib/tcl8.6/Hamlib
|
||||
|
||||
PKG_VER=@ABI_VERSION@.@ABI_REVISION@
|
||||
DLL=hamlibtcl-$(PKG_VER)@TCL_SHLIB_SUFFIX@
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- bindings/rotator.swg.orig 2015-09-19 12:08:54 UTC
|
||||
+++ bindings/rotator.swg
|
||||
@@ -29,7 +29,7 @@ typedef struct Rot {
|
||||
int do_exception;
|
||||
} Rot;
|
||||
|
||||
-typedef const char * const_char_string;
|
||||
+//typedef const char * const_char_string;
|
||||
|
||||
%}
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- hamlib.pc.in.orig 2015-10-02 13:17:24 UTC
|
||||
--- hamlib.pc.in.orig 2016-12-31 20:01:25 UTC
|
||||
+++ hamlib.pc.in
|
||||
@@ -7,7 +7,6 @@ Name: @PACKAGE_NAME@
|
||||
Description: Library to control radio and rotator equipment.
|
||||
|
@ -16,13 +16,13 @@ lib/libhamlib++.a
|
||||
lib/libhamlib++.la
|
||||
lib/libhamlib++.so
|
||||
lib/libhamlib++.so.2
|
||||
lib/libhamlib++.so.2.1.0
|
||||
lib/libhamlib.so.2.1.0
|
||||
lib/libhamlib++.so.2.1.1
|
||||
lib/libhamlib.so.2.1.1
|
||||
lib/libhamlib.a
|
||||
lib/libhamlib.la
|
||||
lib/libhamlib.so
|
||||
lib/libhamlib.so.2
|
||||
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl-3.0.so
|
||||
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl-%%VER%%.so
|
||||
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.la
|
||||
lib/tcl%%TCL_VER%%/Hamlib/pkgIndex.tcl
|
||||
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.a
|
||||
@ -53,9 +53,9 @@ share/aclocal/hamlib.m4
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Hamlib_design.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/hamlib.html
|
||||
man/man1/rigctl.1.gz
|
||||
man/man1/rigctld.1.gz
|
||||
man/man1/rigmem.1.gz
|
||||
man/man1/rigsmtr.1.gz
|
||||
man/man1/rigswr.1.gz
|
||||
man/man1/rotctl.1.gz
|
||||
man/man8/rigctld.8.gz
|
||||
man/man8/rotctld.8.gz
|
||||
man/man1/rotctld.1.gz
|
||||
|
Loading…
Reference in New Issue
Block a user