MFH: r551700

devel/liblpm: fix build on GCC architectures

Patching fails, just use newer GCC.

Approved by:	portmgr (fix build blanket)
This commit is contained in:
Piotr Kubaj 2020-10-20 18:01:50 +00:00
parent 39feb53263
commit 82a16dad35
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q4/; revision=552837
2 changed files with 2 additions and 24 deletions

View File

@ -10,7 +10,7 @@ COMMENT= Longest Prefix Match library
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/../LICENSE
USES= compiler gmake libtool:build
USES= compiler:c11 gmake libtool:build
USE_GITHUB= yes
GH_ACCOUNT= rmind
@ -29,10 +29,4 @@ PLIST_FILES= include/lpm.h \
lib/liblpm.so.1 \
lib/liblpm.so.1.0.0
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == gcc
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-Makefile
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,16 +0,0 @@
--- Makefile.orig 2019-05-18 16:55:32 UTC
+++ Makefile
@@ -11,13 +11,10 @@ CFLAGS+= -D_GNU_SOURCE -D_DEFAULT_SOURCE
#
# Extended warning flags.
#
-CFLAGS+= -Wno-unknown-warning-option # gcc vs clang
-
CFLAGS+= -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith
CFLAGS+= -Wmissing-declarations -Wredundant-decls -Wnested-externs
CFLAGS+= -Wshadow -Wcast-qual -Wcast-align -Wwrite-strings
CFLAGS+= -Wold-style-definition
-CFLAGS+= -Wsuggest-attribute=noreturn -Wjump-misses-init
# New GCC 6/7 flags:
#CFLAGS+= -Wduplicated-cond -Wmisleading-indentation -Wnull-dereference