lang/python311: update to 3.11.0a3
This commit is contained in:
parent
a7a0468919
commit
826c8bace1
@ -2,4 +2,4 @@
|
||||
|
||||
# Do not forget to update python documentation (lang/python-doc-*)
|
||||
# Run "make -C lang/python-doc-html makesum"
|
||||
PYTHON_DISTVERSION= 3.11.0a2
|
||||
PYTHON_DISTVERSION= 3.11.0a3
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1637148409
|
||||
SHA256 (python/Python-3.11.0a2.tar.xz) = 68a8c4d6ce2548a7b617d699fbdb348937bdace0cf96db1aa083849df5dad13f
|
||||
SIZE (python/Python-3.11.0a2.tar.xz) = 18714064
|
||||
TIMESTAMP = 1640120345
|
||||
SHA256 (python/Python-3.11.0a3.tar.xz) = 96fbe735d377dec46a007974d1315868bde9f06aea5e56dee99500d620d814a3
|
||||
SIZE (python/Python-3.11.0a3.tar.xz) = 18775072
|
||||
|
@ -1,9 +1,9 @@
|
||||
# Description: Remove duplicate CFLAGS, CPPFLAGS, LDFLAGS by stripping CONFIGURE_*
|
||||
# Submitted by: koobs (r326729)
|
||||
# TODO: Upstream
|
||||
--- Makefile.pre.in.orig 2019-11-04 01:16:37 UTC
|
||||
--- Makefile.pre.in.orig 2021-12-21 21:06:26 UTC
|
||||
+++ Makefile.pre.in
|
||||
@@ -80,7 +80,6 @@ MAKESETUP= $(srcdir)/Modules/makesetup
|
||||
@@ -81,7 +81,6 @@ MAKESETUP= $(srcdir)/Modules/makesetup
|
||||
OPT= @OPT@
|
||||
BASECFLAGS= @BASECFLAGS@
|
||||
BASECPPFLAGS= @BASECPPFLAGS@
|
||||
@ -11,10 +11,10 @@
|
||||
# CFLAGS_NODIST is used for building the interpreter and stdlib C extensions.
|
||||
# Use it when a compiler flag should _not_ be part of the distutils CFLAGS
|
||||
# once Python is installed (Issue #21121).
|
||||
@@ -89,18 +88,16 @@ CONFIGURE_CFLAGS_NODIST=@CFLAGS_NODIST@
|
||||
# Use it when a linker flag should _not_ be part of the distutils LDFLAGS
|
||||
# once Python is installed (bpo-35257)
|
||||
CONFIGURE_LDFLAGS_NODIST=@LDFLAGS_NODIST@
|
||||
@@ -93,18 +92,16 @@ CONFIGURE_LDFLAGS_NODIST=@LDFLAGS_NODIST@
|
||||
# LDFLAGS_NOLTO is an extra flag to disable lto. It is used to speed up building
|
||||
# of _bootstrap_python and _freeze_module tools, which don't need LTO.
|
||||
CONFIGURE_LDFLAGS_NOLTO=@LDFLAGS_NOLTO@
|
||||
-CONFIGURE_CPPFLAGS= @CPPFLAGS@
|
||||
-CONFIGURE_LDFLAGS= @LDFLAGS@
|
||||
# Avoid assigning CFLAGS, LDFLAGS, etc. so users can use them on the
|
||||
@ -31,9 +31,9 @@
|
||||
+PY_CPPFLAGS= $(BASECPPFLAGS) -I. -I$(srcdir)/Include $(CPPFLAGS)
|
||||
+PY_LDFLAGS= $(LDFLAGS)
|
||||
PY_LDFLAGS_NODIST=$(CONFIGURE_LDFLAGS_NODIST) $(LDFLAGS_NODIST)
|
||||
PY_LDFLAGS_NOLTO=$(PY_LDFLAGS) $(CONFIGURE_LDFLAGS_NOLTO) $(LDFLAGS_NODIST)
|
||||
NO_AS_NEEDED= @NO_AS_NEEDED@
|
||||
SGI_ABI= @SGI_ABI@
|
||||
@@ -1269,14 +1266,6 @@ bininstall: altbininstall
|
||||
@@ -1768,14 +1765,6 @@ bininstall: altbininstall
|
||||
else true; \
|
||||
fi
|
||||
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python3$(EXE))
|
||||
@ -48,7 +48,7 @@
|
||||
-rm -f $(DESTDIR)$(BINDIR)/python3-config
|
||||
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python3-config)
|
||||
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
|
||||
@@ -1580,6 +1569,14 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
@@ -2129,6 +2118,14 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
$(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
|
||||
$(INSTALL_SCRIPT) python-config.py $(DESTDIR)$(LIBPL)/python-config.py
|
||||
$(INSTALL_SCRIPT) python-config $(DESTDIR)$(BINDIR)/python$(LDVERSION)-config
|
||||
|
@ -90,6 +90,7 @@ include/python%%XYDOT%%%%ABI%%/internal/pycore_fileutils.h
|
||||
include/python%%XYDOT%%%%ABI%%/internal/pycore_floatobject.h
|
||||
include/python%%XYDOT%%%%ABI%%/internal/pycore_format.h
|
||||
include/python%%XYDOT%%%%ABI%%/internal/pycore_frame.h
|
||||
include/python%%XYDOT%%%%ABI%%/internal/pycore_function.h
|
||||
include/python%%XYDOT%%%%ABI%%/internal/pycore_gc.h
|
||||
include/python%%XYDOT%%%%ABI%%/internal/pycore_getopt.h
|
||||
include/python%%XYDOT%%%%ABI%%/internal/pycore_gil.h
|
||||
@ -884,7 +885,9 @@ lib/python%%XYDOT%%/concurrent/futures/process.py
|
||||
lib/python%%XYDOT%%/concurrent/futures/thread.py
|
||||
lib/python%%XYDOT%%/config-%%XYDOT%%%%ABI%%/Makefile
|
||||
lib/python%%XYDOT%%/config-%%XYDOT%%%%ABI%%/Setup
|
||||
lib/python%%XYDOT%%/config-%%XYDOT%%%%ABI%%/Setup.bootstrap
|
||||
lib/python%%XYDOT%%/config-%%XYDOT%%%%ABI%%/Setup.local
|
||||
lib/python%%XYDOT%%/config-%%XYDOT%%%%ABI%%/Setup.stdlib
|
||||
lib/python%%XYDOT%%/config-%%XYDOT%%%%ABI%%/config.c
|
||||
lib/python%%XYDOT%%/config-%%XYDOT%%%%ABI%%/config.c.in
|
||||
lib/python%%XYDOT%%/config-%%XYDOT%%%%ABI%%/install-sh
|
||||
@ -2937,9 +2940,9 @@ lib/python%%XYDOT%%/lib-dynload/xxlimited.cpython-%%XY%%%%ABI%%.so
|
||||
lib/python%%XYDOT%%/lib-dynload/xxlimited_35.cpython-%%XY%%%%ABI%%.so
|
||||
lib/python%%XYDOT%%/lib-dynload/zlib.cpython-%%XY%%%%ABI%%.so
|
||||
lib/python%%XYDOT%%/lib2to3/Grammar.txt
|
||||
lib/python%%XYDOT%%/lib2to3/Grammar%%XYZDOT%%.alpha.2.pickle
|
||||
lib/python%%XYDOT%%/lib2to3/Grammar%%XYZDOT%%.alpha.3.pickle
|
||||
lib/python%%XYDOT%%/lib2to3/PatternGrammar.txt
|
||||
lib/python%%XYDOT%%/lib2to3/PatternGrammar%%XYZDOT%%.alpha.2.pickle
|
||||
lib/python%%XYDOT%%/lib2to3/PatternGrammar%%XYZDOT%%.alpha.3.pickle
|
||||
lib/python%%XYDOT%%/lib2to3/__init__.py
|
||||
lib/python%%XYDOT%%/lib2to3/__main__.py
|
||||
lib/python%%XYDOT%%/lib2to3/__pycache__/__init__.cpython-%%XY%%.opt-1.pyc
|
||||
@ -4191,6 +4194,9 @@ lib/python%%XYDOT%%/test/__pycache__/test_getopt.cpython-%%XY%%.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_getpass.cpython-%%XY%%.opt-1.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_getpass.cpython-%%XY%%.opt-2.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_getpass.cpython-%%XY%%.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_getpath.cpython-%%XY%%.opt-1.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_getpath.cpython-%%XY%%.opt-2.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_getpath.cpython-%%XY%%.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_gettext.cpython-%%XY%%.opt-1.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_gettext.cpython-%%XY%%.opt-2.pyc
|
||||
lib/python%%XYDOT%%/test/__pycache__/test_gettext.cpython-%%XY%%.pyc
|
||||
@ -5897,6 +5903,7 @@ lib/python%%XYDOT%%/test/test_genexps.py
|
||||
lib/python%%XYDOT%%/test/test_getargs2.py
|
||||
lib/python%%XYDOT%%/test/test_getopt.py
|
||||
lib/python%%XYDOT%%/test/test_getpass.py
|
||||
lib/python%%XYDOT%%/test/test_getpath.py
|
||||
lib/python%%XYDOT%%/test/test_gettext.py
|
||||
lib/python%%XYDOT%%/test/test_glob.py
|
||||
lib/python%%XYDOT%%/test/test_global.py
|
||||
|
Loading…
Reference in New Issue
Block a user