MFH: r555176

math/labplot: update to 2.8.1

We’re happy to announce the availability of the first minor patch release of
the big release we made two months ago. This release contains minor
improvements and bug fixes only.

Announcement:
	https://labplot.kde.org/2020/11/13/labplot-2-8-1-released/

Approved by:	ports-secteam (fluffy)
This commit is contained in:
Tobias C. Berner 2020-11-15 09:42:15 +00:00
parent dbf77d7000
commit 82543bde99
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q4/; revision=555179
4 changed files with 7 additions and 81 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= labplot
DISTVERSION= 2.8.0
DISTVERSION= 2.8.1
CATEGORIES= math kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1600793535
SHA256 (labplot-2.8.0.tar.xz) = 8957c708ea572d9b7bfd7bdd1e9627bb1e10717c4b8cb10c7687ca6ca187a705
SIZE (labplot-2.8.0.tar.xz) = 13117804
TIMESTAMP = 1605430703
SHA256 (labplot-2.8.1.tar.xz) = 726909a8335921c742c4d92f66663ecdb447ddee0d74568c50a22330c79e079a
SIZE (labplot-2.8.1.tar.xz) = 13203288

View File

@ -1,76 +0,0 @@
From 4255438c98ce274a4bbb381b706b6ba5b41816c7 Mon Sep 17 00:00:00 2001
From: Stefan Gerlach <stefan.gerlach@uni-konstanz.de>
Date: Mon, 14 Sep 2020 16:56:37 +0200
Subject: [PATCH] [cantor] 20.08.1 still uses old code & minor formating fixes
---
CMakeLists.txt | 2 +-
src/backend/gsl/parser.y | 2 +-
src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp | 2 +-
src/kdefrontend/widgets/ExpressionTextEdit.cpp | 8 ++++----
4 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33b407046..57ad46dd8 100644
--- CMakeLists.txt
+++ CMakeLists.txt
@@ -230,7 +230,7 @@ IF (Cantor_FOUND)
ELSE ()
MESSAGE (STATUS "Cantor Library ${Cantor_VERSION} TOO OLD. Minimum usable version is 19.12")
ENDIF ()
- IF (${Cantor_VERSION} VERSION_GREATER "20.08")
+ IF (${Cantor_VERSION} VERSION_GREATER "20.08.3")
add_definitions (-DHAVE_NEW_CANTOR_LIBS)
ENDIF ()
ELSE ()
diff --git a/src/backend/gsl/parser.y b/src/backend/gsl/parser.y
index e90f9f7dc..10121a741 100644
--- src/backend/gsl/parser.y
+++ src/backend/gsl/parser.y
@@ -265,7 +265,7 @@ int yylex(param *p) {
pdebug("PARSER: yylex()\n");
char c;
- /* skip white space */
+ /* skip white space */
while ((c = getcharstr(p)) == ' ' || c == '\t');
/* finish if reached EOF */
diff --git a/src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp b/src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp
index 8492a63a2..45e6a0f5a 100644
--- src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp
+++ src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp
@@ -71,7 +71,7 @@ void XYEquationCurveDock::setupGeneral() {
auto* gridLayout = dynamic_cast<QGridLayout*>(generalTab->layout());
if (gridLayout) {
- gridLayout->setContentsMargins(2,2,2,2);
+ gridLayout->setContentsMargins(2, 2, 2, 2);
gridLayout->setHorizontalSpacing(2);
gridLayout->setVerticalSpacing(2);
}
diff --git a/src/kdefrontend/widgets/ExpressionTextEdit.cpp b/src/kdefrontend/widgets/ExpressionTextEdit.cpp
index f6d26152b..e08b352d9 100644
--- src/kdefrontend/widgets/ExpressionTextEdit.cpp
+++ src/kdefrontend/widgets/ExpressionTextEdit.cpp
@@ -114,13 +114,13 @@ void ExpressionTextEdit::setExpressionType(XYEquationCurve::EquationType type) {
m_expressionType = type;
m_variables.clear();
if (type == XYEquationCurve::EquationType::Cartesian)
- m_variables<<"x";
+ m_variables << "x";
else if (type == XYEquationCurve::EquationType::Polar)
- m_variables<<"phi";
+ m_variables << "phi";
else if (type == XYEquationCurve::EquationType::Parametric)
- m_variables<<"t";
+ m_variables << "t";
else if (type == XYEquationCurve::EquationType::Implicit)
- m_variables<<"x"<<"y";
+ m_variables << "x" << "y";
m_highlighter->setVariables(m_variables);
}
--
GitLab

View File

@ -53,10 +53,13 @@ share/doc/HTML/en/labplot2/tutorial-xy-function9.png
share/doc/HTML/en/labplot2/workbook.png
share/doc/HTML/en/labplot2/worksheet.png
share/icons/hicolor/128x128/apps/labplot2.png
share/icons/hicolor/150x150/apps/labplot2.png
share/icons/hicolor/16x16/apps/labplot2.png
share/icons/hicolor/22x22/apps/labplot2.png
share/icons/hicolor/256x256/apps/labplot2.png
share/icons/hicolor/310x310/apps/labplot2.png
share/icons/hicolor/32x32/apps/labplot2.png
share/icons/hicolor/44x44/apps/labplot2.png
share/icons/hicolor/48x48/apps/labplot2.png
share/icons/hicolor/512x512/apps/labplot2.png
share/icons/hicolor/64x64/apps/labplot2.png
@ -137,7 +140,6 @@ share/kxmlgui5/labplot2/labplot2ui.rc
%%DATADIR%%/datasets/OzDASL.json
%%DATADIR%%/datasets/README.md
%%DATADIR%%/datasets/Rdatasets.json
%%DATADIR%%/datasets/Socrata.json
%%DATADIR%%/datasets/StatLib.json
%%DATADIR%%/example_projects/Big-city-pop.lml
%%DATADIR%%/example_projects/Rainfall.lml