graphics/sswf: prepare for freetype2 update

- freetype2 will no longer ship freetype-config (which was a pkg-config
wrapper) in the near future -- use pkg-config to gather the required
flags.

PR:             251512
This commit is contained in:
Tobias C. Berner 2021-08-07 10:08:15 +02:00
parent de6064a136
commit 8252bf7bd5
2 changed files with 15 additions and 0 deletions

View File

@ -29,6 +29,8 @@ OPTIONS_DEFINE= DEBUG
DEBUG_CONFIGURE_OFF= --disable-debug --disable-yydebug
BINARY_ALIAS= freetype-config=true
.include <bsd.port.pre.mk>
.if empty(ICONV_LIB)

View File

@ -0,0 +1,13 @@
--- configure.orig 2021-08-07 08:00:57 UTC
+++ configure
@@ -22421,8 +22421,8 @@ fi
if test "x$FREETYPE_CONFIG" != "xno" ; then
{ echo "$as_me:$LINENO: checking for freetype libraries" >&5
echo $ECHO_N "checking for freetype libraries... $ECHO_C" >&6; }
- FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
- FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags`
+ FREETYPE_LIBS=`pkg-config freetype2 --libs`
+ FREETYPE_CFLAGS=`pkg-config freetype2 --cflags`
{ echo "$as_me:$LINENO: result: $FREETYPE_LIBS" >&5
echo "${ECHO_T}$FREETYPE_LIBS" >&6; }
fi