- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL

Approved by:	portmgr blanket
This commit is contained in:
Dmitry Marakasov 2017-01-11 10:08:38 +00:00
parent 365eb51f26
commit 8244fe99bc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=431169
57 changed files with 38 additions and 442 deletions

View File

@ -131,15 +131,6 @@ PERFSCHM_SUB_LIST+= PERFSCHEMRC=""
PERFSCHM_SUB_LIST_OFF+= PERFSCHEMRC="--skip-performance-schema"
.endif
.include <bsd.port.options.mk>
### Just for the sake of FreeBSD 9.X ###
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
. if !defined(CLIENT_ONLY)
EXTRA_PATCHES+= ${PATCHDIR}/rapid_plugin-patch-_x_mysqlxtest__src_mysqlxtest.cc
. endif
.endif
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT} == base

View File

@ -1,12 +0,0 @@
--- rapid/plugin/x/mysqlxtest_src/mysqlxtest.cc.orig 2016-03-28 18:06:12 UTC
+++ rapid/plugin/x/mysqlxtest_src/mysqlxtest.cc
@@ -1661,7 +1661,8 @@ private:
if (2 == argl.size())
tolerance = atoi(argl[1].c_str());
- if (abs(expected_msec - msec) > tolerance)
+#define my_abs_64(x) ((x) < 0 ? (-x) : (x))
+ if (my_abs_64((expected_msec - msec)) > tolerance)
{
std::cerr << "Timeout should occur after " << expected_msec << "ms, but it was " << msec <<"ms. \n";
return Stop_with_failure;

View File

@ -18,10 +18,4 @@ BSDISKS_DESC= Use bsdisks instead of hald to mount drives
BSDISKS_CMAKE_BOOL= EXPERIMENTAL_BSDISKS
BSDISKS_RUN_DEPENDS= bsdisks:sysutils/bsdisks
.include <bsd.port.pre.mk>
# Flex on FreeBSD 9 and older 10 is too old
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000033
BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:textproc/flex
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -12,17 +12,7 @@ COMMENT= Helpers CMake modules for LXQt
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/BSD-3-Clause
USES= cmake:outsource lxqt pkgconfig tar:xz
USES= cmake:outsource lxqt pkgconfig tar:xz
USE_QT5= qmake_build buildtools_build core
.include <bsd.port.pre.mk>
# When the CXX compiler is GNU 4.2.1 (DragonFlyBSD seems to have >= 4.7.x)
# we get the following errors:
# cc1plus: error: unrecognized command line option "-flto"
# cc1plus: error: unrecognized command line option "-fuse-linker-plugin"
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000024
EXTRA_PATCHES= ${FILESDIR}/extra-patch-cmake_modules_LXQtCompilerSettings.cmake
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,13 +0,0 @@
--- cmake/modules/LXQtCompilerSettings.cmake.orig 2017-01-01 21:46:43 UTC
+++ cmake/modules/LXQtCompilerSettings.cmake
@@ -144,7 +144,9 @@ endif()
if (CMAKE_COMPILER_IS_GNUCXX OR LXQT_COMPILER_IS_CLANGCXX)
# -flto: use link-time optimizations to generate more efficient code
if (CMAKE_COMPILER_IS_GNUCXX)
- set(LTO_FLAGS "-flto -fuse-linker-plugin")
+ if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ set(LTO_FLAGS "-flto -fuse-linker-plugin")
+ endif()
# When building static libraries with LTO in gcc >= 4.9,
# "gcc-ar" and "gcc-ranlib" should be used instead of "ar" and "ranlib".
# references:

View File

@ -66,14 +66,6 @@ PYTHON_USES= python:2
PYTHON_VARS= STRIP_FILES+=.libs/_unbound.so
THREADS_CONFIGURE_WITH= pthreads
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGOST}
. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000015
WITH_OPENSSL_PORT= yes
. endif
.endif
post-patch:
@${RM} ${WRKSRC}/util/configlexer.c
@${REINPLACE_CMD} -e 's|if test ! -e $$(DESTDIR)$$(configfile); then || ; \

View File

@ -31,26 +31,15 @@ PORTDOCS= CREDITS NEWS README
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e '/INSTALLS/s/man //' \
${WRKSRC}/focuswriter.pro
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000054
@${REINPLACE_CMD} -e 's/std::lround/lround/g' \
${WRKSRC}/src/daily_progress_dialog.cpp \
${WRKSRC}/src/scene_list.cpp \
${WRKSRC}/src/theme_dialog.cpp \
${WRKSRC}/src/fileformats/docx_reader.cpp \
${WRKSRC}/src/fileformats/odt_reader.cpp \
${WRKSRC}/src/fileformats/rtf_reader.cpp
.endif
do-install-DOCS-on:
(cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
post-install:
${INSTALL_MAN} ${WRKSRC}/resources/unix/focuswriter.1 \
${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.post.mk>
post-install-DOCS-on:
(cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>

View File

@ -270,11 +270,6 @@ _MAKE_JOBS= #
.if ${COMPILER_FEATURES:Mlibstdc++}
BROKEN= Build with system libstdc++ is unsupported
.endif
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:textproc/flex
CONFIGURE_ENV+= FLEX=${LOCALBASE}/bin/flex
.endif
.endif # FreeBSD
.if ${COMPILER_TYPE} == "clang"

View File

@ -337,11 +337,6 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-libc++.i386:-p0
EXTRA_PATCHES+= ${FILESDIR}/extra-configure.ac
.endif
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:textproc/flex
CONFIGURE_ENV+= FLEX=${LOCALBASE}/bin/flex
.endif
ACLOCAL_ARGS= -I "${WRKSRC}/m4"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib

View File

@ -123,11 +123,6 @@ REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/gshadow etc/motd \
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} < 1002507 || \
( ${OSVERSION} >= 1100000 && ${OSVERSION} < 1100074 ))
IGNORE= Requires FreeBSD 10.3 or higher
.endif
.if ${LINUX_ARCH} == x86_64 && ${OPSYS} == FreeBSD && ${OSVERSION} >= 11000105
SYSCTLMIB= kern.features.linux64
.else

View File

@ -117,18 +117,11 @@ X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
CONFIGURE_ARGS+= --enable-win64 --libdir=${PREFIX}/lib
PLIST_SUB+= WINE32="@comment " WINE64=""
# Force the use of GCC where it is the system compiler since
# COMPILER_VERSION will be 42 (the GCC version) even if clang
# is CHOSEN_COMPILER_TYPE in that case.
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000054
USE_GCC= yes
.else
. if ${CHOSEN_COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 38
.if ${CHOSEN_COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 38
CPPFLAGS+= -D__builtin_ms_va_list=__builtin_va_list \
-D__builtin_ms_va_start=__builtin_va_start \
-D__builtin_ms_va_end=__builtin_va_end \
-D__builtin_ms_va_copy=__builtin_va_copy
. endif
.endif
# Wine assumes a WoW64 package is available however WoW64 is not yet available on FreeBSD.

View File

@ -36,12 +36,6 @@ MOVIES_CMAKE_ON= -DWITH_MOVIES=ON
MOVIES_CMAKE_OFF= -DWITH_MOVIES=OFF
MOVIES_LIB_DEPENDS= libswresample.so:multimedia/ffmpeg
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000024 && ${CHOSEN_COMPILER_TYPE} == gcc
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
post-patch:
# Allow the game to find its resources without wrapper scripts
@${REINPLACE_CMD} -e \
@ -55,4 +49,4 @@ do-install:
cd ${WRKSRC}/CorsixTH && ${COPYTREE_SHARE} "Bitmap Levels Lua" \
${STAGEDIR}${DATADIR}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -36,12 +36,7 @@ DESKTOP_ENTRIES="Vulture's Eye" "" "" "vulture-nethack" "" ""
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= flex>0:textproc/flex
MAKE_ENV+= FLEX="${LOCALBASE}/bin/flex"
.else
MAKE_ENV+= FLEX="${FLEX}"
.endif
pre-patch:
@(cd ${WRKSRC}/win && ${LN} -sf ../../vulture)

View File

@ -68,18 +68,6 @@ WPG_LIB_DEPENDS= libwpg-0.3.so:graphics/libwpg03
CPPFLAGS+= -Wno-mismatched-tags -Wno-unknown-attributes
.endif
# Base clang 3.4.1 in FreeBSD 9.3 fails to compile this code on i386
# but base clang 3.4.1 in FreeBSD 10.1 succeeds. The difference *appears*
# to be the patch applied in r271597 (head) / r271739 (stable/10). The
# latter happened shortly before 10.1 was branched.
.if ${ARCH} == i386 && ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000 && \
( ${COMPILER_TYPE} == clang || ${ALT_COMPILER_TYPE} == clang )
BUILD_DEPENDS+= clang34:lang/clang34
CPP= ${LOCALBASE}/bin/clang-cpp34
CC= ${LOCALBASE}/bin/clang34
CXX= ${LOCALBASE}/bin/clang++34
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||g' \
${WRKSRC}/configure

View File

@ -34,12 +34,6 @@ CONFLICTS_INSTALL= luminance-hdr-[0-9]*
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000024
USE_GCC= yes
.endif
post-patch:
# Do not install yet another copy of GPL (we use license framework instead)
# and fix installation path for docs (but not for internal help files)
@ -60,4 +54,4 @@ post-patch:
pre-install:
QT_BINDIR_REL=bin
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -34,12 +34,6 @@ USES= bison cmake:outsource compiler:c11
USE_GCC= yes
.endif
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= flex>=2.5.37:textproc/flex
CMAKE_ARGS+= -DFLEX_EXECUTABLE:STRING=${LOCALBASE}/bin/flex
CXXFLAGS+= -I${LOCALBASE}/include/flex
.endif
post-patch:
@${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' \
${WRKSRC}/src/liboslexec/serialize-bc.bash

View File

@ -43,10 +43,6 @@ OPTIONS_DEFAULT= FULL_SDK
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
PATCH_DEPENDS+= gpatch:devel/patch
PATCH= gpatch
.endif
PATCH_STRIP= -p1
.if ${PORT_OPTIONS:MSWT_GTK3_SUPPORT}

View File

@ -39,8 +39,6 @@ MAKE_ENV= MONO_SHARED_DIR="${MONO_SHARED_DIR}" \
ONLY_FOR_ARCHS= i386 amd64 powerpc
PORTSCOUT= limit:^\d+\.\d+\.[1-9]\d*
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|^#!/bin/bash|#!/usr/bin/env bash|g' \
${WRKSRC}/scripts/mono-find-provides.in \
@ -53,14 +51,9 @@ post-patch:
post-configure:
@${REINPLACE_CMD} -e 's|share\/man|man|g' \
${WRKSRC}/mcs/jay/Makefile
# Fix build on FreeBSD 9.3 (and maybe other unsupported releases)
.if ${OSVERSION} < 1000000
@${REINPLACE_CMD} 's/^#define HAVE_LOCALCHARSET_H 1/#undef HAVE_LOCALCHARSET_H/' \
${WRKSRC}/eglib/config.h
.endif
do-test:
@(cd ${WRKSRC}/mono/tests && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
${MAKE_FLAGS} Makefile ${MAKE_ARGS} check)
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -18,6 +18,8 @@ LICENSE_TEXT= The text of the license can be obtained from the following URL:\
http://www.smlnj.org/license.html
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
ONLY_FOR_ARCHS= i386 amd64
NO_WRKSUBDIR= yes
SUB_FILES= pkg-install
@ -41,21 +43,6 @@ POSITION64_DESC= use 64bit file${CALM} positions - implies RECOMPILE
ML_RECOMPILE_OPTIONS= RECOMPILE POSITION64
.endif
.if (${ARCH} == "amd64") && (${OSVERSION} >= 1000029)
ONLY_FOR_ARCHS= i386 amd64
.elif (${ARCH} == "amd64")
ONLY_FOR_ARCHS= i386 amd64
# Compilation of the i386 runtime source on older amd64 systems requires
# i386 system headers from the respective FreeBSD Version, taken from
# stable/N/sys/i386/include, r196045 (N=8) and r225736 (N=9).
EXTRA_DEFS+= -DINCLUDE_FREEBSD_I386_SIGNAL=\\\"freebsd-8-i386-signal.h\\\"
EXTRA_DEFS+= -DINCLUDE_FREEBSD_I386_IEEEFP=\\\"freebsd-8-i386-ieeefp.h\\\"
EXTRA_DEFS+= -DINCLUDE_FREEBSD_I386__TYPES=\\\"freebsd-9-i386-_types.h\\\"
EXTRA_DEFS+= -DINCLUDE_FREEBSD_I386_ENDIAN=\\\"freebsd-9-i386-endian.h\\\"
.else
ONLY_FOR_ARCHS= i386
.endif
.if (${ARCH} == "amd64")
CFLAGS+= -m32
AS?= as

View File

@ -45,12 +45,10 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD
.if (${OSVERSION} < 1002000) || (${OSVERSION} < 1100079)
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100079
BUILD_DEPENDS+= clang38:devel/llvm38
EXTRA_FLAGS= --host-cc=${LOCALBASE}/bin/clang38 --host-cxx=${LOCALBASE}/bin/clang++38
.endif
.endif
post-extract:
@${MKDIR} ${WRKSRC}

View File

@ -53,14 +53,6 @@ PAM_CONFIGURE_WITH= auth-pam=smtpd
SSL_PORT_VARS= with_openssl_port=yes
TABLE_DB_CONFIGURE_WITH= table-db
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} <= 1000015
WITH_OPENSSL_PORT= yes
.endif
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --with-libasr=${LOCALBASE} \
--with-libevent=${LOCALBASE} \
--with-libssl=${OPENSSLBASE} \
@ -73,9 +65,7 @@ post-patch:
'/SMTPD_VERSION/s/"[^"]+"$$/"${PORTVERSION}${DISTVERSIONSUFFIX}"/' \
${WRKSRC}/smtpd/smtpd.h
.if ${PORT_OPTIONS:MTABLE_DB}
post-install:
post-install-TABLE_DB-on:
@${LN} -sf ${PREFIX}/sbin/smtpctl ${STAGEDIR}${PREFIX}/libexec/opensmtpd/makemap
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -52,14 +52,6 @@ PAM_CONFIGURE_WITH= auth-pam=smtpd
SSL_PORT_VARS= with_openssl_port=yes
TABLE_DB_CONFIGURE_WITH= table-db
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} <= 1000015
WITH_OPENSSL_PORT= yes
.endif
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --with-libasr=${LOCALBASE} \
--with-libevent=${LOCALBASE} \
--with-libssl=${OPENSSLBASE} \
@ -68,9 +60,7 @@ CONFIGURE_ARGS+= --with-libasr=${LOCALBASE} \
post-patch:
${REINPLACE_CMD} -e '/chmod 2555/d' ${WRKSRC}/mk/smtpctl/Makefile.in
.if ${PORT_OPTIONS:MTABLE_DB}
post-install:
post-install-TABLE_DB-on:
@${LN} -sf ${PREFIX}/sbin/smtpctl ${STAGEDIR}${PREFIX}/libexec/opensmtpd/makemap
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,10 +1,4 @@
# Compiler settings required for R and the R-cran ports.
.if ${OPSYS} == FreeBSD
. if ${OSVERSION} < 1000015
USE_GCC= yes
. endif
.else
. if ${OPSYS} == DragonFly
.if ${OPSYS} == DragonFly
USE_GCC= 6
. endif
.endif

View File

@ -23,11 +23,4 @@ CONFIGURE_ARGS= --enable-introspection=yes \
--with-bash-completion-dir=${PREFIX}/share/bash-completion/completions
PLIST_SUB= VERSION=1.0 SOVERSION=0.800.0
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:textproc/flex
CONFIGURE_ENV+= FLEX_PATH="${LOCALBASE}/bin/flex"
.endif
.include <bsd.port.mk>

View File

@ -110,8 +110,6 @@ LIRC_RUN_DEPENDS= lircd:comms/lirc
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_PulseAudio:BOOL=true
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} 's/[[:<:]]ARCH[[:>:]]/FFMPEG_ARCH/' \
${WRKSRC}/lib/ffmpeg/Makefile \
@ -122,15 +120,6 @@ post-patch:
${WRKSRC}/plex/CMakeModules/FindIconv.cmake
@${REINPLACE_CMD} 's/COMMAND\ make/COMMAND\ gmake/g' \
${WRKSRC}/lib/ffmpeg/CMakeLists.txt
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1000024
@${REINPLACE_CMD} 's/__builtin_bswap/__bswap/g' \
${WRKSRC}/plex/Third-Party/hash-library/crc32.cpp \
${WRKSRC}/plex/Third-Party/hash-library/keccak.cpp \
${WRKSRC}/plex/Third-Party/hash-library/md5.cpp \
${WRKSRC}/plex/Third-Party/hash-library/sha1.cpp \
${WRKSRC}/plex/Third-Party/hash-library/sha256.cpp \
${WRKSRC}/plex/Third-Party/hash-library/sha3.cpp
.endif
post-install:
${RM} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/*.so

View File

@ -114,11 +114,6 @@ V4L_CONFIGURE_ENABLE= v4l
.include <bsd.port.pre.mk>
#Disable mmx on FreeBSD 10.1 due to a transient bug in clang
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && ${OSVERSION} < 1002000
CONFIGURE_ARGS+= --disable-mmx
.endif
.if empty(ICONV_LIB)
CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=no \
ac_cv_lib_iconv_libiconv_open=no

View File

@ -83,17 +83,6 @@ CMAKE_ARGS+= -DZM_PERL_MM_PARMS=INSTALLDIRS=site \
-DGNUTLS_LIBRARIES=0 \
-DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include"
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 && ${ARCH} == i386
CFLAGS+= -msse
.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
LIB_DEPENDS+= libexecinfo.so:devel/libexecinfo
LDFLAGS+= -L${LOCALBASE}/lib
.endif
PKGMESSAGE= ${WRKDIR}/pkg-message
post-extract:
@ -118,4 +107,4 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -78,17 +78,6 @@ CMAKE_ARGS+= -DZM_PERL_MM_PARMS=INSTALLDIRS=site \
-DGNUTLS_LIBRARIES=0 \
-DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include"
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 && ${ARCH} == i386
CFLAGS+= -msse
.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
LIB_DEPENDS+= libexecinfo.so:devel/libexecinfo
LDFLAGS+= -L${LOCALBASE}/lib
.endif
PKGMESSAGE= ${WRKDIR}/pkg-message
post-extract:
@ -113,4 +102,4 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -34,10 +34,6 @@ SUB_LIST+= SKYPEDIR=${SKYPEDIR}
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100075 || ${OSVERSION} >= 1000000 && ${OSVERSION} < 1002507)
BROKEN= Skype 4.3 requires Linux 2.6.32 emulation
.endif
.if ${PORT_OPTIONS:MVIDEO}
RUN_DEPENDS+= webcamd:multimedia/webcamd
USE_LINUX+= libv4l

View File

@ -108,7 +108,8 @@ CONFIGURE_ARGS= --localstatedir=/var \
--without-lvm \
--without-mic \
--without-oracle \
--disable-turbostat
--disable-turbostat \
--enable-disk
CGI_RUN_DEPENDS= p5-URI>=0:net/p5-URI \
p5-CGI>=0:www/p5-CGI \
@ -323,15 +324,6 @@ CONFIGURE_ARGS+=--enable-aggregation \
--enable-write_log \
--enable-zfs_arc \
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
PLIST_SUB+= DISK="@comment "
.else
CONFIGURE_ARGS+=--enable-disk
PLIST_SUB+= DISK=""
.endif
INSTALL_TARGET= install-strip
SHEBANG_FILES= contrib/collection.cgi

View File

@ -27,7 +27,7 @@ lib/collectd/csv.so
%%CURL_XML%%lib/collectd/curl_xml.so
%%DBI%%lib/collectd/dbi.so
lib/collectd/df.so
%%DISK%%lib/collectd/disk.so
lib/collectd/disk.so
lib/collectd/dns.so
lib/collectd/email.so
lib/collectd/exec.so

View File

@ -89,19 +89,10 @@ PLIST_SUB+= DBBACKEND="@comment "
PLIST_SUB+= DBBACKEND=""
.endif
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= flex>=2.5.31:textproc/flex
CMAKE_ARGS+= -DFLEX_EXECUTABLE:STRING=${LOCALBASE}/bin/flex
CXXFLAGS+= -I${LOCALBASE}/include/flex
.endif
post-patch:
.for f in ${LINUX_CONFIG}
${REINPLACE_CMD} 's,[Ll]inux,FreeBSD,g' ${WRKSRC}/etc/icinga2/conf.d/${f}
.endfor
.if ${OSVERSION} < 1000000
${REINPLACE_CMD} 's|,--no-export-dynamic||' ${WRKSRC}/CMakeLists.txt
.endif
pre-install:
${FIND} ${WRKSRC}/etc -type f -name "*.conf" -exec ${MV} {} {}.sample \;

View File

@ -15,13 +15,6 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
USES= cmake bison
USE_LDCONFIG= yes
CMAKE_ARGS+= -DSCTP_USE_MAPPED_ADDRESSES:BOOL=ON
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:textproc/flex
CMAKE_ARGS+= -DFLEX_EXECUTABLE:FILEPATH="${LOCALBASE}/bin/flex"
.endif
CMAKE_ARGS= -DSCTP_USE_MAPPED_ADDRESSES:BOOL=ON
.include <bsd.port.mk>

View File

@ -42,11 +42,4 @@ INSTALL_TARGET= install-strip
PLIST_SUB= GLUSTERLIBDIR="lib/${PORTNAME}/3.7.6"
KMODDIR?= /boot/modules
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000000
WITH_OPENSSL_PORT= yes
RUN_DEPENDS+= ${KMODDIR}/fuse.ko:sysutils/fusefs-kmod
.endif
.include <bsd.port.mk>

View File

@ -40,13 +40,6 @@ LDFLAGS+= -L${OPENSSLLIB}
BUILD_DEPENDS+= ${NONEXISTENT}:security/libressl:stage
CPPFLAGS+= -I${WRKDIR}/libressl/include
LDFLAGS+= -L${WRKDIR}/libressl/lib
# security/libressl ignores implicit SSP_UNSAFE, see Mk/bsd.ssp.mk
. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000036 && ${ARCH} == i386
SSP_CFLAGS?= -fstack-protector
CFLAGS+= ${SSP_CFLAGS}
LDFLAGS+= -fstack-protector
LIBS+= -lssp_nonshared
. endif
# Don't use COPYTREE_SHARE here as it hard links files, and the original files
# are owned by root, which creates problems of its own.

View File

@ -15,20 +15,12 @@ LICENSE_COMB= multi
WRKSRC= ${WRKDIR}/${PORTVERSION}/${PORTNAME:tu}
USES= cmake:outsource perl5 tar:tgz
USES= cmake:outsource compiler:openmp perl5 tar:tgz
USE_PERL5= build
USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}"
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000000
USES+= compiler:c++11-lib
.else
USES+= compiler:openmp
.endif
post-patch:
@${REINPLACE_CMD} -e \
'/DESTINATION/s|lib$${LIB_SUFFIX}|libdata|' \

View File

@ -24,11 +24,4 @@ post-patch:
@${REINPLACE_CMD} -e '/^pkgconfigdir =/s,libdir),prefix)/libdata,' \
${WRKSRC}/build/Makefile.in
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000034
LIB_DEPENDS+= libml.so:math/ldouble
LDFLAGS+= -lml
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -33,11 +33,7 @@ OPENMPI_DESC= MPI support (with OpenMPI)
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD
. if ${OSVERSION} < 1000000
MPI_DEFAULT= OPENMPI
. else
MPI_DEFAULT= MPICH2
. endif
.endif
.if ${PORT_OPTIONS:MMPICH2} || ${PORT_OPTIONS:MOPENMPI}

View File

@ -34,13 +34,6 @@ MINIMIZE_CORPUS_RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000013
# Broken on FreeBSD 9
PLIST_SUB+= LLVM_SUB="@comment "
.else
PLIST_SUB+= LLVM_SUB=""
.endif
.if ${ARCH} == "i386"
# Clang i386 emits .cfi_sections which base as(1) doesn't understand
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
@ -69,8 +62,6 @@ post-patch-LLVM-on:
-e 's|"clang\+\+"|"clang\+\+${LLVM_VERSION}"|g' \
${WRKSRC}/llvm_mode/afl-clang-fast.c
.if ! ${OSVERSION} < 1000013
# Broken on FreeBSD 9
post-build-LLVM-on:
@(cd ${WRKSRC}/llvm_mode; ${SETENV} \
CC=clang${LLVM_VERSION} \
@ -79,7 +70,6 @@ post-build-LLVM-on:
CFLAGS="${CFLAGS}" \
CXXFLAGS="${CXXFLAGS}" \
${GMAKE})
.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/docs/COPYING ${STAGEDIR}${DOCSDIR}/

View File

@ -1,12 +1,12 @@
bin/afl-analyze
bin/afl-clang
bin/afl-clang++
%%LLVM_SUB%%%%LLVM%%bin/afl-clang-fast
%%LLVM_SUB%%%%LLVM%%bin/afl-clang-fast++
%%LLVM_SUB%%%%LLVM%%lib/afl/afl-llvm-pass.so
%%LLVM_SUB%%%%LLVM%%lib/afl/afl-llvm-rt.o
%%LLVM_SUB%%%%LLVM%%lib/afl/afl-llvm-rt-32.o
%%LLVM_SUB%%%%LLVM%%lib/afl/afl-llvm-rt-64.o
%%LLVM%%bin/afl-clang-fast
%%LLVM%%bin/afl-clang-fast++
%%LLVM%%lib/afl/afl-llvm-pass.so
%%LLVM%%lib/afl/afl-llvm-rt.o
%%LLVM%%lib/afl/afl-llvm-rt-32.o
%%LLVM%%lib/afl/afl-llvm-rt-64.o
%%MINIMIZE_CORPUS%%bin/afl-cmin
bin/afl-fuzz
bin/afl-g++

View File

@ -84,18 +84,6 @@ LBL_CF_RUN_DEPENDS= ${LOCALBASE}/bin/cf:sysutils/lbl-cf
PERFTOOLS_CMAKE_BOOL= ENABLE_PERFTOOLS
PERFTOOLS_RUN_DEPENDS= ${LOCALBASE}/bin/pprof:devel/google-perftools
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBROKER}
. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000
# Bro 2.4 with BROKER requires caf, clang and libc++
BUILD_DEPENDS+= ${LOCALBASE}/bin/clang++34:lang/clang34 \
${LOCALBASE}/lib/c++/libstdc++.so:devel/libc++
CXXFLAGS+= -stdlib=libc++ -I${LOCALBASE}/include/c++/v1 -L${LOCALBASE}/lib
CXX= ${LOCALBASE}/bin/clang++34
. endif
.endif
post-install-BROCTL-on:
@${MKDIR} ${STAGEDIR}${PREFIX}/logs
@${MKDIR} ${STAGEDIR}${PREFIX}/spool/tmp

View File

@ -25,14 +25,7 @@ USE_RC_SUBR= fastd_devel
PLIST_FILES= bin/fastd-devel \
man/man1/fastd-devel.1.gz
.include <bsd.port.pre.mk>
# GCC from base does not support -mpclmul.
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000024
CMAKE_ARGS+= -DWITH_MAC_GHASH_PCLMULQDQ=FALSE
.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/fastd.1 ${STAGEDIR}${PREFIX}/man/man1/fastd-devel.1
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -24,12 +24,6 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CPE_VENDOR= cypherpunks
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000036 && ${ARCH} == i386
LDFLAGS+= -lssp_nonshared
.endif
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc

View File

@ -35,7 +35,7 @@ DIST_OSVER= 10
.if ${ARCH} == amd64
DIST_EXT= _x64
.elif ${ARCH} == i386
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
.if ${OPSYS} == FreeBSD
# use the 9 i386 version for 10 i386
DIST_OSVER= 9
RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:misc/compat9x

View File

@ -34,11 +34,4 @@ BEVIEWER_CONFIGURE_OFF= --disable-BEViewer
BEVIEWER_USE= JAVA=yes
BEVIEWER_PLIST_FILES= bin/BEViewer bin/BEViewer.jar
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000033
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
CONFIGURE_ENV= LEX=${LOCALBASE}/bin/flex
.endif
.include <bsd.port.mk>

View File

@ -45,10 +45,6 @@ SHEBANG_FILES= scripts/sort_res.perl5
.include <bsd.port.pre.mk>
.if !empty(ARCH:Marm*) && ((${OSVERSION} < 1001505) || (${OSVERSION} > 1100000 && ${OSVERSION} < 1100052))
BROKEN= Not supported on ARM platform below release 10.1 or a more recent current
.endif
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -n freebsd
CONFIGURE_ENV= LSOF_CC="${CC}" FREEBSD_SYS="${SRC_BASE}/sys"

View File

@ -43,12 +43,6 @@ GH_PROJECT= third-party:tp
GH_SUBDIR= third-party:tp
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 1000000
CFLAGS+= -D_GLIBCXX_USE_C99
.endif
post-patch:
${REINPLACE_CMD} -e 's|/var/osquery|/var/db/osquery|g' \
${WRKSRC}/osquery/core/init.cpp
@ -74,4 +68,4 @@ do-install:
${MKDIR} ${STAGEDIR}/var/db/osquery
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -22,17 +22,6 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
# base flex(1) v2.5.4 is not sufficient
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000033
BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:textproc/flex
post-patch:
@${REINPLACE_CMD} -e 's!flex!${LOCALBASE}/bin/&!' \
${BUILD_WRKSRC}/xxdiff.pro
.endif
pre-build:
@(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} QMAKE=${QMAKE} \
${MAKE_CMD} -f Makefile.bootstrap ${MAKE_ARGS} Makefile)
@ -44,4 +33,4 @@ do-install-DOCS-on:
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "${PORTDOCS} ! -name Makefile" \
${STAGEDIR}/${DOCSDIR}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -187,12 +187,6 @@ GN_ARGS+= is_clang=true
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang
.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1002000
BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:devel/libc++
GN_ARGS+= extra_cxxflags="-stdlib=libc++ -isystem ${LOCALBASE}/include/c++/v1" \
extra_ldflags="-L${LOCALBASE}/lib"
.endif
.if ${OSVERSION} < 1100000
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-10
.endif

View File

@ -42,18 +42,10 @@ SQLITE_USE= PHP=pdo_sqlite,sqlite3
SMB_RUN_DEPENDS= pecl-smbclient>=0.8.0:net/pecl-smbclient
SSL_USE= PHP=openssl
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1002000
WITH_OPENSSL_PORT= yes
.endif
post-stage:
${RM} ${STAGEDIR}${WWWDIR}/updater/updater.phar
do-install:
@${MKDIR} -m 0755 ${STAGEDIR}${WWWDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
@${RM} ${STAGEDIR}${WWWDIR}/updater/updater.phar
@${MKDIR} ${STAGEDIR}${WWWDIR}/data
.include <bsd.port.mk>

View File

@ -46,12 +46,6 @@ SQLITE_USE= PHP=pdo_sqlite,sqlite3
SMB_RUN_DEPENDS= pecl-smbclient>=0.8.0:net/pecl-smbclient
SSL_USE= PHP=openssl
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1002000
WITH_OPENSSL_PORT= yes
.endif
do-install:
@${MKDIR} -m 0755 ${STAGEDIR}${WWWDIR}
@cd ${WRKSRC} && \

View File

@ -86,11 +86,6 @@ CFLAGS+= -mminimal-toc
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= flex>=0:textproc/flex
CONFIGURE_ENV+= FLEX="${LOCALBASE}/bin/flex"
.endif
.if ${CHOSEN_COMPILER_TYPE} == clang
CXXFLAGS+= -Wno-c++11-extensions # Shutup warning spam
CXXFLAGS+= -Qunused-arguments

View File

@ -88,11 +88,6 @@ CFLAGS+= -mminimal-toc
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= flex>=0:textproc/flex
CONFIGURE_ENV+= FLEX="${LOCALBASE}/bin/flex"
.endif
.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
# Needed for __atomic_fetch_add_8
CFLAGS+= -march=i586

View File

@ -64,11 +64,6 @@ CMAKE_ARGS+= -DENABLE_JIT:BOOL=OFF
CFLAGS+= -mminimal-toc
.endif
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= flex>=0:textproc/flex
CONFIGURE_ENV+= FLEX_PATH="${LOCALBASE}/bin/flex"
.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%BROWSER_PLUGINS_DIR%%|${BROWSER_PLUGINS_DIR}|' \
${WRKSRC}/Source/WebKit2/UIProcess/Plugins/unix/PluginInfoStoreUnix.cpp

View File

@ -26,15 +26,7 @@ CONFIGURE_WRKSRC= ${WRKSRC}/gnome-pty-helper
BUILD_WRKSRC= ${WRKSRC}/gnome-pty-helper
INSTALL_WRKSRC= ${WRKSRC}/gnome-pty-helper
.include <bsd.port.options.mk>
post-patch:
# borrowed osversion from bsd.ssp.mk
.if ${OSVERSION} < 1000036 && ${ARCH} == i386
@${REINPLACE_CMD} -e 's|-fstack-protector-strong||g; \
s|-fstack-protector||g' \
${WRKSRC}/configure
.endif
@${REINPLACE_CMD} -e 's|(AM_MAKEFLAGS) install-exec-hook|(AM_MAKEFLAGS)|g' \
${WRKSRC}/gnome-pty-helper/Makefile.in

View File

@ -32,16 +32,8 @@ INSTALL_TARGET= install-strip
PLIST_SUB= VERSION=2.91
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|-Wno-unused-but-set-variable||g' \
${WRKSRC}/src/Makefile.in
# borrowed osversion from bsd.ssp.mk
.if ${OSVERSION} < 1000036 && ${ARCH} == i386
@${REINPLACE_CMD} -e 's|-fstack-protector-strong||g; \
s|-fstack-protector||g' \
${WRKSRC}/configure
.endif
.include <bsd.port.mk>

View File

@ -406,12 +406,6 @@ BROKEN= Lemon has not supported yet because depended by libnl
BROKEN= Otlozhu has not supported yet (not ported liblaretz)
.endif
.if ${OSVERSION} < 1000000
PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
PORT_OPTIONS:= ${PORT_OPTIONS:NBITTORRENT}
USE_GCC= yes
.endif
post-install:
@${FIND} -d ${STAGEDIR}${PREFIX}/include/leechcraft \
-type d -empty -exec ${RMDIR} {} \;