Add icebreaker - a SDL-based game similar to Jezzball or Barrack.

This commit is contained in:
Maxim Sobolev 2000-10-19 13:17:31 +00:00
parent dcf8dc728d
commit 8201390c0a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33995
7 changed files with 116 additions and 0 deletions

View File

@ -91,6 +91,7 @@
SUBDIR += heroes
SUBDIR += hex
SUBDIR += icbm3d
SUBDIR += icebreaker
SUBDIR += ifm
SUBDIR += imaze
SUBDIR += inform

28
games/icebreaker/Makefile Normal file
View File

@ -0,0 +1,28 @@
# New ports collection makefile for: icebreaker
# Date created: 19 October 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= icebreaker
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://www.mattdm.org/icebreaker/
EXTRACT_SUFX= .tgz
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
prefix="${PREFIX}" \
highscoredir="${PREFIX}/share/icebreaker/scores" \
CHMOD="${CHMOD}" \
CHOWN="${CHOWN}" \
MKDIR="${MKDIR}"
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (icebreaker-1.0.tgz) = 74259ee86ff7bf5eec8471aed89e5388

View File

@ -0,0 +1,53 @@
--- Makefile.orig Thu Oct 5 21:55:31 2000
+++ Makefile Thu Oct 19 14:24:35 2000
@@ -1,4 +1,4 @@
-CC=gcc
+CC?=gcc
ifndef prefix
#prefix=/usr/local
@@ -10,16 +10,16 @@
highscoredir=/var/lib/games
endif
-CFLAGS=-Wall -O3 $(SDL_CFLAGS) -DDATAPREFIX=\"$(prefix)/share/icebreaker\" -DHISCOREPREFIX=\"$(highscoredir)\"
+CFLAGS+=-Wall $(SDL_CFLAGS) -DDATAPREFIX=\"$(prefix)/share/icebreaker\" -DHISCOREPREFIX=\"$(highscoredir)\"
#CFLAGS=-Wall -pg -g $(SDL_CFLAGS)
SRC=icebreaker.c cursor.c grid.c laundry.c line.c penguin.c sound.c \
level.c intro.c text.c status.c transition.c hiscore.c dialog.c
-SDL_MIXER=-lSDL_mixer
+SDL_MIXER=-lSDL_mixer -lsmpeg -lgcc_r
SDL_LIB=$(SDL_LDFLAGS) $(SDL_MIXER)
-SDL_CFLAGS := $(shell sdl-config --cflags)
-SDL_LDFLAGS := $(shell sdl-config --libs)
+SDL_CFLAGS := $(shell $(SDL_CONFIG) --cflags)
+SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
all: icebreaker
@@ -38,15 +38,16 @@
$(CC) $(CFLAGS) $^ -o icebreaker $(SDL_LIB)
install: all
- mkdir -p $(prefix)/bin
- mkdir -p $(prefix)/share/icebreaker
- mkdir -p $(highscoredir)
+ $(MKDIR) $(prefix)/share/icebreaker
+ $(MKDIR) $(highscoredir)
- install -m 644 *.wav *.bmp $(prefix)/share/icebreaker
- install -g games -s -m 2755 icebreaker $(prefix)/bin
+ $(BSD_INSTALL_DATA) *.wav *.bmp $(prefix)/share/icebreaker
+ $(BSD_INSTALL_PROGRAM) icebreaker $(prefix)/bin
touch $(highscoredir)/icebreaker.scores
- chown games:games $(highscoredir)/icebreaker.scores
- chmod 664 $(highscoredir)/icebreaker.scores
+ $(CHOWN) root:games $(prefix)/bin/icebreaker
+ $(CHMOD) 2755 $(prefix)/bin/icebreaker
+ $(CHOWN) root:games $(highscoredir)/icebreaker.scores
+ $(CHMOD) 664 $(highscoredir)/icebreaker.scores
include $(SRC:.c=.d)

View File

@ -0,0 +1 @@
A game similar to Jezzball or Barrack

View File

@ -0,0 +1,24 @@
IceBreaker is a game similar to Jezzball or Barrack. So, uh, there's a bunch of
penguins on an iceberg in Antarctica. You have been selected to catch them so
they can be shipped to Finland, where they are essential to a secret plot for
world domination.
In order to trap the penguins, you'll need to break the iceberg into small
chunks. (They're afraid of water, for no apparent reason.) You do this by
melting lines in the ice with Special High-Tech GNU Tools.
If a penguin hits a line in progress, however, it vanishes with a loud noise,
and you lose a life. (Yes, a life. This story is really breaking down, isn't
it? But never fear -- I'll keep going until it's completely dead.)
Once 80% or more of the iceberg is gone, the remaining chunks are small enough
for shipping. Of course, if you manage to get rid of more than that, you'll
save on postage, thus earning you exponential amounts of Geek Cred (a.k.a.
"score").
After you ship off one batch of penguins, it's time to move on to the next.
Each subsequent 'berg will have one more penguin, and you'll have one more
life. This will continue until you lose, or until you exceed level one hundred
or so, which Ain't Gonna Happen.
WWW: http://www.mattdm.org/icebreaker/

View File

@ -0,0 +1,8 @@
bin/icebreaker
share/icebreaker/crash.wav
share/icebreaker/icebreaker_48.bmp
share/icebreaker/ouch.wav
share/icebreaker/penguin.bmp
share/icebreaker/scores/icebreaker.scores
@dirrm share/icebreaker/scores
@dirrm share/icebreaker