- Update gnuchess to 5.08 (now under GPLv3+)

- Claim maintainership
- Remove obsoleted patch

Feature safe:	yes
This commit is contained in:
Johan van Selst 2011-01-30 19:02:37 +00:00
parent d1c49198a9
commit 81ff34883f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=268458
3 changed files with 7 additions and 24 deletions

View File

@ -6,26 +6,22 @@
#
PORTNAME= gnuchess
PORTVERSION= 5.07
PORTVERSION= 5.08
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= chess
# The DISTFILES here is explicitly needed because it can be extended later.
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= johans@FreeBSD.org
COMMENT= "Classic" Gnu Chess
PLIST_FILES= bin/gnuchess \
bin/gnuchessx
.if !defined(NOPORTDOCS)
PORTDOCS= ChangeLog \
NEWS \
README
.endif
PORTDOCS= *
OPTIONS= OPENING_BOOK "Install opening book (24 MB download)" on
OPTIONS= OPENING_BOOK "Install opening book (25 MB download)" on
.include <bsd.port.pre.mk>
@ -37,7 +33,7 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
.endif
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" MKDIR_P="${MKDIR}"
post-patch:
@${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS:S/"//g}|g ; \

View File

@ -1,6 +1,4 @@
MD5 (gnuchess-5.07.tar.gz) = 259da00aa559e5624c65279484fccaf7
SHA256 (gnuchess-5.07.tar.gz) = b388e0265fe5ad3ee64da95b0dc0e28d943d29bfc95aa5c2cc7a7d57462d017e
SIZE (gnuchess-5.07.tar.gz) = 234542
MD5 (book_1.01.pgn.gz) = 1be508d7a38a8c9a7d599d0cd92b24a6
SHA256 (gnuchess-5.08.tar.gz) = c4e49e0dec210f5d131a02ff89588b482787cd702a08456791ba9100b4c6ffc0
SIZE (gnuchess-5.08.tar.gz) = 279309
SHA256 (book_1.01.pgn.gz) = 35df43a342c73e6624e8dbfed78d588c2085208168c3cd3300295e3c57981be0
SIZE (book_1.01.pgn.gz) = 26070544

View File

@ -1,11 +0,0 @@
--- src/input.c.orig Tue Jun 5 23:34:06 2007
+++ src/input.c Tue Jun 5 23:34:14 2007
@@ -92,7 +92,7 @@
fgets(inputstr, MAXSTR, stdin);
}
-static pthread_t input_thread;
+pthread_t input_thread;
/* Mutex and condition variable for thread communication */