Update to 1.2.4, which is mostly a maintainance release and allows to get

rid of some local patches:

o Fixed autocon warnings (Denis Leroy)
o Ported to lame 3.100 (from Fedora)
o G++ compile fixes (Nick Bailey)
o Renamed xdao folder to gcdmaster (Denis Leroy)
o pccts format security patch (from Fedora)
o Fixed compile issues with glibc >= 2.12
o Gcdmaster segfault fix (Adrian Knoth)
o Prevent a FTBFS on kfreebsd (Christoph Egger)
o Fix printf format security issues (Frantisek Kluknavsky Fedora)
o Add missing options to man page (Honza Horak)
o CD_TEXT fix for HL-DT-ST (Kees Cook)
o Man page hyphen fixes (Markus Koschany)
o Some updates to the old scsilib smake files (Ubuntu patches)

While at it, pet portlint.

Security:	yes
This commit is contained in:
Marius Strobl 2018-06-13 21:40:03 +00:00
parent b990f7429a
commit 81ef7f54fd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=472345
17 changed files with 52 additions and 176 deletions

View File

@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME?= cdrdao
PORTVERSION= 1.2.3
PORTREVISION?= 5
PORTVERSION= 1.2.4
PORTREVISION?= 0
CATEGORIES= sysutils audio
MASTER_SITES= SF/cdrdao/cdrdao/${PORTVERSION}
MASTER_SITES= SF/cdrdao
DISTNAME= cdrdao-${PORTVERSION}
MAINTAINER= marius@FreeBSD.org
@ -40,10 +40,11 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/cdrdao:sysutils/cdrdao \
${LOCALBASE}/share/mime/packages/freedesktop.org.xml:misc/shared-mime-info
CONFIGURE_ARGS+= --with-lame=no
.else
CONFIGURE_ARGS+= --with-xdao=no
CONFIGURE_ARGS+= --with-gcdmaster=no
.if ${PORT_OPTIONS:MTOC2MP3}
LIB_DEPENDS+= libmp3lame.so:audio/lame
CONFIGURE_ARGS+= --with-lame-include=${LOCALBASE}/include \
CONFIGURE_ARGS+= --disable-lame-test \
--with-lame-include=${LOCALBASE}/include \
--with-lame-lib=${LOCALBASE}/lib
PLIST_SUB+= TOC2MP3=""
.else
@ -72,7 +73,7 @@ MAKE_ENV= CCOM=cc
SCSILIBXARCH!= ${UNAME} -m
post-extract:
@(cd ${WRKSRC}/scsilib/RULES && ${CP} os-freebsd.id os-dragonfly.id)
@(cd ${WRKSRC}/scsilib/RULES && ${CP} -p os-freebsd.id os-dragonfly.id)
.if ${SCSILIBXARCH} != "i386"
@${LN} -sf ${WRKSRC}/scsilib/RULES/i386-freebsd-cc.rul \
${WRKSRC}/scsilib/RULES/${SCSILIBXARCH}-${OPSYS:tl}-cc.rul
@ -83,31 +84,19 @@ post-patch:
45librscg 55cdda2wav 55cdrecord 55cmd 55mkisofs 55mkisofs!@!diag \
55readcd 55scgcheck 55scgskeleton 55rscsi 85man
@${RM} ${WRKSRC}/scsilib/TARGETS/${i}
.endfor
@${REINPLACE_CMD} -e 's|"$$ac_declaration"|"$$ac_declarationXXX"|g' \
${WRKSRC}/configure
.for i in include/schily.h libscg/scsitransp.c libschily/fexec.c \
libschily/stdio/fgetline.c
@${REINPLACE_CMD} -E -e 's|fexecve|js_fexecve|g; \
s|^getline|js_getline|g;s|([^f_])getline|\1js_getline|g' \
${WRKSRC}/scsilib/${i}
.endfor
.if ${PORTNAME} == "gcdmaster"
@${REINPLACE_CMD} -E -e 's|(sigc\+\+/)object.h|\1trackable.h|g' \
${WRKSRC}/xdao/CdDevice.h
@${REINPLACE_CMD} -E -e 's|(^SUBDIRS.+) utils|\1|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -E -e 's|(^gladedir.+=).+|\1 ${DATADIR}|' \
${WRKSRC}/xdao/Makefile.in
@${REINPLACE_CMD} -E -e 's|[&]?(pixmap_) == 0|!\1|g' \
${WRKSRC}/xdao/SampleDisplay.cc
${WRKSRC}/gcdmaster/Makefile.in
@${REINPLACE_CMD} -E -e \
's|(SET_CDRDAO_PATH.+path=)(cdrdao)|\1${LOCALBASE}\/bin\/\2|g' \
${WRKSRC}/xdao/Settings.cc
${WRKSRC}/gcdmaster/Settings.cc
@${REINPLACE_CMD} -E -e \
's|(icon-filename=).+(gcdmaster-doc.png)|\1${LOCALBASE}\/share\/pixmaps\/document-icons\/\2|g' \
${WRKSRC}/xdao/gcdmaster.keys
${WRKSRC}/gcdmaster/gcdmaster.keys
@${REINPLACE_CMD} -e 's|connect(SigC::slot|connect(sigc::ptr_fun|g' \
${WRKSRC}/xdao/xcdrdao.cc
${WRKSRC}/gcdmaster/xcdrdao.cc
.else
.for i in cdrdao.man main.cc
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/dao/${i}
@ -121,34 +110,35 @@ post-patch:
.if ${PORTNAME} == "gcdmaster"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xdao/gcdmaster ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xdao/gcdmaster.man \
${INSTALL_PROGRAM} ${WRKSRC}/gcdmaster/gcdmaster \
${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/gcdmaster/gcdmaster.man \
${STAGEDIR}${PREFIX}/man/man1/gcdmaster.1
@${MKDIR} ${STAGEDIR}${LOCALBASE}/share/pixmaps/document-icons
${INSTALL_DATA} ${WRKSRC}/xdao/gcdmaster-doc.png \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/gcdmaster-doc.png \
${STAGEDIR}${LOCALBASE}/share/pixmaps/document-icons
@${MKDIR} ${STAGEDIR}${LOCALBASE}/share/application-registry
${INSTALL_DATA} ${WRKSRC}/xdao/gcdmaster.applications \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/gcdmaster.applications \
${STAGEDIR}${LOCALBASE}/share/application-registry
${INSTALL_DATA} ${WRKSRC}/xdao/gcdmaster.desktop \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/gcdmaster.desktop \
${STAGEDIR}${LOCALBASE}/share/applications
@${MKDIR} ${STAGEDIR}${LOCALBASE}/share/mime-info
${INSTALL_DATA} ${WRKSRC}/xdao/gcdmaster.keys \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/gcdmaster.keys \
${STAGEDIR}${LOCALBASE}/share/mime-info
${INSTALL_DATA} ${WRKSRC}/xdao/gcdmaster.mime \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/gcdmaster.mime \
${STAGEDIR}${LOCALBASE}/share/mime-info
${INSTALL_DATA} ${WRKSRC}/xdao/gcdmaster.png \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/gcdmaster.png \
${STAGEDIR}${LOCALBASE}/share/pixmaps
@${MKDIR} ${STAGEDIR}${LOCALBASE}/etc/gconf/schemas
${INSTALL_DATA} ${WRKSRC}/xdao/gcdmaster.schemas \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/gcdmaster.schemas \
${STAGEDIR}${LOCALBASE}/etc/gconf/schemas
@${MKDIR} ${STAGEDIR}${LOCALBASE}/share/mime/packages
${INSTALL_DATA} ${WRKSRC}/xdao/gcdmaster.xml \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/gcdmaster.xml \
${STAGEDIR}${LOCALBASE}/share/mime/packages
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/xdao/glade/Preferences.glade \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/glade/Preferences.glade \
${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/xdao/glade/ProjectChooser.glade \
${INSTALL_DATA} ${WRKSRC}/gcdmaster/glade/ProjectChooser.glade \
${STAGEDIR}${DATADIR}
.else
do-install:

View File

@ -1,2 +1,3 @@
SHA256 (cdrdao-1.2.3.tar.bz2) = 8193cb8fa6998ac362c55807e89ad0b3c63edc6b01afaeb3d5042519527fb75e
SIZE (cdrdao-1.2.3.tar.bz2) = 1428695
TIMESTAMP = 1528148639
SHA256 (cdrdao-1.2.4.tar.bz2) = 358d9cb83370ceaecdc60564cbf14c2ea2636eac60a966e2461c011ba09853b4
SIZE (cdrdao-1.2.4.tar.bz2) = 1442181

View File

@ -1,11 +0,0 @@
--- dao/CdrDriver.cc.orig 2009-09-12 16:21:25 UTC
+++ dao/CdrDriver.cc
@@ -495,7 +495,7 @@ unsigned char CdrDriver::syncPattern[12]
0, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0
};
-char CdrDriver::REMOTE_MSG_SYNC_[4] = { 0xff, 0x00, 0xff, 0x00 };
+unsigned char CdrDriver::REMOTE_MSG_SYNC_[4] = { 0xff, 0x00, 0xff, 0x00 };
/* Maps a string to the corresponding driver option value

View File

@ -1,11 +0,0 @@
--- dao/CdrDriver.h.orig 2009-02-21 10:27:31 UTC
+++ dao/CdrDriver.h
@@ -440,7 +440,7 @@ protected:
bool fullBurn_;
static unsigned char syncPattern[12];
- static char REMOTE_MSG_SYNC_[4];
+ static unsigned char REMOTE_MSG_SYNC_[4];
static int speed2Mult(int);
static int mult2Speed(int);

View File

@ -1,22 +1,22 @@
--- dao/cdrdao.man.orig Sat Dec 28 03:05:59 2002
+++ dao/cdrdao.man Sat Dec 28 03:08:17 2002
@@ -783,13 +783,9 @@
--- dao/cdrdao.man.orig 2018-05-16 10:46:39 UTC
+++ dao/cdrdao.man
@@ -798,13 +798,9 @@ following locations. The files will be r
.I cdrdao
in that order:
-1. /etc/cdrdao.conf
+1. %%PREFIX%%/etc/cdrdao.conf
-
-2. /etc/defaults/cdrdao
-
-3. /etc/default/cdrdao
-
+1. %%PREFIX%%/etc/cdrdao.conf
-4. $HOME/.cdrdao
+2. $HOME/.cdrdao
Command line options will overwrite the loaded settings.
@@ -869,4 +865,4 @@
@@ -886,4 +882,4 @@ resources may not be released. Use ipcs(
.ft R
.fi
.SH SEE ALSO

View File

@ -1,6 +1,6 @@
--- dao/main.cc.orig Sat Dec 28 03:01:20 2002
+++ dao/main.cc Sat Dec 28 03:04:38 2002
@@ -2314,11 +2314,7 @@
--- dao/main.cc.orig 2018-05-16 10:46:39 UTC
+++ dao/main.cc
@@ -2330,15 +2330,7 @@ int main(int argc, char **argv)
Settings* settings = new Settings;
@ -9,6 +9,10 @@
- log_message(3, "Read settings from \"%s\".", settingsPath);
-
- settingsPath = "/etc/defaults/cdrdao";
- if (settings->read(settingsPath) == 0)
- log_message(3, "Read settings from \"%s\".", settingsPath);
-
- settingsPath = "/etc/default/cdrdao";
+ settingsPath = "%%PREFIX%%/etc/cdrdao.conf";
if (settings->read(settingsPath) == 0)
log_message(3, "Read settings from \"%s\".", settingsPath);

View File

@ -1,6 +1,6 @@
--- scsilib/RULES/i386-freebsd-cc.rul.orig Tue Oct 15 22:43:39 2002
+++ scsilib/RULES/i386-freebsd-cc.rul Sun Oct 27 19:59:00 2002
@@ -24,7 +24,8 @@
--- scsilib/RULES/i386-freebsd-cc.rul.orig 2002-10-15 20:43:39 UTC
+++ scsilib/RULES/i386-freebsd-cc.rul
@@ -24,7 +24,8 @@ include $(SRCROOT)/$(RULESDIR)/rules.prg
###########################################################################
CPPFLAGS= $(CPPOPTS) $(CPPOPTX)
@ -10,7 +10,7 @@
CPPOPTS= -I. -I$(ARCHDIR) -I$(OINCSDIR) $(INCDIRS:%=-I%) $(OSDEFS)
COPTS=
@@ -57,14 +58,14 @@
@@ -57,14 +58,14 @@ LNDYNLIB= @$(SYMLINK) $(TARGET) $(PTARGE
FLOAT_OPTIONS=

View File

@ -1,21 +1,4 @@
###########################################################################
# This patch was contributed by Dimitry Andric.
###########################################################################
# The contents of this file are subject to the terms of the
# Common Development and Distribution License, Version 1.0 only
# (the "License"). You may not use this file except in compliance
# with the License.
#
# See the file CDDL.Schily.txt in this distribution for details.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file CDDL.Schily.txt from this distribution.
###########################################################################
# The file CDDL.Schily.txt can be found in the original cdrtools tarball,
# which is mirrored at ftp://ftp.freebsd.org/pub/FreeBSD/distfiles/.
###########################################################################
--- scsilib/inc/avoffset.c.orig 2009-10-05 11:58:21 UTC
--- scsilib/inc/avoffset.c.orig 2018-05-16 10:46:58 UTC
+++ scsilib/inc/avoffset.c
@@ -61,7 +61,7 @@ main(ac, av)
{

View File

@ -1,20 +1,3 @@
###########################################################################
# This patch was contributed by Dimitry Andric.
###########################################################################
# The contents of this file are subject to the terms of the
# Common Development and Distribution License, Version 1.0 only
# (the "License"). You may not use this file except in compliance
# with the License.
#
# See the file CDDL.Schily.txt in this distribution for details.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file CDDL.Schily.txt from this distribution.
###########################################################################
# The file CDDL.Schily.txt can be found in the original cdrtools tarball,
# which is mirrored at ftp://ftp.freebsd.org/pub/FreeBSD/distfiles/.
###########################################################################
--- scsilib/inc/getfp.c.orig 2003-07-12 23:10:47 UTC
+++ scsilib/inc/getfp.c
@@ -56,7 +56,7 @@

View File

@ -1,4 +1,4 @@
--- scsilib/include/mconfig.h.orig 2009-10-05 11:58:21 UTC
--- scsilib/include/mconfig.h.orig 2018-05-16 10:46:58 UTC
+++ scsilib/include/mconfig.h
@@ -72,12 +72,12 @@ extern "C" {
* Types/Keywords

View File

@ -1,20 +1,3 @@
###########################################################################
# This patch was contributed by Dimitry Andric.
###########################################################################
# The contents of this file are subject to the terms of the
# Common Development and Distribution License, Version 1.0 only
# (the "License"). You may not use this file except in compliance
# with the License.
#
# See the file CDDL.Schily.txt in this distribution for details.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file CDDL.Schily.txt from this distribution.
###########################################################################
# The file CDDL.Schily.txt can be found in the original cdrtools tarball,
# which is mirrored at ftp://ftp.freebsd.org/pub/FreeBSD/distfiles/.
###########################################################################
--- scsilib/libschily/getfp.c.orig 2003-07-12 23:10:47 UTC
+++ scsilib/libschily/getfp.c
@@ -23,6 +23,7 @@

View File

@ -1,5 +1,5 @@
--- trackdb/FormatMp3.cc.orig 2010-06-06 16:45:00.000000000 +0200
+++ trackdb/FormatMp3.cc 2010-06-06 16:45:36.000000000 +0200
--- trackdb/FormatMp3.cc.orig 2018-05-15 13:30:52 UTC
+++ trackdb/FormatMp3.cc
@@ -111,6 +111,7 @@ FormatSupport::Status FormatMp3::madInit
// Initialize libao for WAV output;

View File

@ -1,5 +1,5 @@
--- trackdb/FormatOgg.cc.orig 2010-06-06 16:45:05.000000000 +0200
+++ trackdb/FormatOgg.cc 2010-06-06 16:48:23.000000000 +0200
--- trackdb/FormatOgg.cc.orig 2018-05-15 13:30:52 UTC
+++ trackdb/FormatOgg.cc
@@ -84,6 +84,7 @@ FormatSupport::Status FormatOgg::oggInit
return FS_WRONG_FORMAT;
}

View File

@ -1,24 +0,0 @@
--- utils/toc2mp3.cc.orig 2003-02-22 10:16:56 UTC
+++ utils/toc2mp3.cc
@@ -143,8 +143,8 @@ static void printUsage()
message(0, "LAME encoder version: %s", get_lame_version());
message(0, "Supported bit rates: ");
- for (int i = 0; i < 16 && bitrate_table[1][i] >= 0; i++) {
- message(0, "%d ", bitrate_table[1][i]);
+ for (int br, i = 0; (br = lame_get_bitrate(1, i)) >= 0; i++) {
+ message(0, "%d ", br);
}
message(0, "");
}
@@ -238,8 +238,8 @@ lame_global_flags *init_encoder(int bitr
lame_global_flags *lf;
int bitrateOk = 0;
- for (int i = 0; bitrate_table[1][i] >= 0 && !bitrateOk; i++) {
- if (bitrate == bitrate_table[1][i])
+ for (int br, i = 0; (br = lame_get_bitrate(1, i)) >= 0 && !bitrateOk; i++) {
+ if (br == bitrate)
bitrateOk = 1;
}

View File

@ -1,11 +0,0 @@
--- xdao/CdDevice.cc.orig 2009-02-21 13:49:17 UTC
+++ xdao/CdDevice.cc
@@ -255,7 +255,7 @@ int CdDevice::updateStatus()
bool CdDevice::updateProgress(Glib::IOCondition cond, int fd)
{
- static char msgSync[4] = { 0xff, 0x00, 0xff, 0x00 };
+ static unsigned char msgSync[4] = { 0xff, 0x00, 0xff, 0x00 };
fd_set fds;
int state = 0;
char buf[10];

View File

@ -1,10 +0,0 @@
--- xdao/SoundIF-ao.cc.orig 2010-06-06 16:37:14.000000000 +0200
+++ xdao/SoundIF-ao.cc 2010-06-06 16:42:17.000000000 +0200
@@ -37,6 +37,7 @@ SoundIF::SoundIF()
impl_ = new SoundIFImpl;
impl_->driverId = ao_default_driver_id();
+ memset(&impl_->format, 0, sizeof(impl_->format));
impl_->format.bits = 16;
impl_->format.rate = 44100;
impl_->format.channels = 2;

View File

@ -1,8 +1,7 @@
# Created by: marius@alchemy.franken.de
# Created by: marius
# $FreeBSD$
PORTNAME= gcdmaster
PORTREVISION= 8
COMMENT= GNOME frontend for cdrdao