- Update to 1.7
  - Submitter takes maintainership

Moreover:
  - Refactor pkg-plist as PLIST_FILES/PORTDOCS
  - Replace the Makefile patch by USE_GMAKE and post-patch

PR:		ports/80917 [1]
Submitted by:	Erik Greenwald <erik@smluc.org> (new maintainer) [1]
This commit is contained in:
Jean-Yves Lefort 2005-05-25 09:21:12 +00:00
parent 78059d78f2
commit 81368dd220
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=136096
5 changed files with 33 additions and 50 deletions

View File

@ -6,26 +6,39 @@
#
PORTNAME= picprog
PORTVERSION= 1.4
PORTVERSION= 1.7
CATEGORIES= devel
MASTER_SITES= http://hyvatti.iki.fi/~jaakko/pic/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= erik@smluc.org
COMMENT= Serial port pic16c84 programmer
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_ENV= CXX="${CXX}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/picprog
MAN1= picprog.1
DOCS= README picprog.html *.jpg *.png
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
post-patch:
@${REINPLACE_CMD} -e 's|^CXX=.*||; s|^CXXFLAGS=.*||; s|^LDFLAGS=.*||' \
${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/picprog ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/picprog.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/picprog.1 ${MAN1PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
${MKDIR} ${DOCSDIR}
.for f in README *.png picprog.html
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (picprog-1.4.tar.gz) = 98d8fb42f92b57ea2114033a3f207706
SIZE (picprog-1.4.tar.gz) = 53394
MD5 (picprog-1.7.tar.gz) = 342f65a9cc71a0507fe8083181e2681c
SIZE (picprog-1.7.tar.gz) = 55118

View File

@ -1,33 +0,0 @@
--- Makefile.orig Mon Jan 12 22:42:23 2004
+++ Makefile Mon Jan 12 22:44:01 2004
@@ -26,10 +26,6 @@
# Please use a reasonably recent GNU make.
-CXX=g++
-CXXFLAGS=-g -O2 -Wall -W -Wwrite-strings -Wmissing-prototypes
-LDFLAGS=-g
-
OBJS=main.o picport.o hexfile.o program.o
PROG=picprog
@@ -37,6 +33,8 @@
$(PROG): $(OBJS)
$(CXX) $(LDFLAGS) $(OBJS) -o $@
+.cc.o:
+ $(CXX) -c $(CXXFLAGS) $(CPPFLAGS) $>
dep:
$(CXX) -M $(CXXFLAGS) *.cc > .depend
@@ -55,10 +53,3 @@
install: all
install -c -o 0 -g 0 -m 755 $(PROG) /usr/local/bin/
install -c -o 0 -g 0 -m 644 *.1 /usr/local/man/man1/
-
-#
-# include a dependency file if one exists
-#
-ifeq (.depend,$(wildcard .depend))
-include .depend
-endif

View File

@ -0,0 +1,11 @@
--- picport.cc.orig Thu Apr 29 06:08:10 2004
+++ picport.cc Wed May 25 11:09:06 2005
@@ -40,7 +40,7 @@
#include <unistd.h>
#include <termios.h>
#include <sysexits.h>
-#include <string.h>
+#include <string>
#include <sched.h>
#include "picport.h"

View File

@ -1,8 +0,0 @@
bin/picprog
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/adapter.jpg
%%PORTDOCS%%%%DOCSDIR%%/anybrowser3.png
%%PORTDOCS%%%%DOCSDIR%%/jdm84ne1.png
%%PORTDOCS%%%%DOCSDIR%%/jdm84pcb4.png
%%PORTDOCS%%%%DOCSDIR%%/picprog.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%