Support CC/CXX/CFLAGS/CXXFLAGS/PREFIX properly; tar -> ${TAR}.

PR:		20419
Submitted by:	Ports Fury
This commit is contained in:
Will Andrews 2000-08-11 04:02:02 +00:00
parent b74634e5ca
commit 812e541141
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31504
14 changed files with 267 additions and 101 deletions

View File

@ -10,8 +10,6 @@ PORTVERSION= 0.9.13
CATEGORIES= deskutils
MASTER_SITES= http://www-cad.eecs.berkeley.edu/HomePages/aml/abacus/ \
http://tahoe.inesc.pt/~aml/abacus/
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tgz
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= steve
@ -22,43 +20,39 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
tk82.1:${PORTSDIR}/x11-toolkits/tk82
ALL_TARGET= dep tcl_interf/nxlc
USE_GMAKE= yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${PKGNAME}
USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
ALL_TARGET= dep tcl_interf/nxlc
MAN1= abacus.1
pre-patch:
@ (cd ${WRKSRC}; find -d . -name RCS -exec ${RM} -rf {} \;)
post-extract:
@(cd ${WRKSRC}; find -d . -name RCS -exec ${RM} -rf {} \;)
@(cd ${WRKSRC}; ${RM} canvas; ${LN} -sf canvas-tcl8.2.2 canvas)
post-patch:
@ (cd ${WRKSRC}; ${RM} canvas; ${LN} -sf canvas-tcl8.2.2 canvas)
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/abacus
do-install:
@ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
@ ${INSTALL_MAN} ${WRKSRC}/doc/${DISTNAME}.1 ${PREFIX}/man/man1
@ ${MKDIR} ${PREFIX}/share/abacus
@ ${MKDIR} ${PREFIX}/share/abacus/display
@ ${INSTALL_DATA} ${WRKSRC}/display/*.tcl ${PREFIX}/share/abacus/display
@ ${MKDIR} ${PREFIX}/share/abacus/graphics
@ ${INSTALL_DATA} ${WRKSRC}/graphics/*.tcl ${PREFIX}/share/abacus/graphics
@ ${MKDIR} ${PREFIX}/share/abacus/runlib
@ ${INSTALL_DATA} ${WRKSRC}/runlib/*.tcl ${PREFIX}/share/abacus/runlib
@ ${INSTALL_DATA} ${WRKSRC}/runlib/version ${PREFIX}/share/abacus/runlib
@ ${MKDIR} ${PREFIX}/share/abacus/runlib/bitmaps
@ ${INSTALL_DATA} ${WRKSRC}/runlib/bitmaps/* ${PREFIX}/share/abacus/runlib/bitmaps
@ ${MKDIR} ${PREFIX}/share/abacus/tcl_interf
@ ${INSTALL_PROGRAM} ${WRKSRC}/tcl_interf/nxlc ${PREFIX}/share/abacus/tcl_interf
@ ${MKDIR} ${PREFIX}/share/examples/abacus
@ ${INSTALL_DATA} ${WRKSRC}/regressive/* ${PREFIX}/share/examples/abacus
post-install:
.if !defined(NOPORTDOCS)
@ ${RM} -fr ${WRKSRC}/doc/RCS ${WRKSRC}/doc/help/RCS
@ ${MKDIR} ${PREFIX}/share/doc/abacus
@ cd ${WRKSRC}/doc; tar --exclude ${DISTNAME}.1 -cf - . | \
(cd ${PREFIX}/share/doc/abacus; tar --unlink -xf - )
.endif
${INSTALL_SCRIPT} ${WRKSRC}/abacus ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/abacus.1 ${PREFIX}/man/man1
@${MKDIR} ${PREFIX}/share/abacus
@${MKDIR} ${PREFIX}/share/abacus/display
${INSTALL_DATA} ${WRKSRC}/display/*.tcl ${PREFIX}/share/abacus/display
@${MKDIR} ${PREFIX}/share/abacus/graphics
${INSTALL_DATA} ${WRKSRC}/graphics/*.tcl ${PREFIX}/share/abacus/graphics
@${MKDIR} ${PREFIX}/share/abacus/runlib
${INSTALL_DATA} ${WRKSRC}/runlib/*.tcl ${PREFIX}/share/abacus/runlib
${INSTALL_DATA} ${WRKSRC}/runlib/version ${PREFIX}/share/abacus/runlib
@${MKDIR} ${PREFIX}/share/abacus/runlib/bitmaps
${INSTALL_DATA} ${WRKSRC}/runlib/bitmaps/* ${PREFIX}/share/abacus/runlib/bitmaps
@${MKDIR} ${PREFIX}/share/abacus/tcl_interf
${INSTALL_PROGRAM} ${WRKSRC}/tcl_interf/nxlc ${PREFIX}/share/abacus/tcl_interf
@${MKDIR} ${PREFIX}/share/abacus/doc
${TAR} -C ${WRKSRC} --exclude abacus.1 -cf - doc | \
${TAR} -C ${PREFIX}/share/abacus --unlink -xf -
@${MKDIR} ${PREFIX}/share/examples/abacus
${INSTALL_DATA} ${WRKSRC}/regressive/* ${PREFIX}/share/examples/abacus
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (abacus.tgz) = babbcb9bf71121657ef8ae4619d603cf
MD5 (abacus-0.9.13.tar.gz) = babbcb9bf71121657ef8ae4619d603cf
MD5 (abacus-0.9.13.patch.gz) = e65c0b63b0d65cf867f1c11766077bfe

View File

@ -1,7 +1,19 @@
--- Makefile.options.orig Tue Oct 20 13:19:08 1998
+++ Makefile.options Thu Jan 20 18:04:03 2000
@@ -12,13 +12,13 @@
CPP=g++ -E
--- Makefile.options.orig Wed Oct 21 05:19:08 1998
+++ Makefile.options Fri Aug 4 04:53:59 2000
@@ -3,22 +3,22 @@
#
# C compiler
-CC = gcc
+CC ?= gcc
# C++ compiler
-CCC = g++
+CCC = $(CXX)
# C++ compiler running only the pre-processing stage
-CPP=g++ -E
+CPP = $(CXX) -E
# Grammar generator - e.g. bison,yacc
-YACC = bison
@ -12,7 +24,7 @@
# Favourite flags for favourite compiler
-CCFLAGS = -g
+CCFLAGS = $(CFLAGS)
+CCFLAGS = $(CXXFLAGS)
# Please don't change the next three lines unless you know what you are doing..
AROPTIONS = rc

View File

@ -4,13 +4,13 @@
#!/bin/sh
# The next line restarts using nxlc \
-exec $ABACUS_HOME/tcl_interf/nxlc -f $0 ${1+"$@"}
+exec /usr/X11R6/share/abacus/tcl_interf/nxlc -f $0 ${1+"$@"}
+exec %%PREFIX%%/share/abacus/tcl_interf/nxlc -f $0 ${1+"$@"}
@@ -15,7 +15,7 @@
if [info exists env(ABACUS_HOME)] {
set home $env(ABACUS_HOME)
} else {
- set home "."
+ set home "/usr/X11R6/share/abacus"
+ set home "%%PREFIX%%/share/abacus"
}
wm withdraw .

View File

@ -1,5 +1,5 @@
--- tcl_interf/Makefile Sun Oct 25 23:39:45 1998
+++ /home/andy/tmp/wrk/tcl_interf/Makefile Tue Jan 5 17:05:51 1999
--- tcl_interf/Makefile.orig Mon Oct 26 08:39:45 1998
+++ tcl_interf/Makefile Fri Aug 4 05:11:14 2000
@@ -14,7 +14,7 @@
OTHERSOURCES =
SOURCES = $(CSOURCES) $(OTHERSOURCES)
@ -9,3 +9,12 @@
include ../Makefile.options
@@ -34,7 +34,7 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
scan.c: scan.l
$(LEX) -i -t scan.l -oscan.c

View File

@ -1,5 +1,14 @@
--- calc/Makefile.orig Tue Oct 20 06:41:42 1998
+++ calc/Makefile Thu Jan 20 18:36:31 2000
--- calc/Makefile.orig Tue Oct 20 22:41:42 1998
+++ calc/Makefile Fri Aug 4 05:08:16 2000
@@ -30,7 +30,7 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
scan.c: scan.l
$(LEX) -oscan.c -i scan.l
@@ -40,8 +40,8 @@
gram.cc: gram.y scan.c

View File

@ -0,0 +1,15 @@
--- canvas-tcl8.2.2/Makefile.orig Fri Aug 4 05:14:09 2000
+++ canvas-tcl8.2.2/Makefile Fri Aug 4 05:16:51 2000
@@ -31,10 +31,10 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
tkEvent.o: tkEvent.c
- $(CC) $(IFLAGS) $(CCFLAGS) -DTK_FILE_READ_PTR=1 -c tkEvent.c
+ $(CC) $(IFLAGS) $(CFLAGS) -DTK_FILE_READ_PTR=1 -c tkEvent.c
scan.c: scan.l
$(LEX) -i -t scan.l > scan.c

View File

@ -0,0 +1,27 @@
--- display/Makefile.orig Fri Aug 21 06:54:37 1998
+++ display/Makefile Fri Aug 4 21:37:07 2000
@@ -27,15 +27,7 @@
LIBS =
-CC = gcc
-CCC = g++
-CPP=g++ -E
-YACC = yacc
-YACCFLAGS =
-LEX = flex
-CCFLAGS = -g
IFLAGS = -I$(IDIR)
-LFLAGS = -L/usr/local/tcl/lib -L/usr/local/tk/lib -L.
$(TARGET) : $(OBJECTS)
@@ -49,7 +41,7 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
scan.c: scan.l
$(LEX) -i -t scan.l > scan.c

View File

@ -0,0 +1,26 @@
--- graphics/Makefile.orig Fri Aug 21 07:02:07 1998
+++ graphics/Makefile Fri Aug 4 21:37:33 2000
@@ -20,14 +20,7 @@
LIBS =
-CC = gcc
-CCC = g++
-CPP=g++ -E
-YACC = bison
-LEX = flex
-CCFLAGS = -g
IFLAGS = -I$(IDIR)
-LFLAGS = -L/usr/local/tcl/lib -L/usr/local/tk/lib -L.
$(TARGET) : $(OBJECTS)
@@ -41,7 +34,7 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
scan.c: scan.l
$(LEX) -i -t scan.l > scan.c

View File

@ -0,0 +1,26 @@
--- include/Makefile.orig Fri Aug 21 07:03:26 1998
+++ include/Makefile Fri Aug 4 21:38:02 2000
@@ -20,14 +20,7 @@
LIBS =
-CC = gcc
-CCC = g++
-CPP=g++ -E
-YACC = bison
-LEX = flex
-CCFLAGS = -g
IFLAGS = -I$(IDIR)
-LFLAGS = -L/usr/local/tcl/lib -L/usr/local/tk/lib -L.
$(TARGET) :
@@ -42,7 +35,7 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
scan.c: scan.l
$(LEX) -i -t scan.l > scan.c

View File

@ -0,0 +1,11 @@
--- io/Makefile.orig Tue Oct 20 22:42:29 1998
+++ io/Makefile Fri Aug 4 21:33:00 2000
@@ -25,7 +25,7 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
scan.c: scan.l
$(LEX) -i -t scan.l > scan.c

View File

@ -0,0 +1,11 @@
--- lib/Makefile.orig Tue Oct 20 22:42:41 1998
+++ lib/Makefile Fri Aug 4 21:34:23 2000
@@ -23,7 +23,7 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
scan.c: scan.l
$(LEX) -i -t scan.l > scan.c

View File

@ -0,0 +1,26 @@
--- runlib/Makefile.orig Fri Aug 21 07:05:35 1998
+++ runlib/Makefile Fri Aug 4 21:34:54 2000
@@ -20,14 +20,7 @@
LIBS =
-CC = gcc
-CCC = g++
-CPP=g++ -E
-YACC = bison
-LEX = flex
-CCFLAGS = -g
IFLAGS = -I$(IDIR)
-LFLAGS = -L/usr/local/tcl/lib -L/usr/local/tk/lib -L.
$(TARGET) : $(OBJECTS)
@@ -41,7 +34,7 @@
$(CCC) $(CCFLAGS) $(IFLAGS) -c $<
.c.o:
- $(CC) $(CCFLAGS) $(IFLAGS) -c $<
+ $(CC) $(CFLAGS) $(IFLAGS) -c $<
scan.c: scan.l
$(LEX) -i -t scan.l > scan.c

View File

@ -23,6 +23,50 @@ share/abacus/display/sort.tcl
share/abacus/display/standard.tcl
share/abacus/display/user_interf.tcl
share/abacus/display/utils.tcl
share/abacus/doc/TODO
share/abacus/doc/abacus.ps
share/abacus/doc/benchmarks/README
share/abacus/doc/benchmarks/erase_cr.tcl
share/abacus/doc/benchmarks/graphs.tcl
share/abacus/doc/benchmarks/morerefs.tcl
share/abacus/doc/benchmarks/refs.tcl
share/abacus/doc/benchmarks/sort.tcl
share/abacus/doc/help/abacus
share/abacus/doc/help/about
share/abacus/doc/help/functions
share/abacus/doc/help/help
share/abacus/doc/help/installing
share/abacus/doc/presentation/README
share/abacus/doc/presentation/Undo_objectos.gif
share/abacus/doc/presentation/abacus-graphs.gif
share/abacus/doc/presentation/abacus-layout.gif
share/abacus/doc/presentation/abacus-presentation.tcl
share/abacus/doc/presentation/arquitectura_do_abacus.gif
share/abacus/doc/presentation/demo-help.gif
share/abacus/doc/presentation/display.gif
share/abacus/doc/presentation/estados_graficos.gif
share/abacus/doc/presentation/estrutura_de_dados.gif
share/abacus/doc/presentation/globalstate1.gif
share/abacus/doc/presentation/globalstate2.gif
share/abacus/doc/presentation/globalstate3.gif
share/abacus/doc/presentation/modelo_em_espiral.gif
share/abacus/doc/presentation/open-box.gif
share/abacus/doc/presentation/paste-special.gif
share/abacus/doc/presentation/save-2-slides.tcl
share/abacus/doc/presentation/slides.tcl
share/abacus/doc/presentation/undo_funcionamento.gif
share/abacus/doc/presentation/xxl.gif
share/abacus/doc/user_interf.fig
share/abacus/doc/website/abacus.cgi
share/abacus/doc/website/abacus.html
share/abacus/doc/website/abacus.html~
share/abacus/doc/website/screen.html
share/abacus/doc/website/screen1.gif
share/abacus/doc/website/screen2.gif
share/abacus/doc/wsff1.txt
share/abacus/doc/wsff2.txt
share/abacus/doc/wsff3.txt
share/abacus/doc/wsff4.txt
share/abacus/graphics/bar.tcl
share/abacus/graphics/explodepie.tcl
share/abacus/graphics/histogram.tcl
@ -30,9 +74,6 @@ share/abacus/graphics/line.tcl
share/abacus/graphics/pie.tcl
share/abacus/graphics/scatter.tcl
share/abacus/graphics/stackedBar.tcl
share/abacus/runlib/globals.tcl
share/abacus/runlib/globalvars.tcl
share/abacus/runlib/version
share/abacus/runlib/bitmaps/ascend.gif
share/abacus/runlib/bitmaps/ascend.xbm
share/abacus/runlib/bitmaps/bold.gif
@ -82,55 +123,14 @@ share/abacus/runlib/bitmaps/tmp.gif
share/abacus/runlib/bitmaps/under.gif
share/abacus/runlib/bitmaps/under.xbm
share/abacus/runlib/bitmaps/undo.gif
share/abacus/runlib/bitmaps/xxl.gif
share/abacus/runlib/bitmaps/undo.xbm
share/abacus/runlib/bitmaps/xxl.gif
share/abacus/runlib/bitmaps/xxl2.gif
share/abacus/runlib/bitmaps/xxl_bck.gif
share/abacus/runlib/globals.tcl
share/abacus/runlib/globalvars.tcl
share/abacus/runlib/version
share/abacus/tcl_interf/nxlc
share/doc/abacus/TODO
share/doc/abacus/abacus.ps
share/doc/abacus/user_interf.fig
share/doc/abacus/wsff1.txt
share/doc/abacus/wsff2.txt
share/doc/abacus/wsff3.txt
share/doc/abacus/wsff4.txt
share/doc/abacus/benchmarks/README
share/doc/abacus/benchmarks/erase_cr.tcl
share/doc/abacus/benchmarks/graphs.tcl
share/doc/abacus/benchmarks/morerefs.tcl
share/doc/abacus/benchmarks/refs.tcl
share/doc/abacus/benchmarks/sort.tcl
share/doc/abacus/help/abacus
share/doc/abacus/help/about
share/doc/abacus/help/functions
share/doc/abacus/help/help
share/doc/abacus/help/installing
share/doc/abacus/presentation/README
share/doc/abacus/presentation/Undo_objectos.gif
share/doc/abacus/presentation/abacus-graphs.gif
share/doc/abacus/presentation/abacus-layout.gif
share/doc/abacus/presentation/abacus-presentation.tcl
share/doc/abacus/presentation/arquitectura_do_abacus.gif
share/doc/abacus/presentation/demo-help.gif
share/doc/abacus/presentation/display.gif
share/doc/abacus/presentation/estados_graficos.gif
share/doc/abacus/presentation/estrutura_de_dados.gif
share/doc/abacus/presentation/globalstate1.gif
share/doc/abacus/presentation/globalstate2.gif
share/doc/abacus/presentation/globalstate3.gif
share/doc/abacus/presentation/modelo_em_espiral.gif
share/doc/abacus/presentation/open-box.gif
share/doc/abacus/presentation/paste-special.gif
share/doc/abacus/presentation/save-2-slides.tcl
share/doc/abacus/presentation/slides.tcl
share/doc/abacus/presentation/undo_funcionamento.gif
share/doc/abacus/presentation/xxl.gif
share/doc/abacus/website/abacus.cgi
share/doc/abacus/website/abacus.html
share/doc/abacus/website/abacus.html~
share/doc/abacus/website/screen.html
share/doc/abacus/website/screen1.gif
share/doc/abacus/website/screen2.gif
share/examples/abacus/allfuncs.wk1
share/examples/abacus/desp_97.wk1
share/examples/abacus/emprestimo.wk1
@ -142,15 +142,15 @@ share/examples/abacus/obras.wk1
share/examples/abacus/prestacao.wk1
share/examples/abacus/recpt197.wk1
share/examples/abacus/tables.wk1
@dirrm share/abacus/display
@dirrm share/abacus/graphics
@dirrm share/examples/abacus
@dirrm share/abacus/tcl_interf
@dirrm share/abacus/runlib/bitmaps
@dirrm share/abacus/runlib
@dirrm share/abacus/tcl_interf
@dirrm share/abacus/graphics
@dirrm share/abacus/doc/website
@dirrm share/abacus/doc/presentation
@dirrm share/abacus/doc/help
@dirrm share/abacus/doc/benchmarks
@dirrm share/abacus/doc
@dirrm share/abacus/display
@dirrm share/abacus
@dirrm share/doc/abacus/benchmarks
@dirrm share/doc/abacus/help
@dirrm share/doc/abacus/presentation
@dirrm share/doc/abacus/website
@dirrm share/doc/abacus
@dirrm share/examples/abacus