Add systemc 2.1.v1, a modeling platform for system-level C++ models.

PR:		ports/89987
Submitted by:	Daniel Thiele
This commit is contained in:
Sam Lawrance 2005-12-18 11:23:43 +00:00
parent 50acb2a4ac
commit 80b67d0d6d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151479
6 changed files with 409 additions and 0 deletions

View File

@ -53,6 +53,7 @@
SUBDIR += sceptre
SUBDIR += slffea
SUBDIR += spice
SUBDIR += systemc
SUBDIR += tkgate
SUBDIR += tochnog
SUBDIR += transcalc

47
cad/systemc/Makefile Normal file
View File

@ -0,0 +1,47 @@
# New ports collection makefile for: systemc
# Date created: 15 December 2005
# Whom: Daniel Thiele
#
# $FreeBSD$
#
PORTNAME= systemc
PORTVERSION= 2.1.v1
CATEGORIES= cad devel
EXTRACT_SUFX= .tgz
MAINTAINER= dthiele@gmx.net
COMMENT= A modeling platform for system-level C++ models
RESTRICTED= "You have to register at http://www.systemc.org/account/register.php first"
USE_AUTOTOOLS= aclocal:19 automake:19 autoheader:259 autoconf:259
USE_GMAKE= yes
HAS_CONFIGURE= yes
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../configure
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= is restricted. You have to register at http://www.systemc.org/account/register.php and download ${DISTFILES} from there first. Then put ${DISTFILES} into ${DISTDIR} and run make again
.endif
do-configure:
@${MKDIR} ${WRKSRC}/objdir
@(cd ${WRKSRC}/objdir && \
${CONFIGURE_ENV} && \
${CONFIGURE_SCRIPT} --prefix=${PREFIX}/${PORTNAME})
do-build:
@(cd ${WRKSRC}/objdir && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
do-install:
@(cd ${WRKSRC}/objdir && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.include <bsd.port.post.mk>

4
cad/systemc/distinfo Normal file
View File

@ -0,0 +1,4 @@
MD5 (systemc-2.1.v1.tgz) = 418923135b0c12fbf90622f017f1eee9
SHA256 (systemc-2.1.v1.tgz) =
f2d071819f012d45050d7e5be98c5a32e7c0b307cd154a163ab7dc74ae46c031
SIZE (systemc-2.1.v1.tgz) = 3605838

View File

@ -0,0 +1,35 @@
--- configure.in.orig Mon Apr 11 23:49:25 2005
+++ configure.in Fri Dec 16 23:06:05 2005
@@ -111,6 +111,23 @@
AS=as
QT_ARCH="sparc-os2"
;;
+ *freebsd*)
+ case "$CXX_COMP" in
+ c++ | g++)
+ EXTRA_CXXFLAGS="-Wall"
+ DEBUG_CXXFLAGS="-g"
+ OPT_CXXFLAGS="-O3"
+ TARGET_ARCH="freebsd"
+ CC="$CXX"
+ CFLAGS="$EXTRA_CXXFLAGS $OPT_CXXFLAGS"
+ ;;
+ *)
+ AC_MSG_ERROR("sorry...compiler not supported")
+ ;;
+ esac
+ AS=as
+ QT_ARCH="iX86"
+ ;;
*linux*)
case "$CXX_COMP" in
c++ | g++)
@@ -187,7 +204,7 @@
dnl
test "x$prefix" = xNONE && prefix=$srcdir
-current_dir=`pwd`; cd $prefix; prefix=`pwd`; cd $current_dir
+dnl current_dir=`pwd`; cd $prefix; prefix=`pwd`; cd $current_dir
dnl
dnl Substitution variables.

11
cad/systemc/pkg-descr Normal file
View File

@ -0,0 +1,11 @@
SystemC provides hardware-oriented constructs within the context of C++
as a
class library implemented in standard C++. Its use spans design and
verification from concept to implementation in hardware and software.
SystemC provides an interoperable modeling platform which enables the
development and exchange of very fast system-level C++ models. It also
provides
a stable platform for development of system-level tools.
WWW: http://www.systemc.org/

311
cad/systemc/pkg-plist Normal file
View File

@ -0,0 +1,311 @@
systemc/AUTHORS
systemc/COPYING
systemc/ChangeLog
systemc/INSTALL
systemc/LICENSE
systemc/NEWS
systemc/README
systemc/RELEASENOTES
systemc/docs/.DS_Store
systemc/docs/._.DS_Store
systemc/docs/FuncSpec20.pdf
systemc/docs/LRM_version2.1_April25_2005.pdf
systemc/docs/License.pdf
systemc/docs/README
systemc/docs/SystemC_2_1_features.pdf
systemc/docs/SystemC_2_1_overview.pdf
systemc/docs/UserGuide20.pdf
systemc/docs/WhitePaper20.pdf
systemc/include/sysc/communication/sc_buffer.h
systemc/include/sysc/communication/sc_clock.h
systemc/include/sysc/communication/sc_clock_ports.h
systemc/include/sysc/communication/sc_communication_ids.h
systemc/include/sysc/communication/sc_event_finder.h
systemc/include/sysc/communication/sc_event_queue.h
systemc/include/sysc/communication/sc_export.h
systemc/include/sysc/communication/sc_fifo.h
systemc/include/sysc/communication/sc_fifo_ifs.h
systemc/include/sysc/communication/sc_fifo_ports.h
systemc/include/sysc/communication/sc_interface.h
systemc/include/sysc/communication/sc_mutex.h
systemc/include/sysc/communication/sc_mutex_if.h
systemc/include/sysc/communication/sc_port.h
systemc/include/sysc/communication/sc_prim_channel.h
systemc/include/sysc/communication/sc_semaphore.h
systemc/include/sysc/communication/sc_semaphore_if.h
systemc/include/sysc/communication/sc_signal.h
systemc/include/sysc/communication/sc_signal_ifs.h
systemc/include/sysc/communication/sc_signal_ports.h
systemc/include/sysc/communication/sc_signal_resolved.h
systemc/include/sysc/communication/sc_signal_resolved_ports.h
systemc/include/sysc/communication/sc_signal_rv.h
systemc/include/sysc/communication/sc_signal_rv_ports.h
systemc/include/sysc/datatypes/bit/sc_bit.h
systemc/include/sysc/datatypes/bit/sc_bit_ids.h
systemc/include/sysc/datatypes/bit/sc_bit_proxies.h
systemc/include/sysc/datatypes/bit/sc_bv.h
systemc/include/sysc/datatypes/bit/sc_bv_base.h
systemc/include/sysc/datatypes/bit/sc_logic.h
systemc/include/sysc/datatypes/bit/sc_lv.h
systemc/include/sysc/datatypes/bit/sc_lv_base.h
systemc/include/sysc/datatypes/bit/sc_proxy.h
systemc/include/sysc/datatypes/fx/fx.h
systemc/include/sysc/datatypes/fx/sc_context.h
systemc/include/sysc/datatypes/fx/sc_fix.h
systemc/include/sysc/datatypes/fx/sc_fixed.h
systemc/include/sysc/datatypes/fx/sc_fx_ids.h
systemc/include/sysc/datatypes/fx/sc_fxcast_switch.h
systemc/include/sysc/datatypes/fx/sc_fxdefs.h
systemc/include/sysc/datatypes/fx/sc_fxnum.h
systemc/include/sysc/datatypes/fx/sc_fxnum_observer.h
systemc/include/sysc/datatypes/fx/sc_fxtype_params.h
systemc/include/sysc/datatypes/fx/sc_fxval.h
systemc/include/sysc/datatypes/fx/sc_fxval_observer.h
systemc/include/sysc/datatypes/fx/sc_ufix.h
systemc/include/sysc/datatypes/fx/sc_ufixed.h
systemc/include/sysc/datatypes/fx/scfx_ieee.h
systemc/include/sysc/datatypes/fx/scfx_mant.h
systemc/include/sysc/datatypes/fx/scfx_other_defs.h
systemc/include/sysc/datatypes/fx/scfx_params.h
systemc/include/sysc/datatypes/fx/scfx_rep.h
systemc/include/sysc/datatypes/fx/scfx_string.h
systemc/include/sysc/datatypes/fx/scfx_utils.h
systemc/include/sysc/datatypes/int/sc_bigint.h
systemc/include/sysc/datatypes/int/sc_biguint.h
systemc/include/sysc/datatypes/int/sc_int.h
systemc/include/sysc/datatypes/int/sc_int_base.h
systemc/include/sysc/datatypes/int/sc_int_ids.h
systemc/include/sysc/datatypes/int/sc_length_param.h
systemc/include/sysc/datatypes/int/sc_nbdefs.h
systemc/include/sysc/datatypes/int/sc_nbexterns.h
systemc/include/sysc/datatypes/int/sc_nbutils.h
systemc/include/sysc/datatypes/int/sc_signed.h
systemc/include/sysc/datatypes/int/sc_uint.h
systemc/include/sysc/datatypes/int/sc_uint_base.h
systemc/include/sysc/datatypes/int/sc_unsigned.h
systemc/include/sysc/datatypes/misc/sc_concatref.h
systemc/include/sysc/datatypes/misc/sc_value_base.h
systemc/include/sysc/kernel/sc_attribute.h
systemc/include/sysc/kernel/sc_boost.h
systemc/include/sysc/kernel/sc_cmnhdr.h
systemc/include/sysc/kernel/sc_constants.h
systemc/include/sysc/kernel/sc_cor.h
systemc/include/sysc/kernel/sc_dynamic_processes.h
systemc/include/sysc/kernel/sc_event.h
systemc/include/sysc/kernel/sc_externs.h
systemc/include/sysc/kernel/sc_join.h
systemc/include/sysc/kernel/sc_kernel_ids.h
systemc/include/sysc/kernel/sc_lambda.h
systemc/include/sysc/kernel/sc_lambda_defs.h
systemc/include/sysc/kernel/sc_lambda_exps.h
systemc/include/sysc/kernel/sc_lambda_friends.h
systemc/include/sysc/kernel/sc_macros.h
systemc/include/sysc/kernel/sc_module.h
systemc/include/sysc/kernel/sc_module_name.h
systemc/include/sysc/kernel/sc_object.h
systemc/include/sysc/kernel/sc_process.h
systemc/include/sysc/kernel/sc_process_b.h
systemc/include/sysc/kernel/sc_process_base.h
systemc/include/sysc/kernel/sc_process_host.h
systemc/include/sysc/kernel/sc_runnable.h
systemc/include/sysc/kernel/sc_sensitive.h
systemc/include/sysc/kernel/sc_simcontext.h
systemc/include/sysc/kernel/sc_time.h
systemc/include/sysc/kernel/sc_ver.h
systemc/include/sysc/kernel/sc_wait.h
systemc/include/sysc/kernel/sc_wait_cthread.h
systemc/include/sysc/packages/boost/assert.hpp
systemc/include/sysc/packages/boost/bind.hpp
systemc/include/sysc/packages/boost/bind/apply.hpp
systemc/include/sysc/packages/boost/bind/arg.hpp
systemc/include/sysc/packages/boost/bind/bind_cc.hpp
systemc/include/sysc/packages/boost/bind/bind_mf_cc.hpp
systemc/include/sysc/packages/boost/bind/bind_template.hpp
systemc/include/sysc/packages/boost/bind/make_adaptable.hpp
systemc/include/sysc/packages/boost/bind/mem_fn_cc.hpp
systemc/include/sysc/packages/boost/bind/mem_fn_template.hpp
systemc/include/sysc/packages/boost/bind/mem_fn_vw.hpp
systemc/include/sysc/packages/boost/bind/placeholders.hpp
systemc/include/sysc/packages/boost/bind/protect.hpp
systemc/include/sysc/packages/boost/checked_delete.hpp
systemc/include/sysc/packages/boost/config.hpp
systemc/include/sysc/packages/boost/config/compiler/borland.hpp
systemc/include/sysc/packages/boost/config/compiler/comeau.hpp
systemc/include/sysc/packages/boost/config/compiler/common_edg.hpp
systemc/include/sysc/packages/boost/config/compiler/compaq_cxx.hpp
systemc/include/sysc/packages/boost/config/compiler/gcc.hpp
systemc/include/sysc/packages/boost/config/compiler/greenhills.hpp
systemc/include/sysc/packages/boost/config/compiler/hp_acc.hpp
systemc/include/sysc/packages/boost/config/compiler/intel.hpp
systemc/include/sysc/packages/boost/config/compiler/kai.hpp
systemc/include/sysc/packages/boost/config/compiler/metrowerks.hpp
systemc/include/sysc/packages/boost/config/compiler/mpw.hpp
systemc/include/sysc/packages/boost/config/compiler/sgi_mipspro.hpp
systemc/include/sysc/packages/boost/config/compiler/sunpro_cc.hpp
systemc/include/sysc/packages/boost/config/compiler/vacpp.hpp
systemc/include/sysc/packages/boost/config/compiler/visualc.hpp
systemc/include/sysc/packages/boost/config/platform/aix.hpp
systemc/include/sysc/packages/boost/config/platform/amigaos.hpp
systemc/include/sysc/packages/boost/config/platform/beos.hpp
systemc/include/sysc/packages/boost/config/platform/bsd.hpp
systemc/include/sysc/packages/boost/config/platform/cygwin.hpp
systemc/include/sysc/packages/boost/config/platform/hpux.hpp
systemc/include/sysc/packages/boost/config/platform/irix.hpp
systemc/include/sysc/packages/boost/config/platform/linux.hpp
systemc/include/sysc/packages/boost/config/platform/macos.hpp
systemc/include/sysc/packages/boost/config/platform/solaris.hpp
systemc/include/sysc/packages/boost/config/platform/win32.hpp
systemc/include/sysc/packages/boost/config/posix_features.hpp
systemc/include/sysc/packages/boost/config/select_compiler_config.hpp
systemc/include/sysc/packages/boost/config/select_platform_config.hpp
systemc/include/sysc/packages/boost/config/select_stdlib_config.hpp
systemc/include/sysc/packages/boost/config/stdlib/dinkumware.hpp
systemc/include/sysc/packages/boost/config/stdlib/libcomo.hpp
systemc/include/sysc/packages/boost/config/stdlib/libstdcpp3.hpp
systemc/include/sysc/packages/boost/config/stdlib/modena.hpp
systemc/include/sysc/packages/boost/config/stdlib/msl.hpp
systemc/include/sysc/packages/boost/config/stdlib/roguewave.hpp
systemc/include/sysc/packages/boost/config/stdlib/sgi.hpp
systemc/include/sysc/packages/boost/config/stdlib/stlport.hpp
systemc/include/sysc/packages/boost/config/stdlib/vacpp.hpp
systemc/include/sysc/packages/boost/config/suffix.hpp
systemc/include/sysc/packages/boost/config/user.hpp
systemc/include/sysc/packages/boost/current_function.hpp
systemc/include/sysc/packages/boost/detail/algorithm.hpp
systemc/include/sysc/packages/boost/detail/allocator.hpp
systemc/include/sysc/packages/boost/detail/atomic_count.hpp
systemc/include/sysc/packages/boost/detail/atomic_count_gcc.hpp
systemc/include/sysc/packages/boost/detail/atomic_count_linux.hpp
systemc/include/sysc/packages/boost/detail/atomic_count_pthreads.hpp
systemc/include/sysc/packages/boost/detail/atomic_count_win32.hpp
systemc/include/sysc/packages/boost/detail/binary_search.hpp
systemc/include/sysc/packages/boost/detail/call_traits.hpp
systemc/include/sysc/packages/boost/detail/catch_exceptions.hpp
systemc/include/sysc/packages/boost/detail/compressed_pair.hpp
systemc/include/sysc/packages/boost/detail/dynamic_bitset.hpp
systemc/include/sysc/packages/boost/detail/iterator.hpp
systemc/include/sysc/packages/boost/detail/lightweight_mutex.hpp
systemc/include/sysc/packages/boost/detail/lightweight_test.hpp
systemc/include/sysc/packages/boost/detail/limits.hpp
systemc/include/sysc/packages/boost/detail/lwm_gcc.hpp
systemc/include/sysc/packages/boost/detail/lwm_irix.hpp
systemc/include/sysc/packages/boost/detail/lwm_linux.hpp
systemc/include/sysc/packages/boost/detail/lwm_nop.hpp
systemc/include/sysc/packages/boost/detail/lwm_pthreads.hpp
systemc/include/sysc/packages/boost/detail/lwm_win32.hpp
systemc/include/sysc/packages/boost/detail/lwm_win32_cs.hpp
systemc/include/sysc/packages/boost/detail/named_template_params.hpp
systemc/include/sysc/packages/boost/detail/numeric_traits.hpp
systemc/include/sysc/packages/boost/detail/ob_call_traits.hpp
systemc/include/sysc/packages/boost/detail/ob_compressed_pair.hpp
systemc/include/sysc/packages/boost/detail/select_type.hpp
systemc/include/sysc/packages/boost/detail/shared_array_nmt.hpp
systemc/include/sysc/packages/boost/detail/shared_count.hpp
systemc/include/sysc/packages/boost/detail/shared_ptr_nmt.hpp
systemc/include/sysc/packages/boost/detail/winapi.hpp
systemc/include/sysc/packages/boost/mem_fn.hpp
systemc/include/sysc/packages/boost/ref.hpp
systemc/include/sysc/packages/boost/shared_ptr.hpp
systemc/include/sysc/packages/boost/throw_exception.hpp
systemc/include/sysc/packages/boost/type.hpp
systemc/include/sysc/packages/boost/utility/addressof.hpp
systemc/include/sysc/packages/boost/weak_ptr.hpp
systemc/include/sysc/qt/md/axp.1.Makefile
systemc/include/sysc/qt/md/axp.2.Makefile
systemc/include/sysc/qt/md/axp.Makefile
systemc/include/sysc/qt/md/axp.README
systemc/include/sysc/qt/md/axp.c
systemc/include/sysc/qt/md/axp.h
systemc/include/sysc/qt/md/axp.s
systemc/include/sysc/qt/md/axp_b.s
systemc/include/sysc/qt/md/default.Makefile
systemc/include/sysc/qt/md/hppa-cnx.Makefile
systemc/include/sysc/qt/md/hppa.Makefile
systemc/include/sysc/qt/md/hppa.h
systemc/include/sysc/qt/md/hppa.s
systemc/include/sysc/qt/md/hppa_b.s
systemc/include/sysc/qt/md/i386.README
systemc/include/sysc/qt/md/i386.h
systemc/include/sysc/qt/md/i386.s
systemc/include/sysc/qt/md/i386_b.s
systemc/include/sysc/qt/md/ksr1.Makefile
systemc/include/sysc/qt/md/ksr1.h
systemc/include/sysc/qt/md/ksr1.s
systemc/include/sysc/qt/md/ksr1_b.s
systemc/include/sysc/qt/md/m88k.Makefile
systemc/include/sysc/qt/md/m88k.c
systemc/include/sysc/qt/md/m88k.h
systemc/include/sysc/qt/md/m88k.s
systemc/include/sysc/qt/md/m88k_b.s
systemc/include/sysc/qt/md/mips-irix5.s
systemc/include/sysc/qt/md/mips.h
systemc/include/sysc/qt/md/mips.s
systemc/include/sysc/qt/md/mips_b.s
systemc/include/sysc/qt/md/null.README
systemc/include/sysc/qt/md/null.c
systemc/include/sysc/qt/md/null.s
systemc/include/sysc/qt/md/powerpc.README
systemc/include/sysc/qt/md/powerpc.c
systemc/include/sysc/qt/md/powerpc_mach.h
systemc/include/sysc/qt/md/powerpc_mach.s
systemc/include/sysc/qt/md/powerpc_mach_b.s
systemc/include/sysc/qt/md/powerpc_sys5.h
systemc/include/sysc/qt/md/powerpc_sys5.s
systemc/include/sysc/qt/md/powerpc_sys5_b.s
systemc/include/sysc/qt/md/pthreads.Makefile
systemc/include/sysc/qt/md/solaris.README
systemc/include/sysc/qt/md/sparc.h
systemc/include/sysc/qt/md/sparc.s
systemc/include/sysc/qt/md/sparc_b.s
systemc/include/sysc/qt/md/vax.h
systemc/include/sysc/qt/md/vax.s
systemc/include/sysc/qt/md/vax_b.s
systemc/include/sysc/qt/qt.h
systemc/include/sysc/qt/qtmd.h
systemc/include/sysc/tracing/sc_trace.h
systemc/include/sysc/tracing/sc_vcd_trace.h
systemc/include/sysc/tracing/sc_wif_trace.h
systemc/include/sysc/utils/sc_hash.h
systemc/include/sysc/utils/sc_iostream.h
systemc/include/sysc/utils/sc_list.h
systemc/include/sysc/utils/sc_mempool.h
systemc/include/sysc/utils/sc_pq.h
systemc/include/sysc/utils/sc_report.h
systemc/include/sysc/utils/sc_report_handler.h
systemc/include/sysc/utils/sc_string.h
systemc/include/sysc/utils/sc_temporary.h
systemc/include/sysc/utils/sc_utils_ids.h
systemc/include/sysc/utils/sc_vector.h
systemc/include/systemc
systemc/include/systemc.h
systemc/lib-freebsd/libsystemc.a
@unexec rmdir %D/systemc/docs 2>/dev/null || true
@dirrm systemc/examples/sysc/2.1
@dirrm systemc/examples/sysc/fft
@dirrm systemc/examples/sysc
@dirrm systemc/examples/systemc
@unexec rmdir %D/systemc/examples 2>/dev/null || true
@dirrm systemc/include/sysc/communication
@dirrm systemc/include/sysc/datatypes/bit
@dirrm systemc/include/sysc/datatypes/fx
@dirrm systemc/include/sysc/datatypes/int
@dirrm systemc/include/sysc/datatypes/misc
@dirrm systemc/include/sysc/datatypes
@dirrm systemc/include/sysc/kernel
@dirrm systemc/include/sysc/packages/boost/bind
@dirrm systemc/include/sysc/packages/boost/config/compiler
@dirrm systemc/include/sysc/packages/boost/config/platform
@dirrm systemc/include/sysc/packages/boost/config/stdlib
@dirrm systemc/include/sysc/packages/boost/config
@dirrm systemc/include/sysc/packages/boost/detail
@dirrm systemc/include/sysc/packages/boost/utility
@dirrm systemc/include/sysc/packages/boost
@dirrm systemc/include/sysc/packages
@dirrm systemc/include/sysc/qt/md
@dirrm systemc/include/sysc/qt
@dirrm systemc/include/sysc/tracing
@dirrm systemc/include/sysc/utils
@dirrm systemc/include/sysc
@unexec rmdir %D/systemc/include 2>/dev/null || true
@unexec rmdir %D/systemc/lib-freebsd 2>/dev/null || true
@unexec rmdir %D/systemc 2>/dev/null || true