Add patches to support sparc64.

Submitted by:	tmm
This commit is contained in:
MANTANI Nobutaka 2002-10-06 12:19:58 +00:00
parent e25967e0a7
commit 80a478b717
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=67477
3 changed files with 27 additions and 1 deletions

View File

@ -1,6 +1,6 @@
--- configure.in.orig Fri Oct 19 23:09:18 2001
+++ configure.in Mon Oct 22 21:19:32 2001
@@ -179,6 +179,15 @@
@@ -179,6 +179,16 @@
machine='' opsys='' unported=no
case "${canonical}" in
@ -10,6 +10,7 @@
+ case "${canonical}" in
+ alpha*-*-freebsd*) machine=alpha ;;
+ i[3456]86-*-freebsd*) machine=intel386 ;;
+ sparc64-*-freebsd*) machine=sparc ;;
+ esac
+ ;;
+

View File

@ -0,0 +1,14 @@
--- src/alloc.c.orig Thu Sep 12 13:50:01 2002
+++ src/alloc.c Thu Sep 12 13:48:11 2002
@@ -3723,7 +3723,11 @@
/* This trick flushes the register windows so that all the state of
the process is contained in the stack. */
#ifdef sparc
+#ifdef __sparc64__
+ asm ("flushw");
+#else
asm ("ta 3");
+#endif
#endif
/* Save registers that we need to see on the stack. We need to see

View File

@ -0,0 +1,11 @@
--- src/m/sparc.h.orig Thu Sep 12 02:25:09 2002
+++ src/m/sparc.h Thu Sep 12 12:33:36 2002
@@ -89,7 +89,7 @@
#define PURESIZE 130000
#endif
-#if !defined (__NetBSD__) && !defined (__linux__) && !defined (__OpenBSD__)
+#if !defined (__NetBSD__) && !defined (__linux__) && !defined (__OpenBSD__) && !defined(__FreeBSD__)
/* This really belongs in s/sun.h. */
/* Say that the text segment of a.out includes the header;