New port: misc/libcomps: Comps XML file manipulation library
This commit is contained in:
parent
8873a13832
commit
809370b506
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=550107
@ -207,6 +207,7 @@
|
||||
SUBDIR += lesspipe
|
||||
SUBDIR += lf
|
||||
SUBDIR += libad9361-iio
|
||||
SUBDIR += libcomps
|
||||
SUBDIR += libeatmydata
|
||||
SUBDIR += libemos
|
||||
SUBDIR += libiio
|
||||
|
35
misc/libcomps/Makefile
Normal file
35
misc/libcomps/Makefile
Normal file
@ -0,0 +1,35 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libcomps
|
||||
DISTVERSIONPREFIX= ${PORTNAME}-
|
||||
DISTVERSION= 0.1.15
|
||||
CATEGORIES= misc
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Comps XML file manipulation library
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/../COPYING
|
||||
|
||||
LIB_DEPENDS= libexpat.so:textproc/expat2
|
||||
|
||||
USES= cmake gnome
|
||||
USE_GNOME= libxml2
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= rpm-software-management
|
||||
|
||||
WRKSRC_SUBDIR= ${PORTNAME}
|
||||
|
||||
CMAKE_OFF= ENABLE_TESTS ENABLE_DOCS
|
||||
|
||||
OPTIONS_DEFINE= PYTHON
|
||||
OPTIONS_DEFAULT= PYTHON
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
PYTHON_CMAKE_BOOL= BUILD_PYTHON_MODULE
|
||||
PYTHON_USES= python
|
||||
PYTHON_CMAKE_ON= -DPYTHON_DESIRED=${PYTHON_MAJOR_VER}
|
||||
|
||||
.include <bsd.port.mk>
|
3
misc/libcomps/distinfo
Normal file
3
misc/libcomps/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1601100862
|
||||
SHA256 (rpm-software-management-libcomps-libcomps-0.1.15_GH0.tar.gz) = 3304bf7b178fd719fff6fe67f365b63e486f2f5e3e6e0ff1780f42723776cb61
|
||||
SIZE (rpm-software-management-libcomps-libcomps-0.1.15_GH0.tar.gz) = 3711557
|
11
misc/libcomps/files/patch-CMakeLists.txt
Normal file
11
misc/libcomps/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,11 @@
|
||||
--- CMakeLists.txt.orig 2020-09-26 06:27:52 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -11,7 +11,7 @@ OPTION (ENABLE_DOCS "Build docs?" ON)
|
||||
|
||||
set(LIBCOMPS_OUT "${CMAKE_CURRENT_BINARY_DIR}/src")
|
||||
|
||||
-set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} --pedantic -std=c99 -Wall -Wextra -g -Wno-missing-field-initializers -O2 -fno-strict-aliasing -g")
|
||||
+set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} --pedantic -std=c99 -Wall -Wextra -Wno-missing-field-initializers -O2 -fno-strict-aliasing -g")
|
||||
set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS} -ggdb -O0 -Wall -Wextra")
|
||||
|
||||
set (VERSION "${libcomps_VERSION_MAJOR}.${libcomps_VERSION_MINOR}.${libcomps_VERSION_PATCH}")
|
10
misc/libcomps/files/patch-src_CMakeLists.txt
Normal file
10
misc/libcomps/files/patch-src_CMakeLists.txt
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/CMakeLists.txt.orig 2020-09-26 06:18:01 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -72,5 +72,6 @@ if (ENABLE_DEVELOPMENT)
|
||||
DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
|
||||
endif ()
|
||||
|
||||
+if (BUILD_PYTHON_MODULE)
|
||||
add_subdirectory(python)
|
||||
-
|
||||
+endif()
|
4
misc/libcomps/pkg-descr
Normal file
4
misc/libcomps/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
Libcomps is alternative for yum.comps library. It's written in pure C as library
|
||||
and there's bindings for python.
|
||||
|
||||
WWW: https://github.com/rpm-software-management/libcomps
|
31
misc/libcomps/pkg-plist
Normal file
31
misc/libcomps/pkg-plist
Normal file
@ -0,0 +1,31 @@
|
||||
include/libcomps/comps_bradix.h
|
||||
include/libcomps/comps_default.h
|
||||
include/libcomps/comps_dict.h
|
||||
include/libcomps/comps_doc.h
|
||||
include/libcomps/comps_doccategory.h
|
||||
include/libcomps/comps_docenv.h
|
||||
include/libcomps/comps_docgroup.h
|
||||
include/libcomps/comps_docgroupid.h
|
||||
include/libcomps/comps_docpackage.h
|
||||
include/libcomps/comps_elem.h
|
||||
include/libcomps/comps_hslist.h
|
||||
include/libcomps/comps_log.h
|
||||
include/libcomps/comps_log_codes.h
|
||||
include/libcomps/comps_mm.h
|
||||
include/libcomps/comps_mradix.h
|
||||
include/libcomps/comps_obj.h
|
||||
include/libcomps/comps_objdict.h
|
||||
include/libcomps/comps_objlist.h
|
||||
include/libcomps/comps_objmradix.h
|
||||
include/libcomps/comps_objradix.h
|
||||
include/libcomps/comps_parse.h
|
||||
include/libcomps/comps_radix.h
|
||||
include/libcomps/comps_set.h
|
||||
include/libcomps/comps_utils.h
|
||||
include/libcomps/comps_validate.h
|
||||
lib/libcomps.so
|
||||
lib/libcomps.so.0
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/libcomps-0.1.15-py%%PYTHON_VER%%.egg-info
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/libcomps/__init__.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/libcomps/_libpycomps.so
|
||||
libdata/pkgconfig/libcomps.pc
|
Loading…
Reference in New Issue
Block a user