Don't compile/install useless statically linked versions of shared objects.
This commit is contained in:
parent
332cf4cef7
commit
804465a973
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53598
@ -1,32 +1,32 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- monikers/Makefile.in.orig Fri Aug 3 10:29:46 2001
|
||||
+++ monikers/Makefile.in Fri Aug 3 10:30:33 2001
|
||||
@@ -189,10 +189,10 @@
|
||||
--- monikers/Makefile.in.orig Tue Jan 22 09:26:05 2002
|
||||
+++ monikers/Makefile.in Tue Jan 22 20:47:04 2002
|
||||
@@ -195,10 +195,10 @@
|
||||
DEFS = @DEFS@ -I. -I$(srcdir) -I..
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
-libmoniker_config_la_LDFLAGS =
|
||||
+libmoniker_config_la_LDFLAGS = -avoid-version
|
||||
+libmoniker_config_la_LDFLAGS = -avoid-version -module
|
||||
libmoniker_config_la_DEPENDENCIES = ../bonobo-conf/libbonobo_conf.la
|
||||
libmoniker_config_la_OBJECTS = bonobo-moniker-config.lo
|
||||
-libmoniker_gconf_la_LDFLAGS =
|
||||
+libmoniker_gconf_la_LDFLAGS = -avoid-version
|
||||
+libmoniker_gconf_la_LDFLAGS = -avoid-version -module
|
||||
@ENABLE_GCONF_TRUE@libmoniker_gconf_la_DEPENDENCIES =
|
||||
@ENABLE_GCONF_TRUE@libmoniker_gconf_la_OBJECTS = \
|
||||
@ENABLE_GCONF_TRUE@bonobo-moniker-gconf.lo bonobo-config-gconfdb.lo
|
||||
@@ -203,11 +203,11 @@
|
||||
@@ -209,11 +209,11 @@
|
||||
bonobo_moniker_xmldb_OBJECTS = bonobo-config-xmldb.$(OBJEXT) \
|
||||
bonobo-config-dirdb.$(OBJEXT) bonobo-moniker-xmldb.$(OBJEXT)
|
||||
bonobo_moniker_xmldb_DEPENDENCIES = ../bonobo-conf/libbonobo_conf.la
|
||||
-bonobo_moniker_xmldb_LDFLAGS =
|
||||
+bonobo_moniker_xmldb_LDFLAGS = -avoid-version
|
||||
+bonobo_moniker_xmldb_LDFLAGS = -avoid-version -module
|
||||
test_xmldb_OBJECTS = test-xmldb.$(OBJEXT) bonobo-config-xmldb.$(OBJEXT) \
|
||||
bonobo-config-dirdb.$(OBJEXT)
|
||||
test_xmldb_DEPENDENCIES = ../bonobo-conf/libbonobo_conf.la
|
||||
-test_xmldb_LDFLAGS =
|
||||
+test_xmldb_LDFLAGS = -avoid-version
|
||||
+test_xmldb_LDFLAGS = -avoid-version -module
|
||||
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
||||
CCLD = $(CC)
|
||||
|
@ -1,19 +1,27 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh 2001/08/27 09:51:26 1.1
|
||||
+++ ltmain.sh 2001/08/27 09:51:42
|
||||
@@ -2408,6 +2408,9 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
--- ltmain.sh.orig Sun Jan 20 16:11:07 2002
|
||||
+++ ltmain.sh Tue Jan 22 13:34:20 2002
|
||||
@@ -1060,6 +1060,7 @@
|
||||
|
||||
-module)
|
||||
module=yes
|
||||
+ build_old_libs=no
|
||||
continue
|
||||
;;
|
||||
|
||||
@@ -2442,6 +2443,9 @@
|
||||
*-*-openbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test "$build_libtool_need_lc" = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
if test $build_libtool_need_lc = "yes"; then
|
||||
@@ -4208,10 +4212,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
|
@ -10,9 +10,7 @@ include/bonobo-conf/bonobo-preferences.h
|
||||
include/bonobo-conf/bonobo-property-bag-proxy.h
|
||||
include/bonobo-conf/bonobo-property-editor.h
|
||||
include/bonobo-conf/bonobo-property-frame.h
|
||||
lib/bonobo/monikers/libmoniker_config.a
|
||||
lib/bonobo/monikers/libmoniker_config.so
|
||||
lib/bonobo/monikers/libmoniker_gconf.a
|
||||
lib/bonobo/monikers/libmoniker_gconf.so
|
||||
lib/libbonobo_conf.a
|
||||
lib/libbonobo_conf.so
|
||||
|
Loading…
Reference in New Issue
Block a user