- Update to 1.25

This commit is contained in:
Michael Johnson 2006-08-24 23:34:20 +00:00
parent cfb3d4c3ee
commit 7fc90ea87d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=171349
4 changed files with 29 additions and 70 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= faac
PORTVERSION= 1.24
PORTREVISION= 6
PORTVERSION= 1.25
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= faac
@ -16,37 +15,27 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= MPEG-2 and MPEG-4 AAC audio encoder
PATCH_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
NO_PACKAGE= Distribution in binary form is prohibited
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_DOS2UNIX= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= automake:15 autoheader:259 libtool:15
AUTOMAKE_ARGS= --add-missing
USE_GMAKE= yes
USE_DOS2UNIX= yes
CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
HAVECXX="yes"
INSTALLS_SHLIB= yes
OPTIONS= MPEG4IP "Enable mpeg4 audio encoding" On
LIBS="-lmp4v2"
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libmp4v2.a)
WITH_MPEG4IP=yes
.endif
.if !defined(WITHOUT_MPEG4IP) || defined(WITH_MPEG4IP)
LIB_DEPENDS+= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
.endif
post-patch:
@${ECHO_CMD} "" >>${WRKSRC}/libfaac/psych.h
@cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I .; \
${SETENV} ${SCRIPTS_ENV} ${LIBTOOLIZE} --automake
${REINPLACE_CMD} -e 's|$$lt_target|$$host|' \
${WRKSRC}/aclocal.m4
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (faac-1.24.tar.gz) = e72dc74db17b42b06155613489077ad7
SHA256 (faac-1.24.tar.gz) = a5844ff3bce0d7c885af71f41da01395d3253dcfc33863306a027a78a7cfad9e
SIZE (faac-1.24.tar.gz) = 282585
MD5 (faac-1.25.tar.gz) = 75eaffd18ee072eaca52ae2d622bb1db
SHA256 (faac-1.25.tar.gz) = 059313fcba287a95a7d71b696e54e29310b96566a2b1e7eb6ec1b03cfdf8e5b1
SIZE (faac-1.25.tar.gz) = 386608

View File

@ -0,0 +1,19 @@
--- configure.in.orig Thu Aug 24 18:43:12 2006
+++ configure.in Thu Aug 24 18:45:13 2006
@@ -1,7 +1,7 @@
AC_PREREQ(2.50)
AC_INIT(FAAC, 1.25, faac-dev@lists.sourceforge.net)
AC_CONFIG_AUX_DIR(.)
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE(faac, 1.25)
AM_CONFIG_HEADER(config.h)
@@ -35,6 +35,7 @@
if test x$external_mp4v2 = xyes; then
AC_MSG_NOTICE([*** Building with external mp4v2 ***])
+ MY_DEFINE(HAVE_LIBMP4V2)
else
if test x$WITHMP4V2 = xyes; then
AC_MSG_NOTICE([*** Building with internal mp4v2 ***])

View File

@ -1,49 +0,0 @@
--- include/faac.h.orig Mon Nov 24 13:10:32 2003
+++ include/faac.h Thu Oct 28 20:01:36 2004
@@ -36,7 +36,7 @@
# endif
#endif
-#pragma pack(push, 1)
+#include <sys/types.h>
typedef struct {
void *ptr;
@@ -76,17 +76,16 @@
int FAACAPI faacEncGetDecoderSpecificInfo(faacEncHandle hEncoder, unsigned char **ppBuffer,
unsigned long *pSizeOfDecoderSpecificInfo);
-
int FAACAPI faacEncEncode(faacEncHandle hEncoder, int32_t * inputBuffer, unsigned int samplesInput,
- unsigned char *outputBuffer,
- unsigned int bufferSize);
+ unsigned char *outputBuffer,
+ unsigned int bufferSize);
+
int FAACAPI faacEncClose(faacEncHandle hEncoder);
-#pragma pack(pop)
#ifdef __cplusplus
}
--- include/faaccfg.h.orig Wed Oct 29 05:31:24 2003
+++ include/faaccfg.h Thu Oct 28 20:01:13 2004
@@ -45,7 +45,6 @@
#define SHORTCTL_NOSHORT 1
#define SHORTCTL_NOLONG 2
-#pragma pack(push, 1)
typedef struct faacEncConfiguration
{
/* config version */
@@ -117,6 +116,5 @@
} faacEncConfiguration, *faacEncConfigurationPtr;
-#pragma pack(pop)
#endif /* _FAACCFG_H_ */