Update to 1-rc4.

Fix build error with CPUTYPE=p4. [1]
Fix MPEG-4 AAC audio file support on amd64. [2]
Add two knobs (WITH_LIBCACA and WITH_LIBTHEORA). [3]

PR:		ports/65314 [1], ports/65890 [2], ports/66220 [3]
Submitted by:	Joel Ray Holveck <joelh@piquan.org> [1], Tim Robbins <tim@robbins.dropbear.id.au> [2], michael johnson <ahze@ahze.net> [3]
This commit is contained in:
MANTANI Nobutaka 2004-05-12 16:49:13 +00:00
parent cbd58f858a
commit 7fc6587baa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=109019
13 changed files with 184 additions and 571 deletions

View File

@ -6,13 +6,12 @@
#
PORTNAME= xine
PORTVERSION= 1.0.r3
PORTREVISION= 5
PORTVERSION= 1.0.r4
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= lib
DISTNAME= ${PORTNAME}-lib-1-rc3c
DISTNAME= ${PORTNAME}-lib-1-rc4
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Libraries for xine multimedia player
@ -38,11 +37,11 @@ USE_GMAKE= yes
USE_GL= yes
USE_SDL= sdl
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/dvdread -I${X11BASE}/include" \
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/dvdread -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
THREAD_CFLAGS="${PTHREAD_CFLAGS}" \
THREAD_LIBS="${PTHREAD_LIBS}" \
X_EXTRA_LIBS="-lGL -lGLU -lXext -lX11 -lm"
EXTRA_X_LIBS="-lGL -lGLU -lXext -lX11 -lm"
CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32 --enable-ipv6
INSTALLS_SHLIB= yes
@ -52,10 +51,7 @@ MAN1= xine-config.1
# PRId64, INT16_MAX macro are not defined
.if ${OSVERSION} < 500040
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src:xine-engine:audio_out.c \
${PATCHDIR}/extra-patch-src:xine-engine:video_out.c \
${PATCHDIR}/extra-patch-src:xine-engine:metronom.c \
${PATCHDIR}/extra-patch-src:demuxers:demux_ogg.c
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-config.h.in
.endif
# CDIOCREADAUDIO macro is not defined
@ -64,43 +60,57 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src:input:input_cdda.c
.endif
.if ${XFREE86_VERSION} >= 4
PLIST_SUB+= HAVE_LIBXV=""
PLIST_SUB+= WITH_LIBXV=""
.else
PLIST_SUB+= HAVE_LIBXV="@comment "
PLIST_SUB+= WITH_LIBXV="@comment "
.endif
.if exists(${LOCALBASE}/bin/artsc-config) || defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
PLIST_SUB+= HAVE_ARTS=""
PLIST_SUB+= WITH_ARTS=""
.else
PLIST_SUB+= HAVE_ARTS="@comment "
PLIST_SUB+= WITH_ARTS="@comment "
.endif
.if exists(${LOCALBASE}/lib/libcaca.a) || defined(WITH_LIBCACA)
BUILD_DEPENDS+= caca-config:${PORTSDIR}/graphics/libcaca
PLIST_SUB+= WITH_LIBCACA=""
.else
PLIST_SUB+= WITH_LIBCACA="@comment "
.endif
.if ${HAVE_GNOME:Mesound} != "" || defined(WITH_ESOUND)
USE_GNOME+= esound
PLIST_SUB+= HAVE_ESOUND=""
PLIST_SUB+= WITH_ESOUND=""
.else
PLIST_SUB+= HAVE_ESOUND="@comment "
PLIST_SUB+= WITH_ESOUND="@comment "
.endif
.if ${HAVE_GNOME:Mgnomevfs2} != ""
USE_GNOME+= gnomevfs2
PLIST_SUB+= HAVE_GNOMEVFS2=""
PLIST_SUB+= WITH_GNOMEVFS2=""
.else
PLIST_SUB+= HAVE_GNOMEVFS2="@comment "
PLIST_SUB+= WITH_GNOMEVFS2="@comment "
.endif
.if ${ARCH} == "i386"
PLIST_SUB+= VIDIX=""
PLIST_SUB+= WITH_VIDIX=""
.else
PLIST_SUB+= VIDIX="@comment "
PLIST_SUB+= WITH_VIDIX="@comment "
.endif
.if exists(${X11BASE}/lib/libXvMCNVIDIA.so.1)
LIB_DEPENDS+= XvMCNVIDIA.1:${PORTSDIR}/x11/nvidia-driver
PLIST_SUB+= XVMC=""
PLIST_SUB+= WITH_XVMC=""
.else
PLIST_SUB+= XVMC="@comment "
PLIST_SUB+= WITH_XVMC="@comment "
.endif
.if exists(${LOCALBASE}/lib/libtheora.so.0) || defined (WITH_LIBTHEORA)
LIB_DEPENDS+= theora.0:${PORTSDIR}/graphics/libtheora
PLIST_SUB+= WITH_LIBTHEORA=""
.else
PLIST_SUB+= WITH_LIBTHEORA="@comment "
.endif
pre-everything::
@ -112,10 +122,20 @@ pre-everything::
.else
@${ECHO_MSG} "===> WITH_ARTS (arts support, enabled)"
.endif
.if !exists(${LOCALBASE}/lib/libcaca.a) && !defined(WITH_LIBCACA)
@${ECHO_MSG} "===> WITH_LIBCACA (libcaca support)"
.else
@${ECHO_MSG} "===> WITH_LIBCACA (libcaca support, enabled)"
.endif
.if !(${HAVE_GNOME:Mesound} != "") && !defined(WITH_ESOUND)
@${ECHO_MSG} "===> WITH_ESOUND (esound support)"
.else
@${ECHO_MSG} "===> WITH_ESOUND (esound support, enabled)"
.endif
.if !exists(${LOCALBASE}/lib/libtheora.so.0) && !defined(WITH_LIBTHEORA)
@${ECHO_MSG} "===> WITH_LIBTHEORA (libtheora support)"
.else
@${ECHO_MSG} "===> WITH_LIBTHEORA (libtheora support, enabled)"
.endif
@${ECHO_MSG} "===>"

View File

@ -1,2 +1,2 @@
MD5 (xine-lib-1-rc3c.tar.gz) = 7c51d35b92dc77cd1effc59394ff89de
SIZE (xine-lib-1-rc3c.tar.gz) = 6463319
MD5 (xine-lib-1-rc4.tar.gz) = 0ab4da35964044369768c90f931ce2c2
SIZE (xine-lib-1-rc4.tar.gz) = 6788315

View File

@ -0,0 +1,15 @@
--- config.h.in.orig Thu Apr 29 06:07:44 2004
+++ config.h.in Thu May 13 00:43:36 2004
@@ -554,3 +554,12 @@
/* Define to `unsigned' if <sys/types.h> does not define. */
#undef size_t
+
+#if defined(__alpha__) || defined(__amd64__) || defined(__ia64__) || defined(__\
+sparc64__)
+#define PRId64 "ld"
+#else if defined(__i386__) || defined(__powerpc__)
+#define PRId64 "lld"
+#endif
+#define INT16_MAX 0x7fff
+#define INT16_MIN (-0x7fff-1)

View File

@ -1,115 +0,0 @@
--- src/demuxers/demux_ogg.c.orig Wed Apr 7 23:14:21 2004
+++ src/demuxers/demux_ogg.c Wed Apr 7 23:15:31 2004
@@ -321,7 +321,7 @@
static void check_newpts (demux_ogg_t *this, int64_t pts, int video, int preview) {
int64_t diff;
- lprintf ("new pts %" PRId64 " found in stream\n",pts);
+ lprintf ("new pts %lld found in stream\n",pts);
diff = pts - this->last_pts[video];
@@ -329,7 +329,7 @@
(this->send_newpts || (this->last_pts[video] && abs(diff)>WRAP_THRESHOLD) ) ) {
xprintf (this->stream->xine, XINE_VERBOSITY_DEBUG,
- "diff=%" PRId64 " (pts=%" PRId64 ", last_pts=%" PRId64 ")\n", diff, pts, this->last_pts[video]);
+ "diff=%lld (pts=%lld, last_pts=%lld)\n", diff, pts, this->last_pts[video]);
if (this->buf_flag_seek) {
_x_demux_control_newpts(this->stream, pts, BUF_FLAG_SEEK);
@@ -576,7 +576,7 @@
} else
pts = 0;
- lprintf ("audiostream %d op-gpos %" PRId64 " hdr-gpos %" PRId64 " pts %" PRId64 " \n",
+ lprintf ("audiostream %d op-gpos %lld hdr-gpos %lld pts %lld \n",
stream_num,
op->granulepos,
this->si[stream_num]->header_granulepos,
@@ -611,7 +611,7 @@
} else
pts = 0;
- lprintf ("theorastream %d op-gpos %" PRId64 " hdr-gpos %" PRId64 " pts %" PRId64 " \n",
+ lprintf ("theorastream %d op-gpos %lld hdr-gpos %lld pts %lld \n",
stream_num,
op->granulepos,
this->si[stream_num]->header_granulepos,
@@ -643,7 +643,7 @@
} else
pts = 0;
- lprintf ("videostream %d op-gpos %" PRId64 " hdr-gpos %" PRId64 " pts %" PRId64 " \n",
+ lprintf ("videostream %d op-gpos %lld hdr-gpos %lld pts %lld \n",
stream_num,
op->granulepos,
this->si[stream_num]->header_granulepos,
@@ -819,8 +819,8 @@
this->si[stream_num]->headers = 0; /* header is sent below */
lprintf ("subtype %.4s\n", (char*)&locsubtype);
- lprintf ("time_unit %" PRId64 "\n", loctime_unit);
- lprintf ("samples_per_unit %" PRId64 "\n", locsamples_per_unit);
+ lprintf ("time_unit %lld\n", loctime_unit);
+ lprintf ("samples_per_unit %lld\n", locsamples_per_unit);
lprintf ("default_len %d\n", locdefault_len);
lprintf ("buffersize %d\n", locbuffersize);
lprintf ("bits_per_sample %d\n", locbits_per_sample);
@@ -906,8 +906,8 @@
}
lprintf ("subtype 0x%x\n", codec);
- lprintf ("time_unit %" PRId64 "\n", loctime_unit);
- lprintf ("samples_per_unit %" PRId64 "\n", locsamples_per_unit);
+ lprintf ("time_unit %lld\n", loctime_unit);
+ lprintf ("samples_per_unit %lld\n", locsamples_per_unit);
lprintf ("default_len %d\n", locdefault_len);
lprintf ("buffersize %d\n", locbuffersize);
lprintf ("bits_per_sample %d\n", locbits_per_sample);
@@ -1322,7 +1322,7 @@
iframe=op.granulepos>>keyframe_granule_shift;
pframe=op.granulepos-(iframe<<keyframe_granule_shift);
xprintf (this->stream->xine, XINE_VERBOSITY_DEBUG,
- "seeking keyframe i %" PRId64 " p %" PRId64 "\n", iframe, pframe);
+ "seeking keyframe i %lld p %lld\n", iframe, pframe);
if (pframe!=0)
continue;
} else
@@ -1426,7 +1426,7 @@
if (this->status == DEMUX_OK) {
_x_demux_control_start(this->stream);
send_header (this);
- lprintf ("headers sent, avg bitrate is %" PRId64 "\n", this->avg_bitrate);
+ lprintf ("headers sent, avg bitrate is %lld\n", this->avg_bitrate);
}
_x_stream_info_set(this->stream, XINE_STREAM_INFO_HAS_VIDEO,
@@ -1489,15 +1489,15 @@
);
}
- lprintf ("current_pos is %" PRId64 "\n",current_pos);
- lprintf ("new_pos is %" PRId64 "\n",start_pos);
+ lprintf ("current_pos is %lld\n",current_pos);
+ lprintf ("new_pos is %lld\n",start_pos);
} else {
/*seek using avg_bitrate*/
start_pos = start_time * this->avg_bitrate/8;
}
- lprintf ("seeking to %d seconds => %" PRId64 " bytes\n",
+ lprintf ("seeking to %d seconds => %lld bytes\n",
start_time, start_pos);
}
@@ -1513,7 +1513,7 @@
if (start_pos == 0)
this->keyframe_needed = 0;
- lprintf ("seek to %" PRId64 " called\n",start_pos);
+ lprintf ("seek to %lld called\n",start_pos);
this->input->seek (this->input, start_pos, SEEK_SET);

View File

@ -1,84 +0,0 @@
--- src/xine-engine/audio_out.c.orig Wed Mar 17 05:21:58 2004
+++ src/xine-engine/audio_out.c Wed Apr 7 23:09:00 2004
@@ -63,6 +63,9 @@
/* required for FNDELAY decl */
#define _BSD_SOURCE 1
+#define INT16_MAX 0x7fff
+#define INT16_MIN (-0x7fff-1)
+
#ifdef HAVE_CONFIG_H
#include "config.h"
#endif
@@ -452,7 +455,7 @@
num_frames = pts_len * this->frames_per_kpts / 1024;
xprintf (this->xine, XINE_VERBOSITY_DEBUG,
- "inserting %d 0-frames to fill a gap of %" PRId64 " pts\n", num_frames, pts_len);
+ "inserting %d 0-frames to fill a gap of %lld pts\n", num_frames, pts_len);
if ((this->output.mode == AO_CAP_MODE_A52) || (this->output.mode == AO_CAP_MODE_AC5)) {
write_pause_burst(this,num_frames);
@@ -831,7 +834,7 @@
this->resample_sync_factor = (avg_gap < 0) ? 0.995 : 1.005;
llprintf (LOG_RESAMPLE_SYNC,
- "sample rate adjusted to reduce gap: gap=%" PRId64 "\n", avg_gap);
+ "sample rate adjusted to reduce gap: gap=%lld\n", avg_gap);
return 0;
} else if (info->reduce_gap && abs(avg_gap) < 50) {
@@ -865,7 +868,7 @@
* this during calculation */
num_frames = (this->do_resample) ? (buf->num_frames * this->frame_rate_factor)
: buf->num_frames;
- printf("audio_out: gap=%5" PRId64 "; gap_diff=%5" PRId64 "; frame_diff=%3.0f; drift_factor=%f\n",
+ printf("audio_out: gap=%5lld; gap_diff=%5lld; frame_diff=%3.0f; drift_factor=%f\n",
avg_gap, gap_diff, num_frames * info->window * info->last_factor,
this->resample_sync_factor);
#endif
@@ -1020,7 +1023,7 @@
*/
hw_vpts = cur_time;
- lprintf ("current delay is %" PRId64 ", current time is %" PRId64 "\n", delay, cur_time);
+ lprintf ("current delay is %lld, current time is %lld\n", delay, cur_time);
/* External A52 decoder delay correction */
if ((this->output.mode==AO_CAP_MODE_A52) || (this->output.mode==AO_CAP_MODE_AC5))
@@ -1033,7 +1036,7 @@
* calculate gap:
*/
gap = in_buf->vpts - hw_vpts;
- lprintf ("hw_vpts : %" PRId64 " buffer_vpts : %" PRId64 " gap : %" PRId64 "\n",
+ lprintf ("hw_vpts : %lld buffer_vpts : %lld gap : %lld\n",
hw_vpts, in_buf->vpts, gap);
if (this->resample_sync_method) {
@@ -1057,7 +1060,7 @@
lprintf ("loop: drop package, next fifo\n");
fifo_append (this->free_fifo, in_buf);
- lprintf ("audio package (vpts = %" PRId64 ", gap = %" PRId64 ") dropped\n",
+ lprintf ("audio package (vpts = %lld, gap = %lld) dropped\n",
in_buf->vpts, gap);
in_buf = NULL;
@@ -1286,7 +1289,7 @@
this->frames_per_kpts = (this->output.rate * 1024) / 90000;
this->audio_step = ((int64_t)90000 * (int64_t)32768) / (int64_t)this->input.rate;
- lprintf ("audio_step %" PRId64 " pts per 32768 frames\n", this->audio_step);
+ lprintf ("audio_step %lld pts per 32768 frames\n", this->audio_step);
return this->output.rate;
}
@@ -1395,7 +1398,7 @@
buf->extra_info->vpts = buf->vpts;
- lprintf ("ao_put_buffer, pts=%" PRId64 ", vpts=%" PRId64 ", flushmode=%d\n",
+ lprintf ("ao_put_buffer, pts=%lld, vpts=%lld, flushmode=%d\n",
pts, buf->vpts, this->discard_buffers);
if (!this->discard_buffers)

View File

@ -1,172 +0,0 @@
--- src/xine-engine/metronom.c.orig Tue Apr 6 23:41:38 2004
+++ src/xine-engine/metronom.c Tue Apr 6 23:44:02 2004
@@ -204,7 +204,7 @@
static void metronom_start_clock (metronom_clock_t *this, int64_t pts) {
scr_plugin_t** scr;
- lprintf("start_clock (at %" PRId64 ")\n", pts);
+ lprintf("start_clock (at %lld)\n", pts);
for (scr = this->scr_list; scr < this->scr_list+MAX_SCR_PROVIDERS; scr++)
if (*scr) (*scr)->start(*scr, pts);
@@ -260,7 +260,7 @@
pthread_mutex_unlock (&this->lock);
- lprintf("%" PRId64 " pts per %d samples\n", pts_per_smpls, AUDIO_SAMPLE_NUM);
+ lprintf("%lld pts per %d samples\n", pts_per_smpls, AUDIO_SAMPLE_NUM);
}
static int64_t metronom_got_spu_packet (metronom_t *this, int64_t pts) {
@@ -314,7 +314,7 @@
this->force_video_jump = 1;
this->video_drift = 0;
xprintf(this->xine, XINE_VERBOSITY_DEBUG,
- "vpts adjusted with prebuffer to %" PRId64 "\n", this->video_vpts);
+ "vpts adjusted with prebuffer to %lld\n", this->video_vpts);
break;
case DISC_ABSOLUTE:
@@ -332,7 +332,7 @@
this->force_video_jump = 1;
this->force_audio_jump = 1;
this->video_drift = 0;
- xprintf(this->xine, XINE_VERBOSITY_DEBUG, "vpts adjusted with prebuffer to %" PRId64 "\n",
+ xprintf(this->xine, XINE_VERBOSITY_DEBUG, "vpts adjusted with prebuffer to %lld\n",
this->video_vpts);
}
} else {
@@ -348,7 +348,7 @@
break;
}
- lprintf("video_vpts: %" PRId64 ", audio_vpts: %" PRId64 "\n", this->video_vpts, this->audio_vpts);
+ lprintf("video_vpts: %lld, audio_vpts: %lld\n", this->video_vpts, this->audio_vpts);
/* vpts_offset adjustements */
switch (type) {
@@ -388,7 +388,7 @@
this->video_discontinuity_count++;
pthread_cond_signal (&this->video_discontinuity_reached);
- xprintf(this->xine, XINE_VERBOSITY_DEBUG, "video discontinuity #%d, type is %d, disc_off %" PRId64 "\n",
+ xprintf(this->xine, XINE_VERBOSITY_DEBUG, "video discontinuity #%d, type is %d, disc_off %lld\n",
this->video_discontinuity_count, type, disc_off);
if (this->have_audio) {
@@ -449,7 +449,7 @@
return;
}
- lprintf("got_video_frame pts = %" PRId64 ", duration = %d\n", pts, img->duration);
+ lprintf("got_video_frame pts = %lld, duration = %d\n", pts, img->duration);
this->img_cpt++;
@@ -462,7 +462,7 @@
if (!img->duration) {
if (this->last_video_pts && this->img_cpt) {
this->img_duration = (pts - this->last_video_pts) / this->img_cpt;
- lprintf("computed frame_duration = %" PRId64 "\n", this->img_duration );
+ lprintf("computed frame_duration = %lld\n", this->img_duration );
}
img->duration = this->img_duration;
} else {
@@ -483,7 +483,7 @@
diff = this->video_vpts - vpts;
- lprintf("video diff is %" PRId64 " (predicted %" PRId64 ", given %" PRId64 ")\n", diff, this->video_vpts, vpts);
+ lprintf("video diff is %lld (predicted %lld, given %lld)\n", diff, this->video_vpts, vpts);
if ((abs (diff) > VIDEO_DRIFT_TOLERANCE) || (this->force_video_jump)) {
this->force_video_jump = 0;
@@ -499,7 +499,7 @@
/* this will fix video drift with a constant compensation each
frame for about 1 second of video. */
- if (diff) lprintf("video drift, drift is %" PRId64 "\n", this->video_drift);
+ if (diff) lprintf("video drift, drift is %lld\n", this->video_drift);
}
} else {
if (!img->duration) {
@@ -512,7 +512,7 @@
img->vpts = this->video_vpts + this->av_offset;
- lprintf("video vpts for %10lld : %10lld (duration:%d drift:%" PRId64 " step:%" PRId64 ")\n",
+ lprintf("video vpts for %10lld : %10lld (duration:%d drift:%lld step:%lld)\n",
pts, this->video_vpts, img->duration, this->video_drift, this->video_drift_step );
if( this->video_drift * this->video_drift_step > 0 )
@@ -541,7 +541,7 @@
this->audio_discontinuity_count++;
pthread_cond_signal (&this->audio_discontinuity_reached);
- xprintf(this->xine, XINE_VERBOSITY_DEBUG, "audio discontinuity #%d, type is %d, disc_off %" PRId64 "\n",
+ xprintf(this->xine, XINE_VERBOSITY_DEBUG, "audio discontinuity #%d, type is %d, disc_off %lld\n",
this->audio_discontinuity_count, type, disc_off);
if (this->have_video) {
@@ -571,8 +571,8 @@
int64_t vpts;
int64_t diff;
- lprintf("got %d audio samples, pts is %" PRId64 ", last pts = %" PRId64 "\n", nsamples, pts, this->last_audio_pts);
- lprintf("AUDIO pts from last= %" PRId64 "\n", pts-this->last_audio_pts);
+ lprintf("got %d audio samples, pts is %lld, last pts = %lld\n", nsamples, pts, this->last_audio_pts);
+ lprintf("AUDIO pts from last= %lld\n", pts-this->last_audio_pts);
pthread_mutex_lock (&this->lock);
@@ -616,11 +616,11 @@
this->force_audio_jump = 0;
this->audio_vpts = vpts;
this->audio_drift_step = 0;
- xprintf(this->xine, XINE_VERBOSITY_DEBUG, "audio jump, diff=%" PRId64 "\n", diff);
+ xprintf(this->xine, XINE_VERBOSITY_DEBUG, "audio jump, diff=%lld\n", diff);
} else {
if( this->audio_samples ) {
/* calculate drift_step to recover vpts errors */
- lprintf("audio diff = %" PRId64 " \n", diff );
+ lprintf("audio diff = %lld \n", diff );
diff *= AUDIO_SAMPLE_NUM;
diff /= this->audio_samples * 4;
@@ -633,7 +633,7 @@
this->audio_drift_step = diff;
- lprintf("audio_drift = %" PRId64 ", pts_per_smpls = %" PRId64 "\n", diff, this->pts_per_smpls);
+ lprintf("audio_drift = %lld, pts_per_smpls = %lld\n", diff, this->pts_per_smpls);
}
}
this->audio_samples = 0;
@@ -671,11 +671,11 @@
switch (option) {
case METRONOM_AV_OFFSET:
this->av_offset = value;
- xprintf(this->xine, XINE_VERBOSITY_LOG, "av_offset=%" PRId64 " pts\n", this->av_offset);
+ xprintf(this->xine, XINE_VERBOSITY_LOG, "av_offset=%lld pts\n", this->av_offset);
break;
case METRONOM_SPU_OFFSET:
this->spu_offset = value;
- xprintf(this->xine, XINE_VERBOSITY_LOG, "spu_offset=%" PRId64 " pts\n", this->spu_offset);
+ xprintf(this->xine, XINE_VERBOSITY_LOG, "spu_offset=%lld pts\n", this->spu_offset);
break;
case METRONOM_ADJ_VPTS_OFFSET:
this->audio_vpts += value;
@@ -685,11 +685,11 @@
* once in a while means a small sound card drift (or system
* clock drift -- who knows?). nothing to worry about.
*/
- xprintf(this->xine, XINE_VERBOSITY_LOG, "fixing sound card drift by %" PRId64 " pts\n", value);
+ xprintf(this->xine, XINE_VERBOSITY_LOG, "fixing sound card drift by %lld pts\n", value);
break;
case METRONOM_PREBUFFER:
this->prebuffer = value;
- xprintf(this->xine, XINE_VERBOSITY_LOG, "prebuffer=%" PRId64 " pts\n", this->prebuffer);
+ xprintf(this->xine, XINE_VERBOSITY_LOG, "prebuffer=%lld pts\n", this->prebuffer);
break;
default:
xprintf(this->xine, XINE_VERBOSITY_NONE, "unknown option in set_option: %d\n", option);

View File

@ -1,88 +0,0 @@
--- src/xine-engine/video_out.c.orig Tue Apr 6 23:51:13 2004
+++ src/xine-engine/video_out.c Tue Apr 6 23:51:43 2004
@@ -367,7 +367,7 @@
cur_vpts = this->clock->get_current_time(this->clock);
this->last_delivery_pts = cur_vpts;
- lprintf ("got image oat master vpts %" PRId64 ". vpts for picture is %" PRId64 " (pts was %" PRId64 ")\n",
+ lprintf ("got image oat master vpts %lld. vpts for picture is %lld (pts was %lld)\n",
cur_vpts, pic_vpts, img->pts);
this->num_frames_delivered++;
@@ -408,7 +408,7 @@
}
- lprintf ("delivery diff : %" PRId64 ", current vpts is %" PRId64 ", %d frames to skip\n",
+ lprintf ("delivery diff : %lld, current vpts is %lld, %d frames to skip\n",
diff, cur_vpts, frames_to_skip);
if (!img->bad_frame) {
@@ -652,7 +652,7 @@
if( !this->discard_frames ) {
xine_log(this->xine, XINE_LOG_MSG,
- _("video_out: throwing away image with pts %" PRId64 " because it's too old (diff : %" PRId64 ").\n"), pts, diff);
+ _("video_out: throwing away image with pts %lld because it's too old (diff : %lld).\n"), pts, diff);
this->num_frames_discarded++;
}
@@ -728,7 +728,7 @@
if (this->img_backup && (this->redraw_needed==1)) {
- lprintf("generating still frame (cur_vpts = %" PRId64 ") \n", cur_vpts);
+ lprintf("generating still frame (cur_vpts = %lld) \n", cur_vpts);
/* keep playing still frames */
pthread_mutex_lock( &this->free_img_buf_queue->mutex );
@@ -761,7 +761,7 @@
* time to display frame "img" ?
*/
- lprintf ("diff %" PRId64 "\n", diff);
+ lprintf ("diff %lld\n", diff);
if (diff < 0) {
pthread_mutex_unlock(&this->display_img_buf_queue->mutex);
@@ -807,7 +807,7 @@
vo_frame_t *img, int64_t vpts) {
xine_stream_t *stream;
- lprintf ("displaying image with vpts = %" PRId64 "\n", img->vpts);
+ lprintf ("displaying image with vpts = %lld\n", img->vpts);
/* no, this is not were proc_*() is usually called.
* it's just to catch special cases like late or duplicated frames.
@@ -962,7 +962,7 @@
vpts = this->clock->get_current_time (this->clock);
- lprintf ("loop iteration at %" PRId64 "\n", vpts);
+ lprintf ("loop iteration at %lld\n", vpts);
expire_frames (this, vpts);
img = get_next_frame (this, vpts);
@@ -1026,7 +1026,7 @@
next_frame_vpts += 1000;
}
- lprintf ("next_frame_vpts is %" PRId64 "\n", next_frame_vpts);
+ lprintf ("next_frame_vpts is %lld\n", next_frame_vpts);
do {
vpts = this->clock->get_current_time (this->clock);
@@ -1036,11 +1036,11 @@
usec_to_sleep = (next_frame_vpts - vpts) * 100 / 9;
- lprintf ("%" PRId64 " usec to sleep at master vpts %" PRId64 "\n", usec_to_sleep, vpts);
+ lprintf ("%lld usec to sleep at master vpts %lld\n", usec_to_sleep, vpts);
if ( (next_frame_vpts - vpts) > 2*90000 )
xprintf(this->xine, XINE_VERBOSITY_DEBUG,
- "video_out: vpts/clock error, next_vpts=%" PRId64 " cur_vpts=%" PRId64 "\n", next_frame_vpts,vpts);
+ "video_out: vpts/clock error, next_vpts=%lld cur_vpts=%lld\n", next_frame_vpts,vpts);
if (usec_to_sleep>0)
xine_usec_sleep (usec_to_sleep);

View File

@ -0,0 +1,94 @@
--- src/libfaad/structs.h.old Thu Apr 22 23:49:49 2004
+++ src/libfaad/structs.h Thu Apr 22 23:53:16 2004
@@ -307,58 +307,58 @@
typedef struct mp4AudioSpecificConfig
{
/* Audio Specific Info */
- uint8_t objectTypeIndex;
- uint8_t samplingFrequencyIndex;
- uint32_t samplingFrequency;
- uint8_t channelsConfiguration;
+ unsigned char objectTypeIndex;
+ unsigned char samplingFrequencyIndex;
+ unsigned long samplingFrequency;
+ unsigned char channelsConfiguration;
/* GA Specific Info */
- uint8_t frameLengthFlag;
- uint8_t dependsOnCoreCoder;
- uint16_t coreCoderDelay;
- uint8_t extensionFlag;
- uint8_t aacSectionDataResilienceFlag;
- uint8_t aacScalefactorDataResilienceFlag;
- uint8_t aacSpectralDataResilienceFlag;
- uint8_t epConfig;
+ unsigned char frameLengthFlag;
+ unsigned char dependsOnCoreCoder;
+ unsigned short coreCoderDelay;
+ unsigned char extensionFlag;
+ unsigned char aacSectionDataResilienceFlag;
+ unsigned char aacScalefactorDataResilienceFlag;
+ unsigned char aacSpectralDataResilienceFlag;
+ unsigned char epConfig;
- int8_t sbr_present_flag;
- int8_t forceUpSampling;
+ char sbr_present_flag;
+ char forceUpSampling;
} mp4AudioSpecificConfig;
typedef struct faacDecConfiguration
{
- uint8_t defObjectType;
- uint32_t defSampleRate;
- uint8_t outputFormat;
- uint8_t downMatrix;
- uint8_t useOldADTSFormat;
- uint8_t dontUpSampleImplicitSBR;
+ unsigned char defObjectType;
+ unsigned long defSampleRate;
+ unsigned char outputFormat;
+ unsigned char downMatrix;
+ unsigned char useOldADTSFormat;
+ unsigned char dontUpSampleImplicitSBR;
} faacDecConfiguration, *faacDecConfigurationPtr;
typedef struct faacDecFrameInfo
{
- uint32_t bytesconsumed;
- uint32_t samples;
- uint8_t channels;
- uint8_t error;
- uint32_t samplerate;
+ unsigned long bytesconsumed;
+ unsigned long samples;
+ unsigned char channels;
+ unsigned char error;
+ unsigned long samplerate;
/* SBR: 0: off, 1: on; normal, 2: on; downsampled */
- uint8_t sbr;
+ unsigned char sbr;
/* MPEG-4 ObjectType */
- uint8_t object_type;
+ unsigned char object_type;
/* AAC header type; MP4 will be signalled as RAW also */
- uint8_t header_type;
+ unsigned char header_type;
/* multichannel configuration */
- uint8_t num_front_channels;
- uint8_t num_side_channels;
- uint8_t num_back_channels;
- uint8_t num_lfe_channels;
- uint8_t channel_position[MAX_CHANNELS];
+ unsigned char num_front_channels;
+ unsigned char num_side_channels;
+ unsigned char num_back_channels;
+ unsigned char num_lfe_channels;
+ unsigned char channel_position[MAX_CHANNELS];
} faacDecFrameInfo;
typedef struct

View File

@ -1,52 +0,0 @@
--- src/libw32dll/wine/ldt_keeper.c.orig Sat Oct 11 12:22:18 2003
+++ src/libw32dll/wine/ldt_keeper.c Tue Dec 2 19:49:23 2003
@@ -138,7 +138,7 @@
#define TEB_SEL_IDX 1024
#endif
-#define TEB_SEL LDT_SEL(TEB_SEL_IDX)
+static unsigned int teb_sel = LDT_SEL(TEB_SEL_IDX);
#ifdef __cplusplus
extern "C"
@@ -146,7 +146,7 @@
void Setup_FS_Segment(void)
{
__asm__ __volatile__(
- "movl %0,%%eax; movw %%ax, %%fs" : : "i" (TEB_SEL) : "%eax"
+ "movl %0,%%eax; movw %%ax, %%fs" : : "r" (teb_sel) : "%eax"
);
}
@@ -158,7 +158,7 @@
);
fs = fs & 0xffff;
- if( fs != TEB_SEL ) {
+ if( fs != teb_sel ) {
printf("ldt_keeper: FS segment is not set or has being lost!\n");
printf(" Please report this error to xine-devel@sourceforge.net\n");
printf(" Aborting....\n");
@@ -230,7 +230,13 @@
unsigned long d[2];
LDT_EntryToBytes( d, &array );
+#if defined(__FreeBSD__) && defined(LDT_AUTO_ALLOC)
+ ret = i386_set_ldt(LDT_AUTO_ALLOC, (union descriptor *)d, 1);
+ array.entry_number = ret;
+ teb_sel = LDT_SEL(ret);
+#else
ret = i386_set_ldt(array.entry_number, (union descriptor *)d, 1);
+#endif
if (ret < 0)
{
perror("install_fs");
@@ -244,7 +250,7 @@
#if defined(__svr4__)
{
struct ssd ssd;
- ssd.sel = TEB_SEL;
+ ssd.sel = teb_sel;
ssd.bo = array.base_addr;
ssd.ls = array.limit - array.base_addr;
ssd.acc1 = ((array.read_exec_only == 0) << 1) |

View File

@ -0,0 +1,11 @@
--- src/post/goom/zoom_filter_xmmx.c.orig Sun May 9 22:41:34 2004
+++ src/post/goom/zoom_filter_xmmx.c Sun May 9 22:51:42 2004
@@ -124,7 +124,7 @@
"andl $15,%%eax\n"
"movd (%%ebx,%%eax,4),%%mm3\n"
- ::"X"(precalCoef):"eax","ebx");
+ ::"g"(precalCoef):"eax","ebx");
/*
* extraction des coefficients...

View File

@ -1,11 +0,0 @@
--- src/video_out/Makefile.in.orig Tue Apr 6 21:57:52 2004
+++ src/video_out/Makefile.in Tue Apr 6 21:58:35 2004
@@ -280,8 +280,6 @@
#opengl_module = xineplug_vo_out_opengl.la
#endif
@HAVE_SYNCFB_TRUE@@HAVE_X11_TRUE@syncfb_module = xineplug_vo_out_syncfb.la
-@HAVE_SUNFB_TRUE@@HAVE_X11_TRUE@pgx64_module = xineplug_vo_out_pgx64.la
-@HAVE_SUNFB_TRUE@@HAVE_X11_TRUE@pgx32_module = xineplug_vo_out_pgx32.la
@HAVE_VIDIX_TRUE@vidix_module = xineplug_vo_out_vidix.la

View File

@ -1,6 +1,6 @@
--- src/video_out/video_out_xv.c.orig Sun Dec 14 23:13:26 2003
+++ src/video_out/video_out_xv.c Thu Feb 5 14:27:10 2004
@@ -47,13 +47,17 @@
--- src/video_out/video_out_xv.c.orig Wed Apr 28 01:56:34 2004
+++ src/video_out/video_out_xv.c Sun May 9 21:51:48 2004
@@ -47,7 +47,11 @@
#if defined (__SVR4) && defined (__sun)
# include <sys/int_types.h>
#else
@ -12,11 +12,4 @@
+# endif
#endif
+#include <sys/types.h>
#if defined(__FreeBSD__)
#include <machine/param.h>
#endif
-#include <sys/types.h>
#include <sys/ipc.h>
#include <sys/shm.h>
#include <sys/time.h>
#include <sys/types.h>

View File

@ -37,17 +37,17 @@ lib/xine/plugins/1.0.0/post/xineplug_post_planar.so
lib/xine/plugins/1.0.0/post/xineplug_post_switch.so
lib/xine/plugins/1.0.0/post/xineplug_post_tvtime.so
lib/xine/plugins/1.0.0/post/xineplug_post_visualizations.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/cyberblade_vid.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/mach64_vid.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/mga_crtc2_vid.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/mga_vid.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/pm2_vid.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/pm3_vid.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/radeon_vid.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/rage128_vid.so
%%VIDIX%%lib/xine/plugins/1.0.0/vidix/sis_vid.so
%%HAVE_ARTS%%lib/xine/plugins/1.0.0/xineplug_ao_out_arts.so
%%HAVE_ESOUND%%lib/xine/plugins/1.0.0/xineplug_ao_out_esd.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/cyberblade_vid.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/mach64_vid.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/mga_crtc2_vid.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/mga_vid.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/pm2_vid.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/pm3_vid.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/radeon_vid.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/rage128_vid.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/vidix/sis_vid.so
%%WITH_ARTS%%lib/xine/plugins/1.0.0/xineplug_ao_out_arts.so
%%WITH_ESOUND%%lib/xine/plugins/1.0.0/xineplug_ao_out_esd.so
lib/xine/plugins/1.0.0/xineplug_ao_out_file.so
lib/xine/plugins/1.0.0/xineplug_ao_out_none.so
lib/xine/plugins/1.0.0/xineplug_ao_out_oss.so
@ -71,6 +71,8 @@ lib/xine/plugins/1.0.0/xineplug_decode_speex.so
lib/xine/plugins/1.0.0/xineplug_decode_spu.so
lib/xine/plugins/1.0.0/xineplug_decode_spucc.so
lib/xine/plugins/1.0.0/xineplug_decode_sputext.so
%%WITH_LIBTHEORA%%lib/xine/plugins/1.0.0/xineplug_decode_theora.so
%%WITH_LIBCACA%%lib/xine/plugins/1.0.0/xineplug_vo_out_caca.so
lib/xine/plugins/1.0.0/xineplug_decode_vorbis.so
lib/xine/plugins/1.0.0/xineplug_decode_w32dll.so
lib/xine/plugins/1.0.0/xineplug_decode_yuv.so
@ -104,7 +106,7 @@ lib/xine/plugins/1.0.0/xineplug_inp_cdda.so
lib/xine/plugins/1.0.0/xineplug_inp_dvb.so
lib/xine/plugins/1.0.0/xineplug_inp_dvd.so
lib/xine/plugins/1.0.0/xineplug_inp_file.so
%%HAVE_GNOMEVFS2%%lib/xine/plugins/1.0.0/xineplug_inp_gnome_vfs.so
%%WITH_GNOMEVFS2%%lib/xine/plugins/1.0.0/xineplug_inp_gnome_vfs.so
lib/xine/plugins/1.0.0/xineplug_inp_http.so
lib/xine/plugins/1.0.0/xineplug_inp_mms.so
lib/xine/plugins/1.0.0/xineplug_inp_net.so
@ -117,10 +119,10 @@ lib/xine/plugins/1.0.0/xineplug_inp_vcdo.so
lib/xine/plugins/1.0.0/xineplug_vo_out_aa.so
lib/xine/plugins/1.0.0/xineplug_vo_out_none.so
lib/xine/plugins/1.0.0/xineplug_vo_out_sdl.so
%%VIDIX%%lib/xine/plugins/1.0.0/xineplug_vo_out_vidix.so
%%WITH_VIDIX%%lib/xine/plugins/1.0.0/xineplug_vo_out_vidix.so
lib/xine/plugins/1.0.0/xineplug_vo_out_xshm.so
%%HAVE_LIBXV%%lib/xine/plugins/1.0.0/xineplug_vo_out_xv.so
%%XVMC%%lib/xine/plugins/1.0.0/xineplug_vo_out_xvmc.so
%%WITH_LIBXV%%lib/xine/plugins/1.0.0/xineplug_vo_out_xv.so
%%WITH_XVMC%%lib/xine/plugins/1.0.0/xineplug_vo_out_xvmc.so
libdata/pkgconfig/libxine.pc
share/aclocal/xine.m4
%%DOCSDIR%%/README