multimedia/gstreamer1-plugins-rust: update to 0.8.4

Changes:	https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs/-/compare/0.7.2...0.8.4
This commit is contained in:
Jan Beich 2022-04-26 11:20:02 +00:00
parent da00b9a366
commit 7f9937ae40
6 changed files with 866 additions and 709 deletions

View File

@ -1,8 +1,10 @@
PORTNAME= gstreamer1-plugins-rust
DISTVERSION= 0.7.2
PORTREVISION= 12
DISTVERSION= 0.8.4
CATEGORIES= multimedia
PATCH_SITES= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/commit/
PATCHFILES+= 6da4192fe62c.patch:-p1 # https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs/-/merge_requests/910
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Various GStreamer plugins written in Rust
WWW= https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs
@ -20,264 +22,264 @@ USE_GNOME= glib20
GL_SITE= https://gitlab.freedesktop.org
GL_ACCOUNT= gstreamer
GL_PROJECT= gst-plugins-rs
GL_COMMIT= d0466b3eee114207f851b37cae0015c0e718f021
GL_COMMIT= 18c9bd0355e0fc1ab20072d805807112945ad5bb
MAKE_ENV= ${CARGO_ENV}
CARGO_CRATES= adler-1.0.2 \
adler32-1.2.0 \
aes-0.6.0 \
aes-ctr-0.6.0 \
aes-soft-0.6.4 \
aesni-0.10.0 \
aho-corasick-0.7.18 \
ansi_term-0.11.0 \
ansi_term-0.12.1 \
anyhow-1.0.43 \
anyhow-1.0.57 \
arbitrary-0.4.7 \
arg_enum_proc_macro-0.3.1 \
arg_enum_proc_macro-0.3.2 \
array-init-2.0.0 \
arrayvec-0.5.2 \
async-compression-0.3.8 \
async-trait-0.1.51 \
async-tungstenite-0.14.0 \
atk-0.14.0 \
atk-sys-0.14.0 \
atomic_refcell-0.1.7 \
arrayvec-0.7.2 \
async-compression-0.3.12 \
async-task-4.2.0 \
async-trait-0.1.53 \
async-tungstenite-0.17.2 \
atomic_refcell-0.1.8 \
atty-0.2.14 \
autocfg-1.0.1 \
base-x-0.2.8 \
autocfg-1.1.0 \
backoff-0.4.0 \
base-x-0.2.10 \
base32-0.4.0 \
base64-0.13.0 \
bincode-1.3.3 \
bindgen-0.58.1 \
bindgen-0.59.2 \
bitflags-1.3.2 \
bitstream-io-1.2.0 \
bitvec-0.19.5 \
bitstream-io-1.3.0 \
block-buffer-0.9.0 \
bumpalo-3.7.0 \
byte-slice-cast-1.0.0 \
bytemuck-1.7.2 \
block-buffer-0.10.2 \
build_const-0.2.2 \
bumpalo-3.9.1 \
byte-slice-cast-1.2.1 \
bytemuck-1.9.1 \
byteorder-1.4.3 \
bytes-0.5.6 \
bytes-1.1.0 \
cairo-rs-0.14.3 \
cairo-sys-rs-0.14.0 \
cc-1.0.69 \
cache-padded-1.2.0 \
cc-1.0.73 \
cdg-0.1.0 \
cdg_renderer-0.6.0 \
cexpr-0.4.0 \
cdg_renderer-0.7.0 \
cexpr-0.6.0 \
cfg-expr-0.7.4 \
cfg-expr-0.10.2 \
cfg-if-0.1.10 \
cfg-if-1.0.0 \
chrono-0.4.19 \
clang-sys-1.2.1 \
clap-2.33.3 \
cipher-0.2.5 \
clang-sys-1.3.1 \
clap-2.34.0 \
clap-3.1.12 \
clap_derive-3.1.7 \
clap_lex-0.1.1 \
claxon-0.4.3 \
color_quant-1.1.0 \
const_fn-0.4.8 \
cookie-0.14.4 \
cookie_store-0.12.0 \
core-foundation-0.9.1 \
core-foundation-sys-0.8.2 \
cpufeatures-0.2.1 \
crc-2.0.0 \
crc-catalog-1.1.1 \
crc32fast-1.2.1 \
crossbeam-channel-0.5.1 \
concurrent-queue-1.2.2 \
const_fn-0.4.9 \
cookie-0.15.1 \
cookie_store-0.15.1 \
core-foundation-0.9.3 \
core-foundation-sys-0.8.3 \
cpufeatures-0.2.2 \
crc-1.8.1 \
crc-3.0.0 \
crc-catalog-2.1.0 \
crc32fast-1.3.2 \
crossbeam-channel-0.5.4 \
crossbeam-deque-0.8.1 \
crossbeam-epoch-0.9.5 \
crossbeam-utils-0.8.5 \
crossbeam-epoch-0.9.8 \
crossbeam-utils-0.8.8 \
crypto-common-0.1.3 \
crypto-mac-0.11.1 \
csound-0.1.8 \
csound-sys-0.1.2 \
ctor-0.1.20 \
ctor-0.1.22 \
ctr-0.6.0 \
dasp_frame-0.11.0 \
dasp_sample-0.11.0 \
dav1d-0.6.0 \
dav1d-sys-0.3.4 \
deflate-0.9.1 \
dav1d-0.8.0 \
dav1d-sys-0.5.0 \
deflate-1.0.0 \
diff-0.1.12 \
digest-0.9.0 \
digest-0.10.3 \
dirs-next-2.0.0 \
dirs-sys-next-0.1.2 \
discard-1.0.4 \
ebur128-0.1.6 \
ed25519-1.2.0 \
ed25519-1.4.1 \
either-1.6.1 \
encoding_rs-0.8.28 \
encoding_rs-0.8.31 \
env_logger-0.8.4 \
env_logger-0.9.0 \
fastrand-1.7.0 \
field-offset-0.3.4 \
flate2-1.0.20 \
flate2-1.0.23 \
fnv-1.0.7 \
foreign-types-0.3.2 \
foreign-types-shared-0.1.1 \
form_urlencoded-1.0.1 \
fragile-1.2.0 \
fst-0.4.7 \
fuchsia-zircon-0.3.3 \
fuchsia-zircon-sys-0.3.3 \
funty-1.1.0 \
futures-0.3.16 \
futures-channel-0.3.16 \
futures-core-0.3.16 \
futures-executor-0.3.16 \
futures-io-0.3.16 \
futures-macro-0.3.16 \
futures-sink-0.3.16 \
futures-task-0.3.16 \
futures-util-0.3.16 \
gdk-0.14.0 \
gdk-pixbuf-0.14.0 \
gdk-pixbuf-sys-0.14.0 \
gdk-sys-0.14.0 \
generic-array-0.14.4 \
getrandom-0.2.3 \
gif-0.11.2 \
gio-0.14.3 \
gio-sys-0.14.0 \
glib-0.14.4 \
glib-macros-0.14.1 \
glib-sys-0.14.0 \
futures-0.3.21 \
futures-channel-0.3.21 \
futures-core-0.3.21 \
futures-executor-0.3.21 \
futures-io-0.3.21 \
futures-macro-0.3.21 \
futures-sink-0.3.21 \
futures-task-0.3.21 \
futures-util-0.3.21 \
generic-array-0.14.5 \
getopts-0.2.21 \
getrandom-0.2.6 \
gif-0.11.3 \
glob-0.3.0 \
gobject-sys-0.14.0 \
gstreamer-0.17.3 \
gstreamer-app-0.17.2 \
gstreamer-app-sys-0.17.0 \
gstreamer-audio-0.17.2 \
gstreamer-audio-sys-0.17.0 \
gstreamer-base-0.17.2 \
gstreamer-base-sys-0.17.0 \
gstreamer-check-0.17.0 \
gstreamer-check-sys-0.17.0 \
gstreamer-net-0.17.0 \
gstreamer-net-sys-0.17.0 \
gstreamer-rtp-0.17.0 \
gstreamer-rtp-sys-0.17.0 \
gstreamer-sys-0.17.3 \
gstreamer-video-0.17.2 \
gstreamer-video-sys-0.17.0 \
gtk-0.14.1 \
gtk-sys-0.14.0 \
gtk3-macros-0.14.0 \
h2-0.3.4 \
h2-0.3.13 \
hashbrown-0.11.2 \
headers-0.3.4 \
headers-0.3.7 \
headers-core-0.2.0 \
heck-0.3.3 \
heck-0.4.0 \
hermit-abi-0.1.19 \
hex-0.4.3 \
hmac-0.11.0 \
http-0.2.4 \
http-body-0.4.3 \
httparse-1.5.1 \
httpdate-1.0.1 \
hostname-0.3.1 \
hrtf-0.8.0 \
http-0.2.6 \
http-body-0.4.4 \
httparse-1.7.0 \
httpdate-1.0.2 \
humantime-2.1.0 \
hyper-0.14.12 \
hyper-0.14.18 \
hyper-proxy-0.9.1 \
hyper-tls-0.5.0 \
hyphenation-0.8.4 \
hyphenation_commons-0.8.4 \
idna-0.2.3 \
image-0.23.14 \
indexmap-1.7.0 \
input_buffer-0.4.0 \
instant-0.1.10 \
if-addrs-0.6.7 \
if-addrs-sys-0.3.2 \
image-0.24.1 \
indexmap-1.8.1 \
instant-0.1.12 \
interpolate_name-0.2.3 \
iovec-0.1.4 \
ipnet-2.3.1 \
itertools-0.10.1 \
itoa-0.4.8 \
js-sys-0.3.53 \
kernel32-sys-0.2.2 \
ipnet-2.5.0 \
itertools-0.10.3 \
itoa-1.0.1 \
jobserver-0.1.24 \
js-sys-0.3.57 \
lazy_static-1.4.0 \
lazycell-1.3.0 \
lewton-0.10.2 \
lexical-core-0.7.6 \
libc-0.2.101 \
libc-0.2.124 \
libfuzzer-sys-0.3.5 \
libloading-0.7.0 \
libloading-0.7.3 \
libm-0.2.2 \
libmdns-0.6.2 \
librespot-0.3.1 \
librespot-audio-0.3.1 \
librespot-connect-0.3.1 \
librespot-core-0.3.1 \
librespot-discovery-0.3.1 \
librespot-metadata-0.3.1 \
librespot-playback-0.3.1 \
librespot-protocol-0.3.1 \
libsodium-sys-0.2.7 \
libwebp-sys2-0.1.2 \
lock_api-0.4.5 \
log-0.4.14 \
lock_api-0.4.7 \
log-0.4.16 \
m3u8-rs-4.0.0 \
match_cfg-0.1.0 \
matches-0.1.9 \
md-5-0.9.1 \
memchr-2.4.1 \
memoffset-0.6.4 \
memoffset-0.6.5 \
mime-0.3.16 \
minimal-lexical-0.1.2 \
miniz_oxide-0.4.4 \
mio-0.6.23 \
mio-0.7.13 \
miow-0.2.2 \
minimal-lexical-0.2.1 \
miniz_oxide-0.5.1 \
mio-0.8.2 \
miow-0.3.7 \
more-asserts-0.2.2 \
muldiv-1.0.0 \
native-tls-0.2.8 \
net2-0.2.37 \
nnnoiseless-0.3.2 \
nom-5.1.2 \
nom-6.1.2 \
nom-7.0.0 \
multimap-0.8.3 \
nasm-rs-0.2.4 \
native-tls-0.2.10 \
nnnoiseless-0.4.0 \
nom-7.1.1 \
noop_proc_macro-0.3.0 \
ntapi-0.3.6 \
num-0.4.0 \
num-bigint-0.4.1 \
num-complex-0.3.1 \
ntapi-0.3.7 \
num-bigint-0.4.3 \
num-complex-0.4.0 \
num-derive-0.3.3 \
num-integer-0.1.44 \
num-iter-0.1.42 \
num-rational-0.3.2 \
num-rational-0.4.0 \
num-traits-0.2.14 \
num_cpus-1.13.0 \
once_cell-1.8.0 \
num_cpus-1.13.1 \
ogg-0.8.0 \
once_cell-1.10.0 \
opaque-debug-0.3.0 \
openssl-0.10.36 \
openssl-probe-0.1.4 \
openssl-sys-0.9.66 \
output_vt100-0.1.2 \
pango-0.14.3 \
pango-sys-0.14.0 \
pangocairo-0.14.0 \
pangocairo-sys-0.14.0 \
parking_lot-0.11.2 \
parking_lot_core-0.8.5 \
paste-1.0.5 \
openssl-0.10.38 \
openssl-probe-0.1.5 \
openssl-sys-0.9.72 \
option-operations-0.4.0 \
os_str_bytes-6.0.0 \
output_vt100-0.1.3 \
parking_lot-0.12.0 \
parking_lot_core-0.9.2 \
paste-1.0.7 \
pbkdf2-0.8.0 \
peeking_take_while-0.1.2 \
percent-encoding-2.1.0 \
pest-2.1.3 \
pin-project-1.0.8 \
pin-project-internal-1.0.8 \
pin-project-lite-0.1.12 \
pin-project-lite-0.2.7 \
pin-project-lite-0.2.8 \
pin-utils-0.1.0 \
pkg-config-0.3.19 \
png-0.17.1 \
pkg-config-0.3.25 \
png-0.17.5 \
pocket-resources-0.3.2 \
ppv-lite86-0.2.10 \
pretty-hex-0.2.1 \
pretty_assertions-0.7.2 \
polling-2.2.0 \
ppv-lite86-0.2.16 \
pretty-hex-0.3.0 \
pretty_assertions-1.2.1 \
primal-check-0.3.1 \
proc-macro-crate-1.0.0 \
priority-queue-1.2.1 \
proc-macro-crate-1.1.3 \
proc-macro-error-1.0.4 \
proc-macro-error-attr-1.0.4 \
proc-macro-hack-0.5.19 \
proc-macro-nested-0.1.7 \
proc-macro2-1.0.28 \
publicsuffix-1.5.6 \
quote-1.0.9 \
radium-0.5.3 \
rand-0.8.4 \
proc-macro2-1.0.37 \
protobuf-2.27.1 \
protobuf-codegen-2.27.1 \
protobuf-codegen-pure-2.27.1 \
psl-types-2.0.10 \
publicsuffix-2.1.1 \
quick-xml-0.22.0 \
quote-1.0.18 \
rand-0.8.5 \
rand_chacha-0.3.1 \
rand_core-0.6.3 \
rand_hc-0.3.1 \
rav1e-0.4.1 \
rayon-1.5.1 \
rayon-core-1.9.1 \
redox_syscall-0.2.10 \
redox_users-0.4.0 \
regex-1.5.4 \
rand_distr-0.4.3 \
rav1e-0.5.1 \
rayon-1.5.2 \
rayon-core-1.9.2 \
realfft-2.0.1 \
redox_syscall-0.2.13 \
redox_users-0.4.3 \
regex-1.5.5 \
regex-syntax-0.6.25 \
remove_dir_all-0.5.3 \
reqwest-0.11.4 \
rusoto_core-0.47.0 \
rusoto_credential-0.47.0 \
rusoto_s3-0.47.0 \
rusoto_signature-0.47.0 \
reqwest-0.11.10 \
rpassword-5.0.1 \
rubato-0.10.1 \
rusoto_core-0.48.0 \
rusoto_credential-0.48.0 \
rusoto_s3-0.48.0 \
rusoto_signature-0.48.0 \
rust_hawktracer-0.7.0 \
rust_hawktracer_normal_macro-0.4.1 \
rust_hawktracer_proc_macro-0.4.1 \
@ -285,121 +287,144 @@ CARGO_CRATES= adler-1.0.2 \
rustc_version-0.2.3 \
rustc_version-0.3.3 \
rustc_version-0.4.0 \
rustfft-5.1.1 \
ryu-1.0.5 \
rustfft-6.0.1 \
ryu-1.0.9 \
same-file-1.0.6 \
schannel-0.1.19 \
scopeguard-1.1.0 \
security-framework-2.4.1 \
security-framework-sys-2.4.1 \
security-framework-2.6.1 \
security-framework-sys-2.6.1 \
semver-0.9.0 \
semver-0.11.0 \
semver-1.0.4 \
semver-1.0.7 \
semver-parser-0.7.0 \
semver-parser-0.10.2 \
serde-1.0.130 \
serde-1.0.136 \
serde_bytes-0.11.5 \
serde_derive-1.0.130 \
serde_json-1.0.67 \
serde_urlencoded-0.7.0 \
serde_derive-1.0.136 \
serde_json-1.0.79 \
serde_urlencoded-0.7.1 \
sha-1-0.9.8 \
sha1-0.6.0 \
sha2-0.9.6 \
sha-1-0.10.0 \
sha1-0.6.1 \
sha1_smol-1.0.0 \
sha2-0.9.9 \
shannon-0.2.0 \
shell-words-1.1.0 \
shlex-1.1.0 \
signal-hook-registry-1.4.0 \
signature-1.3.1 \
signature-1.5.0 \
simd_helpers-0.1.0 \
slab-0.4.4 \
smallvec-1.6.1 \
slab-0.4.6 \
smallvec-1.8.0 \
smawk-0.3.1 \
socket2-0.4.1 \
socket2-0.4.4 \
sodiumoxide-0.2.7 \
standback-0.2.17 \
static_assertions-1.1.0 \
stdweb-0.4.20 \
stdweb-derive-0.5.3 \
stdweb-internal-macros-0.2.9 \
stdweb-internal-runtime-0.1.5 \
strength_reduce-0.2.3 \
strsim-0.8.0 \
strsim-0.10.0 \
structopt-0.3.26 \
structopt-derive-0.4.18 \
strum-0.21.0 \
strum_macros-0.21.1 \
subtle-2.4.1 \
syn-1.0.75 \
syn-1.0.91 \
synstructure-0.12.6 \
system-deps-3.1.2 \
tap-1.0.1 \
tempfile-3.2.0 \
termcolor-1.1.2 \
system-deps-6.0.2 \
tempfile-3.3.0 \
termcolor-1.1.3 \
textwrap-0.11.0 \
textwrap-0.14.2 \
thiserror-1.0.28 \
thiserror-impl-1.0.28 \
textwrap-0.15.0 \
thiserror-1.0.30 \
thiserror-impl-1.0.30 \
time-0.1.43 \
time-0.2.27 \
time-macros-0.1.1 \
time-macros-impl-0.1.2 \
tinyvec-1.3.1 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.0 \
tokio-1.10.1 \
tokio-macros-1.3.0 \
tokio-1.17.0 \
tokio-macros-1.7.0 \
tokio-native-tls-0.3.0 \
tokio-util-0.6.7 \
toml-0.5.8 \
tokio-stream-0.1.8 \
tokio-util-0.6.9 \
tokio-util-0.7.1 \
toml-0.5.9 \
tower-service-0.3.1 \
tracing-0.1.26 \
tracing-core-0.1.19 \
tracing-0.1.34 \
tracing-attributes-0.1.20 \
tracing-core-0.1.26 \
transpose-0.2.1 \
try-lock-0.2.3 \
tungstenite-0.13.0 \
typenum-1.13.0 \
tungstenite-0.17.2 \
typenum-1.15.0 \
ucd-trie-0.1.3 \
unicode-bidi-0.3.6 \
unicode-bidi-0.3.7 \
unicode-linebreak-0.1.2 \
unicode-normalization-0.1.19 \
unicode-segmentation-1.8.0 \
unicode-width-0.1.8 \
unicode-segmentation-1.9.0 \
unicode-width-0.1.9 \
unicode-xid-0.2.2 \
url-2.2.2 \
utf-8-0.7.6 \
uuid-0.8.2 \
v_frame-0.2.2 \
va_list-0.1.3 \
uuid-1.0.0 \
v_frame-0.2.5 \
va_list-0.1.4 \
vcpkg-0.2.15 \
vec_map-0.8.2 \
vergen-3.2.0 \
version-compare-0.0.11 \
version_check-0.9.3 \
version-compare-0.1.0 \
version_check-0.9.4 \
waker-fn-1.1.0 \
walkdir-2.3.2 \
want-0.3.0 \
wasi-0.10.2+wasi-snapshot-preview1 \
wasm-bindgen-0.2.76 \
wasm-bindgen-backend-0.2.76 \
wasm-bindgen-futures-0.4.26 \
wasm-bindgen-macro-0.2.76 \
wasm-bindgen-macro-support-0.2.76 \
wasm-bindgen-shared-0.2.76 \
web-sys-0.3.53 \
weezl-0.1.5 \
which-3.1.1 \
winapi-0.2.8 \
wasi-0.11.0+wasi-snapshot-preview1 \
wasm-bindgen-0.2.80 \
wasm-bindgen-backend-0.2.80 \
wasm-bindgen-futures-0.4.30 \
wasm-bindgen-macro-0.2.80 \
wasm-bindgen-macro-support-0.2.80 \
wasm-bindgen-shared-0.2.80 \
web-sys-0.3.57 \
weezl-0.1.6 \
wepoll-ffi-0.1.2 \
which-4.2.5 \
winapi-0.3.9 \
winapi-build-0.1.1 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-util-0.1.5 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
winreg-0.7.0 \
ws2_32-sys-0.2.1 \
wyz-0.2.0 \
windows-sys-0.34.0 \
windows_aarch64_msvc-0.34.0 \
windows_i686_gnu-0.34.0 \
windows_i686_msvc-0.34.0 \
windows_x86_64_gnu-0.34.0 \
windows_x86_64_msvc-0.34.0 \
winreg-0.10.1 \
xml-rs-0.8.4 \
zeroize-1.4.1 \
tokio,tokio-macros@git+https://github.com/fengalin/tokio\#2fd1551867c145cabe4548da2e37adc3bdf457a4 \
flavors@git+https://github.com/rust-av/flavors\#ceb65b8ce94e183c4cf4011da0a40e3a4892c2c0
zerocopy-0.3.0 \
zerocopy-derive-0.2.0 \
zeroize-1.5.4 \
cairo-rs,cairo-sys-rs,gdk-pixbuf,gdk-pixbuf-sys,gio,gio-sys,glib,glib-macros,glib-sys,gobject-sys,graphene-rs,graphene-sys,pango,pango-sys,pangocairo,pangocairo-sys@git+https://github.com/gtk-rs/gtk-rs-core?branch=0.15\#59eea5774c06bfd323e9298240f615ad2f7ced9e \
gstreamer,gstreamer-app,gstreamer-app-sys,gstreamer-audio,gstreamer-audio-sys,gstreamer-base,gstreamer-base-sys,gstreamer-check,gstreamer-check-sys,gstreamer-net,gstreamer-net-sys,gstreamer-rtp,gstreamer-rtp-sys,gstreamer-sys,gstreamer-video,gstreamer-video-sys@git+https://gitlab.freedesktop.org/gstreamer/gstreamer-rs?branch=0.18\#9ee22baa07d2c4e67742baeafb2be49e1db9befe \
gdk4,gdk4-sys,gsk4,gsk4-sys,gtk4,gtk4-macros,gtk4-sys@git+https://github.com/gtk-rs/gtk4-rs?branch=0.4\#36aa4108f8e221536e194f62d8ee3be8ea6191f0 \
ffv1@git+https://github.com/rust-av/ffv1.git?rev=2afb025a327173ce891954c052e804d0f880368a\#2afb025a327173ce891954c052e804d0f880368a \
flavors@git+https://github.com/rust-av/flavors\#c48542aef94b7da36d6f306f4016bee9c79e09ba \
atk,atk-sys,gdk,gdk-sys,gtk,gtk-sys,gtk3-macros@git+https://github.com/gtk-rs/gtk3-rs?branch=0.15\#51df5c22fbe02ec57c5052a3e5a91cc9671a0e83
CARGO_BUILD= no
CARGO_INSTALL= no
CARGO_TEST= no
OPTIONS_DEFINE= CSOUND DAV1D PANGO SODIUM
OPTIONS_DEFAULT=CSOUND DAV1D PANGO SODIUM
OPTIONS_DEFINE= CAIRO CSOUND DAV1D GTK4 PANGO SODIUM
OPTIONS_DEFAULT=CAIRO CSOUND DAV1D GTK4 PANGO SODIUM
OPTIONS_EXCLUDE_aarch64= CSOUND # https://github.com/neithanmo/csound-rs/commit/8962b89d7bda
OPTIONS_EXCLUDE_armv7= CSOUND # https://github.com/neithanmo/csound-rs/commit/8962b89d7bda
OPTIONS_EXCLUDE_powerpc64le= CSOUND
@ -407,6 +432,9 @@ OPTIONS_EXCLUDE_powerpc64= CSOUND
OPTIONS_EXCLUDE_powerpc= CSOUND DAV1D
OPTIONS_SUB= yes
CAIRO_USE= GNOME=cairo
CAIRO_MESON_ENABLED= videofx
CSOUND_DESC= Audio filtering via Csound
CSOUND_LIB_DEPENDS= libcsound64.so:audio/csound
CSOUND_CONFIGURE_ENV= CSOUND_LIB_DIR="${LOCALBASE}/lib"
@ -417,6 +445,10 @@ DAV1D_BUILD_DEPENDS= llvm${LLVM_DEFAULT}>0:devel/llvm${LLVM_DEFAULT}
DAV1D_LIB_DEPENDS= libdav1d.so:multimedia/dav1d
DAV1D_MESON_ENABLED= dav1d
GTK4_DESC= ${GTK3_DESC:S/3/4/}
GTK4_LIB_DEPENDS= libgraphene-1.0.so:graphics/graphene
GTK4_USE= GNOME=gtk40
PANGO_USE= GNOME=cairo,pango
PANGO_MESON_ENABLED= closedcaption
@ -430,7 +462,7 @@ post-patch:
${WRKSRC}/cargo-crates/clang-sys-*/build/common.rs \
${WRKSRC}/cargo-crates/clang-sys-*/src/support.rs
# Make each cargo subcommand very verbose
@${REINPLACE_CMD} -e "/'cargo'/s/, '--/&verbose'&verbose'&/" \
@${REINPLACE_CMD} -e "/'cargo'/s/]/, '--verbose', '--verbose'&/" \
${WRKSRC}/cargo_wrapper.py
post-install:

File diff suppressed because it is too large Load Diff

View File

@ -1,18 +0,0 @@
$ cargo cbuild
Error: CliError { error: Some(failed to load manifest for workspace member `generic/threadshare`
Caused by:
0: failed to parse manifest at `generic/threadshare/Cargo.toml`
1: key `tag` is ignored for dependency (tokio).), exit_code: 101 }
--- generic/threadshare/Cargo.toml.orig 2021-08-31 05:49:18 UTC
+++ generic/threadshare/Cargo.toml
@@ -15,7 +15,7 @@ gst-net = { package = "gstreamer-net", version = "0.17
gst-rtp = { package = "gstreamer-rtp", version = "0.17" }
pin-project = "1"
once_cell = "1"
-tokio = { git = "https://github.com/fengalin/tokio", tag = "tokio-0.2.13-throttling", features = ["io-util", "macros", "rt-core", "sync", "stream", "time", "tcp", "udp", "rt-util"] }
+tokio = { git = "https://github.com/fengalin/tokio", features = ["io-util", "macros", "rt-core", "sync", "stream", "time", "tcp", "udp", "rt-util"] }
futures = { version = "0.3", features = ["thread-pool"] }
rand = "0.8"
socket2 = {features = ["all"], version = "0.4"}

View File

@ -0,0 +1,89 @@
https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs/-/commit/ea98a0b5964c
error[E0609]: no field `n_frame_threads` on type `dav1d_sys::Dav1dSettings`
--> cargo-crates/dav1d-0.7.0/src/lib.rs:111:29
|
111 | self.dav1d_settings.n_frame_threads = n_frame_threads as i32;
| ^^^^^^^^^^^^^^^ unknown field
|
= note: available fields are: `n_threads`, `max_frame_delay`, `apply_grain`, `operating_point`, `all_layers` ... and 7 others
error[E0609]: no field `n_frame_threads` on type `dav1d_sys::Dav1dSettings`
--> cargo-crates/dav1d-0.7.0/src/lib.rs:115:29
|
115 | self.dav1d_settings.n_frame_threads as u32
| ^^^^^^^^^^^^^^^ unknown field
|
= note: available fields are: `n_threads`, `max_frame_delay`, `apply_grain`, `operating_point`, `all_layers` ... and 7 others
error[E0609]: no field `n_tile_threads` on type `dav1d_sys::Dav1dSettings`
--> cargo-crates/dav1d-0.7.0/src/lib.rs:119:29
|
119 | self.dav1d_settings.n_tile_threads = n_tile_threads as i32;
| ^^^^^^^^^^^^^^ unknown field
|
= note: available fields are: `n_threads`, `max_frame_delay`, `apply_grain`, `operating_point`, `all_layers` ... and 7 others
error[E0609]: no field `n_tile_threads` on type `dav1d_sys::Dav1dSettings`
--> cargo-crates/dav1d-0.7.0/src/lib.rs:123:29
|
123 | self.dav1d_settings.n_tile_threads as u32
| ^^^^^^^^^^^^^^ unknown field
|
= note: available fields are: `n_threads`, `max_frame_delay`, `apply_grain`, `operating_point`, `all_layers` ... and 7 others
error[E0609]: no field `n_postfilter_threads` on type `dav1d_sys::Dav1dSettings`
--> cargo-crates/dav1d-0.7.0/src/lib.rs:159:29
|
159 | self.dav1d_settings.n_postfilter_threads = n_postfilter_threads as i32;
| ^^^^^^^^^^^^^^^^^^^^ unknown field
|
= note: available fields are: `n_threads`, `max_frame_delay`, `apply_grain`, `operating_point`, `all_layers` ... and 7 others
error[E0609]: no field `n_postfilter_threads` on type `dav1d_sys::Dav1dSettings`
--> cargo-crates/dav1d-0.7.0/src/lib.rs:163:29
|
163 | self.dav1d_settings.n_postfilter_threads as u32
| ^^^^^^^^^^^^^^^^^^^^ unknown field
|
= note: available fields are: `n_threads`, `max_frame_delay`, `apply_grain`, `operating_point`, `all_layers` ... and 7 others
For more information about this error, try `rustc --explain E0609`.
error: could not compile `dav1d` due to 6 previous errors
--- Cargo.lock.orig 2022-04-26 11:20:02 UTC
+++ Cargo.lock
@@ -746,18 +746,18 @@ name = "dav1d"
[[package]]
name = "dav1d"
-version = "0.7.0"
+version = "0.8.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "9f31455daf4c299ff51191482db319c556b3b0afc3deced5331ab3359c898fe5"
+checksum = "d9669fd63fb7d46c2faadff42a0d168819735a2be83903e7973f09721ed42a8a"
dependencies = [
"dav1d-sys",
]
[[package]]
name = "dav1d-sys"
-version = "0.4.0"
+version = "0.5.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "b3cc7ff2ad3b5a27f98378e646c3afa851ffce6277664b35b0b10b0d28f617a1"
+checksum = "237e2b43eb9a661b07147ec8dd483e7fe337977791d32c69c82f9a0e6c3be501"
dependencies = [
"bindgen",
"system-deps 6.0.2",
--- video/dav1d/Cargo.toml.orig 2022-04-26 11:20:02 UTC
+++ video/dav1d/Cargo.toml
@@ -10,7 +10,7 @@ atomic_refcell = "0.1"
[dependencies]
atomic_refcell = "0.1"
-dav1d = "0.7"
+dav1d = "0.8"
gst = { package = "gstreamer", git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs", branch = "0.18", version = "0.18" }
gst-base = { package = "gstreamer-base", git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs", branch = "0.18", version = "0.18" }
gst-video = { package = "gstreamer-video", git = "https://gitlab.freedesktop.org/gstreamer/gstreamer-rs", branch = "0.18", version = "0.18", features = ["v1_12"] }

View File

@ -1,10 +0,0 @@
--- cargo-crates/crossbeam-utils-0.8.5/no_atomic.rs.orig 2021-07-12 16:01:05.023177000 +0200
+++ cargo-crates/crossbeam-utils-0.8.5/no_atomic.rs 2021-07-12 16:01:16.538869000 +0200
@@ -30,6 +30,7 @@
"mipsel-unknown-none",
"mipsisa32r6-unknown-linux-gnu",
"mipsisa32r6el-unknown-linux-gnu",
+ "powerpc-unknown-freebsd",
"powerpc-unknown-linux-gnu",
"powerpc-unknown-linux-gnuspe",
"powerpc-unknown-linux-musl",

View File

@ -2,7 +2,11 @@ lib/gstreamer-1.0/libgstcdg.so
lib/gstreamer-1.0/libgstclaxon.so
%%CSOUND%%lib/gstreamer-1.0/libgstcsound.so
lib/gstreamer-1.0/libgstfallbackswitch.so
lib/gstreamer-1.0/libgstffv1.so
lib/gstreamer-1.0/libgstfmp4.so
lib/gstreamer-1.0/libgstgif.so
%%GTK4%%lib/gstreamer-1.0/libgstgtk4.so
lib/gstreamer-1.0/libgsthlssink3.so
lib/gstreamer-1.0/libgsthsv.so
lib/gstreamer-1.0/libgstlewton.so
lib/gstreamer-1.0/libgstrav1e.so
@ -19,13 +23,21 @@ lib/gstreamer-1.0/libgstrstextwrap.so
lib/gstreamer-1.0/libgstrswebp.so
lib/gstreamer-1.0/libgstrusoto.so
%%SODIUM%%lib/gstreamer-1.0/libgstsodium.so
lib/gstreamer-1.0/libgstspotify.so
lib/gstreamer-1.0/libgsttextahead.so
lib/gstreamer-1.0/libgstthreadshare.so
lib/gstreamer-1.0/libgsttogglerecord.so
lib/gstreamer-1.0/libgsturiplaylistbin.so
%%CAIRO%%lib/gstreamer-1.0/libgstvideofx.so
libdata/pkgconfig/gstcdg.pc
libdata/pkgconfig/gstclaxon.pc
%%CSOUND%%libdata/pkgconfig/gstcsound.pc
libdata/pkgconfig/gstfallbackswitch.pc
libdata/pkgconfig/gstffv1.pc
libdata/pkgconfig/gstfmp4.pc
libdata/pkgconfig/gstgif.pc
%%GTK4%%libdata/pkgconfig/gstgtk4.pc
libdata/pkgconfig/gsthlssink3.pc
libdata/pkgconfig/gsthsv.pc
libdata/pkgconfig/gstlewton.pc
libdata/pkgconfig/gstrav1e.pc
@ -42,5 +54,9 @@ libdata/pkgconfig/gstrstextwrap.pc
libdata/pkgconfig/gstrswebp.pc
libdata/pkgconfig/gstrusoto.pc
%%SODIUM%%libdata/pkgconfig/gstsodium.pc
libdata/pkgconfig/gstspotify.pc
libdata/pkgconfig/gsttextahead.pc
libdata/pkgconfig/gstthreadshare.pc
libdata/pkgconfig/gsttogglerecord.pc
libdata/pkgconfig/gsturiplaylistbin.pc
%%CAIRO%%libdata/pkgconfig/gstvideofx.pc