sysutils/py-google-compute-engine: remove patches for InstanceSetup
While here, pet portlint by fixing shebang and bump PORTREVISION. PR: 230741 Submitted by: Helen Koike <helen.koike@collabora.com> (maintainer)
This commit is contained in:
parent
ada18d20be
commit
7f94536b01
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=477577
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= google-compute-engine
|
||||
DISTVERSION= 2.8.3
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= sysutils python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -19,9 +19,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${PY_FLAVOR} \
|
||||
google_oslogin_control:sysutils/google-compute-engine-oslogin \
|
||||
sudo:security/sudo
|
||||
|
||||
USES= python
|
||||
USES= python shebangfix
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
NO_ARCH= yes
|
||||
SHEBANG_FILES= scripts/set_multiqueue scripts/optimize_local_ssd
|
||||
|
||||
USE_RC_SUBR= google_instance_setup \
|
||||
google_accounts_daemon \
|
||||
|
@ -6,3 +6,7 @@ groupadd_cmd = pw groupadd {group}
|
||||
|
||||
[MetadataScripts]
|
||||
default_shell = /bin/sh
|
||||
|
||||
[InstanceSetup]
|
||||
set_multiqueue = false
|
||||
optimize_local_ssd = false
|
||||
|
@ -1,16 +0,0 @@
|
||||
--- google_compute_engine/instance_setup/instance_config.py.orig 2018-06-11 23:51:09 UTC
|
||||
+++ google_compute_engine/instance_setup/instance_config.py
|
||||
@@ -74,11 +74,11 @@ class InstanceConfig(config_manager.Conf
|
||||
},
|
||||
'InstanceSetup': {
|
||||
'host_key_types': 'ecdsa,ed25519,rsa',
|
||||
- 'optimize_local_ssd': 'true',
|
||||
+ 'optimize_local_ssd': 'false',
|
||||
'network_enabled': 'true',
|
||||
'set_boto_config': 'true',
|
||||
'set_host_keys': 'true',
|
||||
- 'set_multiqueue': 'true',
|
||||
+ 'set_multiqueue': 'false',
|
||||
},
|
||||
'IpForwarding': {
|
||||
'ethernet_proto_id': '66',
|
@ -1,10 +0,0 @@
|
||||
--- setup.py.orig 2018-06-11 23:51:09 UTC
|
||||
+++ setup.py
|
||||
@@ -34,7 +34,6 @@ setuptools.setup(
|
||||
long_description='Google Compute Engine guest environment.',
|
||||
name='google-compute-engine',
|
||||
packages=setuptools.find_packages(),
|
||||
- scripts=glob.glob('scripts/*'),
|
||||
url='https://github.com/GoogleCloudPlatform/compute-image-packages',
|
||||
version='2.8.3',
|
||||
# Entry points create scripts in /usr/bin that call a function.
|
Loading…
Reference in New Issue
Block a user