Fix hardcoded use of /etc/imapproxyd.conf with autoconf

Remove unneeded postpatch section

Other PRs just set the default location of the
default config file:  ports/142247 ports/125655 ports/122422

PR:		ports/133098
Submitted by:	Daniel Bond <db@danielbond.org>
This commit is contained in:
Martin Blapp 2010-01-02 22:30:52 +00:00
parent 463d6d0b94
commit 7f3c36366f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=247020
2 changed files with 15 additions and 6 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= imapproxy
PORTVERSION= 1.2.6
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://www.imapproxy.org/downloads/
PKGNAMEPREFIX= up-
@ -16,7 +16,8 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= mbr@FreeBSD.org
COMMENT= A caching IMAP proxy server
GNU_CONFIGURE= YES
USE_AUTOTOOLS= autoheader:262
USE_RC_SUBR= imapproxyd.sh
DOCS= COPYING ChangeLog README README.debian \
README.known_issues README.ssl
@ -26,10 +27,6 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
post-patch:
${REINPLACE_CMD} -e "s|-lc_r|${PTHREAD_LIBS}|g" \
-e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}

View File

@ -0,0 +1,12 @@
--- configure.in.orig 2009-03-26 15:13:59.000000000 +0100
+++ configure.in 2009-03-26 15:14:54.000000000 +0100
@@ -129,7 +129,8 @@
LIBS="$save_LIBS"
AC_SUBST(LIB_CURSES)
-
+eval expanded_sysconfdir="\"$sysconfdir\""
+AC_DEFINE_UNQUOTED(DEFAULT_CONFIG_FILE, "$expanded_sysconfdir/imapproxyd.conf", [default location of config file])
AC_CONFIG_HEADER(config.h)