- Add patch to deal with FreeBSD location of PFPRO_CERT_PATH

PR:		ports/98996
Submitted by:	Alexandr Kovalenko <never@nevermind.kiev.ua>
Approved by:	tobez (implicit)
This commit is contained in:
Aaron Dalton 2006-06-16 04:26:57 +00:00
parent c3496b0186
commit 7f242f3ed9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=165535
2 changed files with 17 additions and 0 deletions

View File

@ -23,4 +23,7 @@ PERL_CONFIGURE= yes
MAN3= PFProAPI.3
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/PFProAPI.pm
.include <bsd.port.mk>

View File

@ -0,0 +1,14 @@
--- PFProAPI.pm.orig Fri Jun 16 01:37:04 2006
+++ PFProAPI.pm Fri Jun 16 01:37:13 2006
@@ -76,6 +76,11 @@
my $parmlist;
my ($name, $value);
+ # If no PFPRO_CERT_PATH set, we will set default one
+ if ($ENV{'PFPRO_CERT_PATH'} eq '') {
+ $ENV{'PFPRO_CERT_PATH'} = '%%PREFIX%%/etc/pfpro/certs';
+ }
+
if (! $data) {
# If no data was passed, we will build a test transaction
$data->{ACCT} = "5105105105105100";