Now that I've assured the CVS/Repository files are correct, remove
p5-Mail-SpamAssassin-devel (again). Also, add it to MOVED. Ah, the joy and wonder of CVS.
This commit is contained in:
parent
3b4a505e5a
commit
7f0c68d522
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73973
1
MOVED
1
MOVED
@ -151,3 +151,4 @@ devel/gnustep-devel|devel/gnustep|2003-01-20|merged
|
||||
x11-toolkits/gnustep-gui-devel|x11-toolkits/gnustep-gui|2003-01-20|merged
|
||||
x11-toolkits/gnustep-xgps|x11-toolkits/gnustep-back|2003-01-20|full substitute
|
||||
devel/ruby-unit|devel/ruby-testunit|2003-01-23|succeeded
|
||||
mail/p5-Mail-SpamAssassin-devel|p5-Mail-SpamAssassin-snapshot|2003-01-25|directory renamed
|
||||
|
@ -1,63 +0,0 @@
|
||||
# New ports collection makefile for: p5-Mail-SpamAssassin-devel
|
||||
# Date created: Dec 5 2002
|
||||
# Whom: Brian Fundakowski Feldman
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= Mail-SpamAssassin
|
||||
PORTVERSION= 2.50
|
||||
CATEGORIES= mail perl5
|
||||
MASTER_SITES= http://spamassassin.org/devel/ \
|
||||
${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= Mail
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= dougb@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS \
|
||||
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
|
||||
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS} \
|
||||
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
|
||||
razor-client:${PORTSDIR}/mail/razor-agents
|
||||
|
||||
PODPARSER= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
|
||||
RUN_DEPENDS+= ${PODPARSER}
|
||||
BUILD_DEPENDS+= ${PODPARSER}
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= SYSCONFDIR="${PREFIX}/etc" RUN_RAZOR1_TESTS="no" \
|
||||
RUN_RAZOR2_TESTS="no"
|
||||
|
||||
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
|
||||
MAN3= Mail::SpamAssassin.3 Mail::SpamAssassin::PerMsgStatus.3 \
|
||||
Mail::SpamAssassin::Conf.3 \
|
||||
Mail::SpamAssassin::PersistentAddrList.3 \
|
||||
Mail::SpamAssassin::PerMsgLearner.3 \
|
||||
Mail::SpamAssassin::Bayes.3 \
|
||||
Mail::SpamAssassin::BayesStore.3
|
||||
MAN1PREFIX= ${PREFIX}
|
||||
MAN1= spamd.1 spamassassin.1 spamc.1 sa-learn-nonspam.1 \
|
||||
sa-learn-spam.1 sa-learn-rebuild.1 sa-forget.1
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
|
||||
EXAMPLESDIR= ${PREFIX}/share/examples//${PKGNAMEPREFIX}${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name \*.orig -delete
|
||||
|
||||
post-install:
|
||||
@strip ${PREFIX}/bin/spamc
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/spamd.sh ${PREFIX}/etc/rc.d/spamd.sh-dist
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/sql/README ${DOCSDIR}/README.sql
|
||||
cd ${WRKSRC} ; ${INSTALL_DATA} \
|
||||
BUGS COPYRIGHT Changes README TRADEMARK procmailrc.example sample* \
|
||||
spamd/README* sql/spamassassin.sql \
|
||||
${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1 +0,0 @@
|
||||
MD5 (Mail-SpamAssassin-2.50.tar.gz) = 0b693ea51431fd099caf9054bbf43214
|
@ -1,93 +0,0 @@
|
||||
diff -ur ../Mail-SpamAssassin-2.43/lib/Mail/SpamAssassin/Conf.pm ./lib/Mail/SpamAssassin/Conf.pm
|
||||
--- ../Mail-SpamAssassin-2.43/lib/Mail/SpamAssassin/Conf.pm Fri Oct 4 05:54:15 2002
|
||||
+++ ./lib/Mail/SpamAssassin/Conf.pm Thu Oct 17 22:12:05 2002
|
||||
@@ -144,6 +144,9 @@
|
||||
$self->{user_rules_to_compile} = 0;
|
||||
$self->{fold_headers} = 1;
|
||||
|
||||
+ # Added by FreeBSD ports
|
||||
+ $self->{use_dcc} = 1;
|
||||
+
|
||||
$self->{dcc_path} = undef; # Browse PATH
|
||||
$self->{dcc_body_max} = 999999;
|
||||
$self->{dcc_fuz1_max} = 999999;
|
||||
@@ -763,6 +766,16 @@
|
||||
|
||||
if (/^rbl[-_]timeout\s+(\d+)$/) {
|
||||
$self->{rbl_timeout} = $1+0; next;
|
||||
+ }
|
||||
+
|
||||
+=item use_dcc { 0 | 1 } (default: 1)
|
||||
+
|
||||
+Should we use dccproc, or not.
|
||||
+
|
||||
+=cut
|
||||
+
|
||||
+ if (/^use[-_]dcc\s+(\d+)$/) {
|
||||
+ $self->{use_dcc} = $1+0; next;
|
||||
}
|
||||
|
||||
=item ok_locales xx [ yy zz ... ] (default: all)
|
||||
diff -ur ../Mail-SpamAssassin-2.43/lib/Mail/SpamAssassin/Dns.pm ./lib/Mail/SpamAssassin/Dns.pm
|
||||
--- ../Mail-SpamAssassin-2.43/lib/Mail/SpamAssassin/Dns.pm Fri Oct 4 05:54:16 2002
|
||||
+++ ./lib/Mail/SpamAssassin/Dns.pm Thu Oct 17 22:12:51 2002
|
||||
@@ -449,6 +449,9 @@
|
||||
sub is_dcc_available {
|
||||
my ($self) = @_;
|
||||
|
||||
+ # Added by FreeBSD ports
|
||||
+ return 0 unless $self->{conf}->{use_dcc};
|
||||
+
|
||||
if ($self->{main}->{local_tests_only}) {
|
||||
dbg ("local tests only, ignoring DCC");
|
||||
return 0;
|
||||
@@ -476,6 +479,10 @@
|
||||
|
||||
sub dcc_lookup {
|
||||
my ($self, $fulltext) = @_;
|
||||
+
|
||||
+ # Added by FreeBSD ports
|
||||
+ return 0 unless $self->{conf}->{use_dcc};
|
||||
+
|
||||
my $response = undef;
|
||||
my %count;
|
||||
my $left;
|
||||
diff -ur ../Mail-SpamAssassin-2.43/lib/Mail/SpamAssassin/EvalTests.pm ./lib/Mail/SpamAssassin/EvalTests.pm
|
||||
--- ../Mail-SpamAssassin-2.43/lib/Mail/SpamAssassin/EvalTests.pm Fri Oct 4 05:54:16 2002
|
||||
+++ ./lib/Mail/SpamAssassin/EvalTests.pm Thu Oct 17 22:10:46 2002
|
||||
@@ -2026,6 +2026,9 @@
|
||||
sub check_dcc {
|
||||
my ($self, $fulltext) = @_;
|
||||
|
||||
+ # Added by FreeBSD ports
|
||||
+ return 0 unless $self->{conf}->{use_dcc};
|
||||
+
|
||||
return 0 unless ($self->is_dcc_available());
|
||||
return 0 if ($self->{already_checked_dcc});
|
||||
|
||||
diff -ur ../Mail-SpamAssassin-2.43/lib/Mail/SpamAssassin/Reporter.pm ./lib/Mail/SpamAssassin/Reporter.pm
|
||||
--- ../Mail-SpamAssassin-2.43/lib/Mail/SpamAssassin/Reporter.pm Mon Oct 14 09:44:35 2002
|
||||
+++ ./lib/Mail/SpamAssassin/Reporter.pm Thu Oct 17 22:13:19 2002
|
||||
@@ -238,6 +238,9 @@
|
||||
sub is_dcc_available {
|
||||
my ($self) = @_;
|
||||
|
||||
+ # Added by FreeBSD ports
|
||||
+ return 0 unless $self->{conf}->{use_dcc};
|
||||
+
|
||||
if ($self->{main}->{local_tests_only}) {
|
||||
dbg ("local tests only, ignoring DCC");
|
||||
return 0;
|
||||
diff -ur ../Mail-SpamAssassin-2.43/rules/10_misc.cf ./rules/10_misc.cf
|
||||
--- ../Mail-SpamAssassin-2.43/rules/10_misc.cf Thu Sep 26 03:50:25 2002
|
||||
+++ ./rules/10_misc.cf Thu Oct 17 22:10:46 2002
|
||||
@@ -107,6 +107,9 @@
|
||||
# test, so it is set to "all" so the test will not be used by default.
|
||||
ok_languages all
|
||||
|
||||
+# Added by FreeBSD ports
|
||||
+use_dcc 0
|
||||
+
|
||||
# Some common prefs settings can be set here, to take effect site-wide
|
||||
# unless the user override them. See the .prefs file for explanations.
|
||||
|
@ -1,19 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
|
||||
echo "$0: Cannot determine the PREFIX" >&2
|
||||
exit 1
|
||||
fi
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
[ -x ${PREFIX}/bin/spamd ] && ${PREFIX}/bin/spamd -a -c -d && echo -n ' spamd'
|
||||
;;
|
||||
stop)
|
||||
;;
|
||||
*)
|
||||
echo "Usage: `basename $0` {start|stop}" >&2
|
||||
;;
|
||||
esac
|
||||
|
||||
exit 0
|
@ -1 +0,0 @@
|
||||
A mail filter for identifying SPAM
|
@ -1,11 +0,0 @@
|
||||
SpamAssassin is a mail filter which attempts to identify spam using text
|
||||
analysis and several internet-based realtime blacklists.
|
||||
|
||||
Using its rule base, it uses a wide range of heuristic tests on mail
|
||||
headers and body text to identify "spam", also known as unsolicited
|
||||
commercial email.
|
||||
|
||||
Once identified, the mail can then be optionally tagged as spam for later
|
||||
filtering using the user's own mail user-agent application.
|
||||
|
||||
WWW: http://spamassassin.org/
|
@ -1,81 +0,0 @@
|
||||
bin/sa-learn-nonspam
|
||||
bin/spamd
|
||||
bin/sa-learn-rebuild
|
||||
bin/sa-forget
|
||||
bin/sa-learn-spam
|
||||
bin/spamc
|
||||
bin/spamassassin
|
||||
etc/rc.d/spamd.sh-dist
|
||||
etc/mail/spamassassin/local.cf
|
||||
@dirrm etc/mail/spamassassin
|
||||
@dirrm etc/mail
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/SpamAssassin/.packlist
|
||||
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/SpamAssassin
|
||||
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/Conf.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/Replier.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/Bayes.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/ConfSourceSQL.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/DBBasedAddrList.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/PerMsgStatus.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/Reporter.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/SHA1.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/AuditMessage.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/HTML.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/MailingList.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/ArchiveIterator.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/CmdLearn.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/ExposedMessage.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/PerMsgLearner.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/EncappedMIME.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/BayesStore.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/NoMailAudit.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/AutoWhitelist.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/PersistentAddrList.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/Dns.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/PhraseFreqs.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/TextCat.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/EncappedMessage.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/Message.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/EvalTests.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin/Locales.pm
|
||||
@dirrm lib/perl5/site_perl/%%PERL_VER%%/Mail/SpamAssassin
|
||||
@dirrm lib/perl5/site_perl/%%PERL_VER%%/Mail
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/README.sql
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/BUGS
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/COPYRIGHT
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/Changes
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/README
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/TRADEMARK
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/procmailrc.example
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/sample-nonspam.txt
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/sample-spam.txt
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/README.spamd
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/README.spamd-vpopmail
|
||||
%%PORTDOCS%%share/doc/p5-Mail-SpamAssassin/spamassassin.sql
|
||||
@dirrm %%PORTDOCS%%share/doc/p5-Mail-SpamAssassin
|
||||
share/spamassassin/10_misc.cf
|
||||
share/spamassassin/20_anti_ratware.cf
|
||||
share/spamassassin/20_body_tests.cf
|
||||
share/spamassassin/20_compensate.cf
|
||||
share/spamassassin/20_head_tests.cf
|
||||
share/spamassassin/20_meta_tests.cf
|
||||
share/spamassassin/20_ratware.cf
|
||||
share/spamassassin/20_uri_tests.cf
|
||||
share/spamassassin/23_bayes.cf
|
||||
share/spamassassin/25_body_tests_es.cf
|
||||
share/spamassassin/25_body_tests_pl.cf
|
||||
share/spamassassin/25_head_tests_es.cf
|
||||
share/spamassassin/25_head_tests_pl.cf
|
||||
share/spamassassin/30_text_de.cf
|
||||
share/spamassassin/30_text_es.cf
|
||||
share/spamassassin/30_text_fr.cf
|
||||
share/spamassassin/30_text_pl.cf
|
||||
share/spamassassin/40_spam_phrases.cf
|
||||
share/spamassassin/50_scores.cf
|
||||
share/spamassassin/60_whitelist.cf
|
||||
share/spamassassin/user_prefs.template
|
||||
share/spamassassin/triplets.txt
|
||||
share/spamassassin/languages
|
||||
@dirrm share/spamassassin
|
Loading…
Reference in New Issue
Block a user