Fix build in -CURRENT.
Approved by: antoine (implicit)
This commit is contained in:
parent
502cc9f8b2
commit
7f04382e6c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=546906
@ -13,7 +13,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= xmlwf:textproc/expat2
|
||||
|
||||
USES= autoreconf gmake perl5
|
||||
#USES= autoreconf gmake perl5
|
||||
USES= autoreconf perl5
|
||||
USE_PERL5= build
|
||||
|
||||
USE_GITHUB= yes
|
||||
@ -30,7 +31,6 @@ OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^PKG_/d' ${WRKSRC}/configure.ac
|
||||
@${REINPLACE_CMD} -e 's|sys/capability.h|sys/capsicum.h|' ${WRKSRC}/src/platform-headers.h ${WRKSRC}/src/platform/freebsd/platform-freebsd.h
|
||||
|
||||
post-install-DOCS-on:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
|
11
sysutils/procenv/files/patch-configure.ac
Normal file
11
sysutils/procenv/files/patch-configure.ac
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.ac.orig 2019-08-02 20:40:49 UTC
|
||||
+++ configure.ac
|
||||
@@ -58,7 +58,7 @@ AC_CHECK_HEADERS([numa.h])
|
||||
# FreeBSD 9+ with appropriately configured kernel
|
||||
# (enabled by default in FreeBSD 10)
|
||||
AC_SEARCH_LIBS([cap_getmode], [c])
|
||||
-AC_CHECK_HEADERS([sys/capability.h])
|
||||
+AC_CHECK_HEADERS([sys/capsicum.h])
|
||||
|
||||
AC_SEARCH_LIBS([cap_init], [cap],
|
||||
[HAVE_LIBCAP=yes],
|
20
sysutils/procenv/files/patch-src_platform-headers.h
Normal file
20
sysutils/procenv/files/patch-src_platform-headers.h
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/platform-headers.h.orig 2019-08-02 20:40:49 UTC
|
||||
+++ src/platform-headers.h
|
||||
@@ -98,7 +98,7 @@ typedef struct statfs procenv_mnt_type;
|
||||
#endif
|
||||
|
||||
#if defined (HAVE_SYS_CAPABILITY_H)
|
||||
-#include <sys/capability.h>
|
||||
+#include <sys/capsicum.h>
|
||||
#endif
|
||||
|
||||
#if defined (__GLIBC__)
|
||||
@@ -263,7 +263,7 @@ typedef struct statfs procenv_mnt_type;
|
||||
#include <link.h>
|
||||
|
||||
#if defined (HAVE_SYS_CAPABILITY_H)
|
||||
-#include <sys/capability.h>
|
||||
+#include <sys/capsicum.h>
|
||||
#endif
|
||||
|
||||
#define PROCENV_CPU_TYPE int
|
@ -0,0 +1,13 @@
|
||||
--- src/platform/freebsd/platform-freebsd.h.orig 2019-08-02 20:40:49 UTC
|
||||
+++ src/platform/freebsd/platform-freebsd.h
|
||||
@@ -22,8 +22,8 @@
|
||||
#include "platform.h"
|
||||
#include "util.h"
|
||||
|
||||
-#if defined (HAVE_SYS_CAPABILITY_H)
|
||||
-#include <sys/capability.h>
|
||||
+#if defined (HAVE_SYS_CAPSICUM_H)
|
||||
+#include <sys/capsicum.h>
|
||||
|
||||
#if __FreeBSD__ == 9
|
||||
|
@ -0,0 +1,17 @@
|
||||
--- src/tests/show_compiler_details.orig 2019-08-02 20:40:49 UTC
|
||||
+++ src/tests/show_compiler_details
|
||||
@@ -9,8 +9,12 @@ CPP=${CPP:-cpp}
|
||||
LD=${LD:-ld}
|
||||
|
||||
# handle strange environments
|
||||
-command -v gcpp >/dev/null 2>&1 && CPP=gcpp
|
||||
-command -v gcc >/dev/null 2>&1 && CC=gcc
|
||||
+if ! command -v $CPP; then
|
||||
+ command -v gcpp && CPP=gcpp
|
||||
+fi >/dev/null 2>&1
|
||||
+if ! command -v $CC; then
|
||||
+ command -v gcc && CC=gcc
|
||||
+fi >/dev/null 2>&1
|
||||
|
||||
echo "XXX:--------------------------------------------------"
|
||||
echo "XXX: $0: preprocessor ('$CPP') version"
|
Loading…
Reference in New Issue
Block a user