Upgrade to nmap-2.2-BETA4. The beta includes a very nice GUI (xnmap) that
simplifies the running of nmap for the point and shoot crowd.
This commit is contained in:
parent
6aa2ebee92
commit
7efe79f49b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=20318
@ -4,10 +4,11 @@
|
||||
# Date created: Tue Aug 04, 1998
|
||||
# Whom: David O'Brien (obrien@NUXI.com)
|
||||
#
|
||||
# $Id: Makefile,v 1.16 1999/04/04 22:54:44 obrien Exp $
|
||||
# $Id: Makefile,v 1.17 1999/04/07 19:00:04 fenner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nmap-2.12
|
||||
DISTNAME= nmap-2.2-BETA4
|
||||
PKGNAME= nmap-2.2b4
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://www.insecure.org/nmap/dist/ \
|
||||
ftp://relay.nuxi.com/pub/misc/
|
||||
@ -15,10 +16,14 @@ EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= obrien@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
USE_XLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --libdir=${PREFIX}/share/misc
|
||||
MAKE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
|
||||
.if ${OSVERSION} < 300004
|
||||
CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
|
||||
.endif
|
||||
|
@ -1 +1 @@
|
||||
MD5 (nmap-2.12.tgz) = 197fc5fe2888febf47efe7d823e2f678
|
||||
MD5 (nmap-2.2-BETA4.tgz) = 23c3e6c7f4969338b79c8e6fa6c2ddbd
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.in.orig Sun Feb 7 12:23:10 1999
|
||||
+++ Makefile.in Mon Feb 8 03:18:01 1999
|
||||
--- Makefile.in.orig Fri May 7 04:20:11 1999
|
||||
+++ Makefile.in Thu Jul 22 10:45:28 1999
|
||||
@@ -5,12 +5,12 @@
|
||||
sbindir = @sbindir@
|
||||
mandir = @mandir@
|
||||
@ -15,12 +15,12 @@
|
||||
DEFS = @DEFS@ -DVERSION=\"$(VERSION)\" -DLIBDIR=\"$(libdir)\"
|
||||
CFLAGS = @CFLAGS@ $(CCOPT) $(DEFS) $(INCLS)
|
||||
# CFLAGS = -g -Wall $(DEFS) $(INCLS)
|
||||
@@ -32,7 +32,7 @@
|
||||
@@ -33,7 +33,7 @@
|
||||
|
||||
all: $(TARGET)
|
||||
|
||||
-$(TARGET): $(DEPS) @PCAP_DEPENDS@ $(OBJS)
|
||||
+$(TARGET): $(DEPS) $(OBJS) # @PCAP_DEPENDS@
|
||||
-$(TARGET): $(DEPS) @PCAP_DEPENDS@ $(OBJS) nmapfe/nmapfe
|
||||
+$(TARGET): $(DEPS) $(OBJS) nmapfe/nmapfe # @PCAP_DEPENDS@
|
||||
@echo Compiling nmap
|
||||
rm -f $@
|
||||
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
|
||||
|
@ -1,4 +1,6 @@
|
||||
@comment $Id: PLIST,v 1.3 1998/12/15 11:18:32 obrien Exp $
|
||||
@comment $Id: PLIST,v 1.4 1999/02/08 11:58:17 obrien Exp $
|
||||
bin/nmap
|
||||
bin/nmapfe
|
||||
bin/xnmap
|
||||
share/misc/nmap-os-fingerprints
|
||||
share/misc/nmap-services
|
||||
|
@ -4,10 +4,11 @@
|
||||
# Date created: Tue Aug 04, 1998
|
||||
# Whom: David O'Brien (obrien@NUXI.com)
|
||||
#
|
||||
# $Id: Makefile,v 1.16 1999/04/04 22:54:44 obrien Exp $
|
||||
# $Id: Makefile,v 1.17 1999/04/07 19:00:04 fenner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nmap-2.12
|
||||
DISTNAME= nmap-2.2-BETA4
|
||||
PKGNAME= nmap-2.2b4
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://www.insecure.org/nmap/dist/ \
|
||||
ftp://relay.nuxi.com/pub/misc/
|
||||
@ -15,10 +16,14 @@ EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= obrien@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
USE_XLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --libdir=${PREFIX}/share/misc
|
||||
MAKE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
|
||||
.if ${OSVERSION} < 300004
|
||||
CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
|
||||
.endif
|
||||
|
@ -1 +1 @@
|
||||
MD5 (nmap-2.12.tgz) = 197fc5fe2888febf47efe7d823e2f678
|
||||
MD5 (nmap-2.2-BETA4.tgz) = 23c3e6c7f4969338b79c8e6fa6c2ddbd
|
||||
|
@ -1,4 +1,6 @@
|
||||
@comment $Id: PLIST,v 1.3 1998/12/15 11:18:32 obrien Exp $
|
||||
@comment $Id: PLIST,v 1.4 1999/02/08 11:58:17 obrien Exp $
|
||||
bin/nmap
|
||||
bin/nmapfe
|
||||
bin/xnmap
|
||||
share/misc/nmap-os-fingerprints
|
||||
share/misc/nmap-services
|
||||
|
@ -4,10 +4,11 @@
|
||||
# Date created: Tue Aug 04, 1998
|
||||
# Whom: David O'Brien (obrien@NUXI.com)
|
||||
#
|
||||
# $Id: Makefile,v 1.16 1999/04/04 22:54:44 obrien Exp $
|
||||
# $Id: Makefile,v 1.17 1999/04/07 19:00:04 fenner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nmap-2.12
|
||||
DISTNAME= nmap-2.2-BETA4
|
||||
PKGNAME= nmap-2.2b4
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://www.insecure.org/nmap/dist/ \
|
||||
ftp://relay.nuxi.com/pub/misc/
|
||||
@ -15,10 +16,14 @@ EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= obrien@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
USE_XLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --libdir=${PREFIX}/share/misc
|
||||
MAKE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
|
||||
.if ${OSVERSION} < 300004
|
||||
CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
|
||||
.endif
|
||||
|
@ -1 +1 @@
|
||||
MD5 (nmap-2.12.tgz) = 197fc5fe2888febf47efe7d823e2f678
|
||||
MD5 (nmap-2.2-BETA4.tgz) = 23c3e6c7f4969338b79c8e6fa6c2ddbd
|
||||
|
@ -1,4 +1,6 @@
|
||||
@comment $Id: PLIST,v 1.3 1998/12/15 11:18:32 obrien Exp $
|
||||
@comment $Id: PLIST,v 1.4 1999/02/08 11:58:17 obrien Exp $
|
||||
bin/nmap
|
||||
bin/nmapfe
|
||||
bin/xnmap
|
||||
share/misc/nmap-os-fingerprints
|
||||
share/misc/nmap-services
|
||||
|
Loading…
Reference in New Issue
Block a user