- Update to 1.1.10
- Move to GitHub, project moved - Update WWW - Pacify portlint - Don't install changelog and build instructions, it is not really documentation
This commit is contained in:
parent
97d58c0855
commit
7eeb85a365
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=486215
@ -2,11 +2,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= magicrescue
|
||||
PORTVERSION= 1.1.9
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.1.10
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.itu.dk/people/jobr/magicrescue/release/ \
|
||||
LOCAL/ehaupt
|
||||
|
||||
MAINTAINER= ehaupt@FreeBSD.org
|
||||
COMMENT= File recovery tool which recovers deleted files from a block device
|
||||
@ -15,25 +13,23 @@ LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= perl5 shebangfix
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX}
|
||||
USE_PERL5= run
|
||||
|
||||
SHEBANG_FILES= magicsort tools/gimp-resave.pl
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX}
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= jbj
|
||||
|
||||
SHEBANG_FILES= magicsort tools/*.pl tools/checkrecipe
|
||||
|
||||
MAKE_ENV+= STAGEDIR=${STAGEDIR}
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in NEWS README
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/magicrescue
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dupemap
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/magicrescue \
|
||||
${STAGEDIR}${PREFIX}/bin/dupemap
|
||||
.for f in safecat inputseek textextract
|
||||
@${STRIP_CMD} ${STAGEDIR}${DATADIR}/tools/${f}
|
||||
${STRIP_CMD} ${STAGEDIR}${DATADIR}/tools/${f}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (magicrescue-1.1.9.tar.gz) = a920b174efd664afe9760a43700588c9c5e6182cb13d7421e07ab613bceeb3c7
|
||||
SIZE (magicrescue-1.1.9.tar.gz) = 92621
|
||||
TIMESTAMP = 1543528315
|
||||
SHA256 (jbj-magicrescue-v1.1.10_GH0.tar.gz) = 060c77be3e86a328a4f90f45d2da41b2b78cb74f13d44f69e29909cf68e98cad
|
||||
SIZE (jbj-magicrescue-v1.1.10_GH0.tar.gz) = 227237
|
||||
|
@ -1,32 +0,0 @@
|
||||
--- ./Makefile.in.orig 2008-06-26 22:24:06.000000000 +0200
|
||||
+++ ./Makefile.in 2013-10-26 09:06:55.772677532 +0200
|
||||
@@ -57,20 +57,20 @@
|
||||
maintainer-clean: distclean docs-clean
|
||||
|
||||
install: all
|
||||
- [ -d $(PREFIX) ]
|
||||
+ [ -d $(STAGEDIR)$(PREFIX) ]
|
||||
|
||||
- mkdir -p $(PREFIX)/share/magicrescue/tools \
|
||||
- $(PREFIX)/share/magicrescue/recipes \
|
||||
- $(PREFIX)/man/man1 \
|
||||
- $(PREFIX)/bin
|
||||
+ mkdir -p $(STAGEDIR)$(PREFIX)/share/magicrescue/tools \
|
||||
+ $(STAGEDIR)$(PREFIX)/share/magicrescue/recipes \
|
||||
+ $(STAGEDIR)$(PREFIX)/man/man1 \
|
||||
+ $(STAGEDIR)$(PREFIX)/bin
|
||||
|
||||
- cp magicrescue$(EXE) dupemap$(EXE) magicsort $(PREFIX)/bin/
|
||||
- cp recipes/* $(PREFIX)/share/magicrescue/recipes/
|
||||
- cp $(DOCS) $(PREFIX)/man/man1
|
||||
+ cp magicrescue$(EXE) dupemap$(EXE) magicsort $(STAGEDIR)$(PREFIX)/bin/
|
||||
+ cp recipes/* $(STAGEDIR)$(PREFIX)/share/magicrescue/recipes/
|
||||
+ cp $(DOCS) $(STAGEDIR)$(MANPREFIX)/man/man1
|
||||
|
||||
for f in tools/*; do \
|
||||
if [ -x "$$f" ]; then \
|
||||
- cp -f "$$f" $(PREFIX)/share/magicrescue/tools/; \
|
||||
+ cp -f "$$f" $(STAGEDIR)$(PREFIX)/share/magicrescue/tools/; \
|
||||
fi; \
|
||||
done
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ./magicsort.orig 2013-10-26 09:06:33.969663571 +0200
|
||||
+++ ./magicsort 2013-10-26 09:06:33.972663781 +0200
|
||||
@@ -13,7 +13,7 @@
|
||||
--- magicsort.orig 2018-11-29 21:59:50 UTC
|
||||
+++ magicsort
|
||||
@@ -13,7 +13,7 @@ opendir DH, "." or die "opening $dir: $!
|
||||
while (defined(my $file = readdir DH)) {
|
||||
next unless -f $file;
|
||||
|
||||
@ -9,7 +9,7 @@
|
||||
my $idstring = <FILE>;
|
||||
close FILE;
|
||||
|
||||
@@ -25,7 +25,7 @@
|
||||
@@ -25,7 +25,7 @@ while (defined(my $file = readdir DH)) {
|
||||
next;
|
||||
}
|
||||
my $dir = substr($idstring, length($file) + 2);
|
||||
|
@ -8,4 +8,4 @@ It works on any file system, but on very fragmented file systems it can only
|
||||
recover the first chunk of each file. Practical experience shows, however, that
|
||||
chunks of 30-50MB are not uncommon.
|
||||
|
||||
WWW: http://www.itu.dk/people/jobr/magicrescue/
|
||||
WWW: https://github.com/jbj/magicrescue/
|
||||
|
@ -5,12 +5,19 @@ man/man1/dupemap.1.gz
|
||||
man/man1/magicrescue.1.gz
|
||||
man/man1/magicsort.1.gz
|
||||
%%DATADIR%%/recipes/avi
|
||||
%%DATADIR%%/recipes/canon-cr2
|
||||
%%DATADIR%%/recipes/elf
|
||||
%%DATADIR%%/recipes/empathy
|
||||
%%DATADIR%%/recipes/flac
|
||||
%%DATADIR%%/recipes/flv
|
||||
%%DATADIR%%/recipes/gimp-xcf
|
||||
%%DATADIR%%/recipes/gpl
|
||||
%%DATADIR%%/recipes/gzip
|
||||
%%DATADIR%%/recipes/jpeg-exif
|
||||
%%DATADIR%%/recipes/jpeg-jfif
|
||||
%%DATADIR%%/recipes/mbox
|
||||
%%DATADIR%%/recipes/mbox-mozilla-inbox
|
||||
%%DATADIR%%/recipes/mbox-mozilla-sent
|
||||
%%DATADIR%%/recipes/mp3-id3v1
|
||||
%%DATADIR%%/recipes/mp3-id3v2
|
||||
%%DATADIR%%/recipes/msoffice
|
||||
@ -18,12 +25,9 @@ man/man1/magicsort.1.gz
|
||||
%%DATADIR%%/recipes/perl
|
||||
%%DATADIR%%/recipes/png
|
||||
%%DATADIR%%/recipes/ppm
|
||||
%%DATADIR%%/recipes/rar
|
||||
%%DATADIR%%/recipes/sqlite
|
||||
%%DATADIR%%/recipes/zip
|
||||
%%DATADIR%%/recipes/canon-cr2
|
||||
%%DATADIR%%/recipes/flac
|
||||
%%DATADIR%%/recipes/mbox-mozilla-sent
|
||||
%%DATADIR%%/recipes/mbox-mozilla-inbox
|
||||
%%DATADIR%%/recipes/mbox
|
||||
%%DATADIR%%/tools/checkrecipe
|
||||
%%DATADIR%%/tools/elfextract.pl
|
||||
%%DATADIR%%/tools/gimp-resave.pl
|
||||
@ -37,5 +41,3 @@ man/man1/magicsort.1.gz
|
||||
%%DATADIR%%/tools/safecat
|
||||
%%DATADIR%%/tools/script_rename.pl
|
||||
%%DATADIR%%/tools/textextract
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
|
Loading…
Reference in New Issue
Block a user