unbreak port by eliminating varargs.h
informed maintainer.
This commit is contained in:
parent
3287007480
commit
7ed835d409
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91318
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= op
|
||||
PORTVERSION= 1.11
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.cerias.purdue.edu/pub/tools/%SUBDIR%/ \
|
||||
ftp://ftp.rge.com/pub/security/cerias/tools/%SUBDIR%/ \
|
||||
@ -50,10 +50,6 @@ DOC_FILES= README op.paper
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 501000
|
||||
BROKEN= "Does not compile"
|
||||
.endif
|
||||
|
||||
# Post-extract
|
||||
#
|
||||
|
||||
|
@ -1,6 +1,11 @@
|
||||
--- lex.l.orig Mon Apr 15 23:30:47 2002
|
||||
+++ lex.l Mon Apr 15 23:30:18 2002
|
||||
@@ -14,6 +14,7 @@
|
||||
--- lex.l.orig Wed Oct 15 05:58:41 2003
|
||||
+++ lex.l Wed Oct 15 06:01:15 2003
|
||||
@@ -10,10 +10,11 @@
|
||||
/* +-------------------------------------------------------------------+ */
|
||||
|
||||
#include <stdio.h>
|
||||
-#include <varargs.h>
|
||||
+#include <stdarg.h>
|
||||
#include <ctype.h>
|
||||
#include "defs.h"
|
||||
|
||||
@ -8,3 +13,26 @@
|
||||
static cmd_t *newcmd();
|
||||
char *savestr();
|
||||
|
||||
@@ -47,20 +48,15 @@
|
||||
#include <sys/stat.h>
|
||||
#include <syslog.h>
|
||||
|
||||
-msg(va_alist)
|
||||
- va_dcl
|
||||
+msg(char *s,...)
|
||||
{
|
||||
-#if 0
|
||||
va_list ap;
|
||||
- char *s;
|
||||
|
||||
- va_start(ap);
|
||||
- s = va_arg(ap, char *);
|
||||
+ va_start(ap,s);
|
||||
fprintf(stderr,"line %d: ",yyline);
|
||||
vfprintf(stderr, s, ap);
|
||||
fputc('\n', stderr);
|
||||
va_end(ap);
|
||||
-#endif
|
||||
}
|
||||
|
||||
static addarg(state, cmd, str)
|
||||
|
@ -1,6 +1,32 @@
|
||||
--- main.c.orig Tue Sep 9 01:24:31 2003
|
||||
+++ main.c Tue Sep 9 01:29:26 2003
|
||||
@@ -448,29 +448,17 @@
|
||||
--- main.c.orig Wed Oct 15 05:58:41 2003
|
||||
+++ main.c Wed Oct 15 06:02:22 2003
|
||||
@@ -9,7 +9,7 @@
|
||||
/* +-------------------------------------------------------------------+ */
|
||||
|
||||
#include <stdio.h>
|
||||
-#include <varargs.h>
|
||||
+#include <stdarg.h>
|
||||
#include <syslog.h>
|
||||
#include <pwd.h>
|
||||
#include <grp.h>
|
||||
@@ -170,14 +170,11 @@
|
||||
return Go(new, num, argc, argv);
|
||||
}
|
||||
|
||||
-fatal(va_alist)
|
||||
- va_dcl
|
||||
+fatal(char *s,...)
|
||||
{
|
||||
va_list ap;
|
||||
- char *s;
|
||||
|
||||
- va_start(ap);
|
||||
- s = va_arg(ap, char *);
|
||||
+ va_start(ap,s);
|
||||
vfprintf(stderr, s, ap);
|
||||
fputc('\n', stderr);
|
||||
va_end(ap);
|
||||
@@ -448,29 +445,17 @@
|
||||
char *cp, *np;
|
||||
struct passwd *pw;
|
||||
struct group *gr;
|
||||
@ -32,7 +58,7 @@
|
||||
gidset[ngroups++] = gr->gr_gid;
|
||||
}
|
||||
if (ngroups == 0)
|
||||
@@ -533,6 +521,18 @@
|
||||
@@ -533,6 +518,18 @@
|
||||
new_envp[curenv++] = environ[i];
|
||||
}
|
||||
new_envp[curenv] = NULL;
|
||||
|
Loading…
Reference in New Issue
Block a user