- Some demos need to be linked against libm.so
Approved by: maintainer
This commit is contained in:
parent
22fe0a57bf
commit
7e933d9737
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=370775
@ -1,5 +1,23 @@
|
||||
--- demo/CMakeLists.txt.orig 2013-11-18 14:51:59.000000000 +0100
|
||||
+++ demo/CMakeLists.txt 2013-11-18 14:52:21.000000000 +0100
|
||||
--- demo/CMakeLists.txt.orig 2013-10-30 14:11:59.000000000 +0100
|
||||
+++ demo/CMakeLists.txt 2014-10-13 10:52:19.000000000 +0200
|
||||
@@ -61,7 +61,7 @@
|
||||
# =======================================================================
|
||||
foreach(demo ${demos_NAMES})
|
||||
add_executable(${demo} ${demo}.c)
|
||||
- target_link_libraries(${demo} ${_LIBHPDF_LIB})
|
||||
+ target_link_libraries(${demo} ${_LIBHPDF_LIB} m)
|
||||
if(DEMO_C_FLAGS)
|
||||
set_target_properties(${demo} PROPERTIES COMPILE_FLAGS ${DEMO_C_FLAGS})
|
||||
endif(DEMO_C_FLAGS)
|
||||
@@ -70,7 +70,7 @@
|
||||
# some demos need grid_sheet.c compiled in
|
||||
foreach(demo ${demos_with_grid_NAMES})
|
||||
add_executable(${demo} ${demo}.c grid_sheet.c)
|
||||
- target_link_libraries(${demo} ${_LIBHPDF_LIB})
|
||||
+ target_link_libraries(${demo} ${_LIBHPDF_LIB} m)
|
||||
if(DEMO_C_FLAGS)
|
||||
set_target_properties(${demo} PROPERTIES COMPILE_FLAGS ${DEMO_C_FLAGS})
|
||||
endif(DEMO_C_FLAGS)
|
||||
@@ -75,6 +75,7 @@
|
||||
set_target_properties(${demo} PROPERTIES COMPILE_FLAGS ${DEMO_C_FLAGS})
|
||||
endif(DEMO_C_FLAGS)
|
||||
|
Loading…
Reference in New Issue
Block a user