Adding toxic, the CLI front-end for Tox.

This commit is contained in:
Thierry Thomas 2014-05-08 19:39:33 +00:00
parent f061d99981
commit 7e8980cc38
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=353348
7 changed files with 75 additions and 0 deletions

View File

@ -166,6 +166,7 @@
SUBDIR += tkabber-plugins
SUBDIR += tkabbur
SUBDIR += tox
SUBDIR += toxic
SUBDIR += ttytter
SUBDIR += turpial
SUBDIR += twirssi

36
net-im/toxic/Makefile Normal file
View File

@ -0,0 +1,36 @@
# Created by: Thierry Thomas <thierry@pompo.net>
# $FreeBSD$
PORTNAME= toxic
PORTVERSION= 0.3.3.140508
CATEGORIES= net-im
MAINTAINER= thierry@FreeBSD.org
COMMENT= A console client for Tox
LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= tox
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= af09961
WRKSRC= ${WRKDIR}/Tox-${PORTNAME}-${GH_COMMIT}
SUB_FILES= pkg-message
USES= ncurses:port pkgconfig
USE_AUTOTOOLS= autoconf aclocal
run-autotools:
cd ${CONFIGURE_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${AUTORECONF} -if
post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/misc/toxic.conf ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>

2
net-im/toxic/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (toxic-0.3.3.140508.tar.gz) = 2196aeac8f0e938d3214df627ae8606378ebdcf3d00fb47c5b8a2535d8d8b5b5
SIZE (toxic-0.3.3.140508.tar.gz) = 76206

View File

@ -0,0 +1,11 @@
--- src/main.c.orig 2014-04-20 22:43:14.000000000 +0200
+++ src/main.c 2014-04-21 12:44:27.000000000 +0200
@@ -169,6 +169,8 @@
#ifdef __linux__
tox_set_name(m, (uint8_t *) "Cool guy", strlen("Cool guy"));
+#elif defined(__FreeBSD__)
+ tox_set_name(m, (uint8_t *) "Very cool guy", strlen("Very cool guy"));
#elif defined(_WIN32)
tox_set_name(m, (uint8_t *) "I should install GNU/Linux", strlen("I should install GNU/Linux"));
#elif defined(__APPLE__)

View File

@ -0,0 +1,14 @@
===============================================================================
+ toxic is set for IPv6 by default; if you have no IPv6 connectivity, try
toxic -4
+ if your screen is unreadable, try to set
colour_theme:1;
in your ~/.config/tox/toxic.conf
(more parameters available - see %%EXAMPLESDIR%%/toxic.conf )
or try to define another TERM, e.g.:
TERM=vt100 toxic
===============================================================================

6
net-im/toxic/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
Toxic, sometimes referred to as Tox/Toxic or the purged Core/Toxic, is the
reference CLI front-end written for the Tox core.
It uses the ncurses library.
WWW: http://tox.im/

5
net-im/toxic/pkg-plist Normal file
View File

@ -0,0 +1,5 @@
bin/toxic
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/toxic.conf
%%DATADIR%%/DHTnodes
@dirrm %%DATADIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%