- Update to version 0.5 which is compatible with modern OpenSSL

- Hook provided test suite (albeit rather small) to our framework
This commit is contained in:
Alexey Dokuchaev 2020-09-02 07:17:29 +00:00
parent 114a831ecb
commit 7e62b0d011
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=547334
4 changed files with 7 additions and 29 deletions

View File

@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= tcpcrypt
PORTVERSION= 0.5
DISTVERSIONPREFIX= v
DISTVERSION= 0.3-rc1
CATEGORIES= security net
MAINTAINER= jmg@FreeBSD.org
@ -20,15 +20,9 @@ USES= autoreconf libtool ssl
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
INSTALL_TARGET= install-strip
TEST_TARGET= check
USERS= tcpcryptd
GROUPS= tcpcryptd
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT} == base
BROKEN_FreeBSD_12= incomplete definition of type 'struct rsa_st'
BROKEN_FreeBSD_13= incomplete definition of type 'struct rsa_st'
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (scslab-tcpcrypt-v0.3-rc1_GH0.tar.gz) = 4a139da6a8768ca0ab24968a546dfea23c63e8d3d566b342f27e9674a3ebe9cc
SIZE (scslab-tcpcrypt-v0.3-rc1_GH0.tar.gz) = 183008
TIMESTAMP = 1468561049
SHA256 (scslab-tcpcrypt-v0.5_GH0.tar.gz) = 251213be8bfd0b9224f4d8d7a79fe1b8961a180f5a278f128376a66364a38ea3
SIZE (scslab-tcpcrypt-v0.5_GH0.tar.gz) = 824288

View File

@ -1,17 +0,0 @@
--- src/unix.c.orig 2014-09-10 16:22:26.000000000 -0700
+++ src/unix.c 2014-10-31 23:59:29.000000000 -0700
@@ -57,7 +57,13 @@
s_in.sin_addr = ip->ip_dst;
s_in.sin_port = tcp->th_dport;
-#if defined(__FreeBSD__) || defined(__DARWIN_UNIX03)
+#if defined(__FreeBSD__)
+#include <osreldate.h>
+#if __FreeBSD_version < 1000022
+ #define HO_LEN
+#endif
+#endif
+#ifdef __DARWIN_UNIX03
#define HO_LEN
#endif
#ifdef HO_LEN

View File

@ -1,6 +1,6 @@
bin/tcnetstat
bin/tcpcryptd
include/tcpcrypt/socket_address.h
bin/tcs
include/tcpcrypt/tcpcrypt.h
lib/libtcpcrypt.a
lib/libtcpcrypt.so